why are my arps failing?

alliasneoalliasneo Posts: 186Member

Hi everyone,I've been messing around with VLAN's and have created the attached network. I got everything up and running did my router on a stick configuration and everything works fine. But, I decided right ok rather than have my vlan 20 in the middle go to the left of the router on FA0/0.20 I would disable this interface and remove the ip address. I created a new sub interface on FA0/1.20 with the ip address of the default gateway for VLAN 20. I flushed the arp cache from the PC's in VLAN 20 as they would be trying to send packets to FA0/0 still right? but now when I try and ping anything other than VLAN 20 PC's the ARP fails completely. Any ideas? Thanks

Comments

  • mark_s0mark_s0 Posts: 82Member ■■□□□□□□□□
    Is the fa0/1.20 interface configured with encapsulation type and vlan after you changed it? And i'm assuming the link between the switch and that interface is a trunk link?
  • PristonPriston Posts: 999Member ■■■■□□□□□□
    can we see the router config?
    A.A.S. in Networking Technologies
    A+, Network+, CCNA
  • dustinmurphydustinmurphy Posts: 170Member
    Did you switch the cable to Fa0/1 ? I'm just shooting out an idea here, but Fa0/0.20 is on a completely different physical interface than Fa0/1.20...

    I would also assume you have the switchport set to either a trunk with VLAN 20 added OR you have the switchport in Access mode for VLAN 20... plugged into the Fa0/1 port on the router? Also, as mark_s0 said... make sure you're using the right encapsulation... and set the vlan on the interface to 20. ;)

    Edit: looking at your topology, the switchport should be in trunk mode with VLAN 20 configured on it. If you have not changed the cabling, I'd assume that may be where your issue lies.
  • cisco_troopercisco_trooper Posts: 1,439Member ■■■■□□□□□□
    Dont forget there are arp tables and cam tables on the network equipment itself to worry about...
  • drkatdrkat Posts: 703Banned
    I'd say show us the configs because it could be a number of things. Was everything reachable before the switch to fa0/1?
    Married to the game but she broke her vows. That's why my bars are full of broken bottles And my night stands are full of open bibles
  • alliasneoalliasneo Posts: 186Member
    Thanks so much for all the help everyone. The config for the router is below, I can include the switches as well if that would help. I have also tried to ping from vlan 30 to vlan 20 and get a destination unreachable:

    Ping from PC4 in VLAN 30 - to PC6 in VLAN 20 in the middle.


    The pings from VLAN 20 though, if I open the command line on a PC and try to ping the default gateway or any other VLAN the ping fails at the PC and says the arp process timed out. I mean maybe it is a packet tracer fault but I hope it isn't really as I would like to get to the bottom of this.


    ____________________________

    Router#sh run
    Building configuration...

    Current configuration : 795 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.1
    encapsulation dot1Q 10
    ip address 192.168.0.254 255.255.255.0
    !
    interface FastEthernet0/0.20
    encapsulation dot1Q 20
    no ip address
    shutdown
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.20
    encapsulation dot1Q 20
    ip address 172.168.255.254 255.255.255.0
    !
    interface FastEthernet0/1.30
    encapsulation dot1Q 30
    ip address 10.10.10.254 255.255.255.0
    !
    interface Vlan1
    no ip address
    shutdown
    !
    ip classless
    !
    line con 0
    line vty 0 4
    login
    !
    End
    !
    Router#sh ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 1 subnets
    C 10.10.10.0 is directly connected, FastEthernet0/1.30
    172.168.0.0/24 is subnetted, 1 subnets
    C 172.168.255.0 is directly connected, FastEthernet0/1.20
    C 192.168.0.0/24 is directly connected, FastEthernet0/0.1
    Router#


    _____________________________


    thanks again.
  • mark_s0mark_s0 Posts: 82Member ■■□□□□□□□□
    Your fa0/1.20 subnet mask is 255.255.255.0 where as your hosts subnet mask says 255.255.0.0 which if that's right might be causing the issue you're having as the hosts would be on a different subnet to the router interface.
  • alliasneoalliasneo Posts: 186Member
    mark_s0 your a genius. I changed the subnet mask to 255.255.0.0 and this all works now. How come though? I understand it would be on a different subnet but would this really cause the arp's to fail?

    thanks again to everyone for the help
  • networker050184networker050184 Posts: 11,962Mod Mod
    If the subnet doesn't match the router isn't going to try and arp out that interface.
    An expert is a man who has made all the mistakes which can be made.
Sign In or Register to comment.