ldp-tunneling with hidden route in table inet.3

koala0808koala0808 Registered Users Posts: 6 ■□□□□□□□□□
Hi mates,

im experiencing an issue regarding ldp-tunneling.

The question is why some hidden routes will be generated within inet.3 routing table when ldp-tunneling is cofigurated within the LSP.

When I deactive the ldp-tunneling, the hidden routes within inet.3 are gone.

could any experts bring me some light on this?


Thanks in advance.



Kind regards
Leo Gu

Comments

  • Ryan82Ryan82 Member Posts: 428
    I'm not an expert by any means but I will try to help :)

    Might be easier to deduce if you provided a diagram and relevent configurations. Are the hidden routes from the ldp portion of your network on the other end of your RSVP network?

    What routes does this reveal: sh route table inet.3 hidden
  • koala0808koala0808 Registered Users Posts: 6 ■□□□□□□□□□
    Many thanks for your kind reply, Ryan82.
    Here is the Topo(P518/868_Using LDP through an RSVP Network in JNCIS_studyguide):
    -wIG8zNE7G4FpMWuNVRjx3ZFQTUN_NsADfeQiWZLawhBiloZgEFDrO6Np9eV0Mlz0ZDkFsyOUUZYajawPK0hcZASgzNUsjuZ37k=w1024
    And below is the output of "show":
    ================
    [edit]
    [email protected]# run show route hidden logical-router r3


    inet.0: 21 destinations, 21 routes (21 active, 0 holddown, 0 hidden)


    inet.3: 8 destinations, 12 routes (5 active, 0 holddown, 6 hidden)
    + = Active Route, - = Last Active, * = Both


    4.4.4.4/32 [OSPF] 00:03:44, metric 3
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4
    5.5.47.0/24 [OSPF] 00:03:44, metric 4
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4
    5.5.48.0/24 [OSPF] 00:03:39, metric 4
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4
    5.5.78.0/24 [OSPF] 00:03:44, metric 5
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4
    7.7.7.7/32 [OSPF] 00:03:44, metric 4
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4
    8.8.8.8/32 [OSPF] 00:03:39, metric 4
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4


    mpls.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
    ================

    ================
    [edit]
    [email protected]# run show route hidden logical-router r3 detail 4.4.4.4


    inet.3: 8 destinations, 12 routes (5 active, 0 holddown, 6 hidden)
    4.4.4.4/32 (3 entries, 2 announced)
    State: <FlashAll>
    OSPF
    Next hop type: Router
    Next-hop reference count: 10
    Next hop: 5.5.13.1 via fxp2.13 weight 0x1, selected
    Label-switched-path r3->r4
    Label operation: Push 100016
    State: <Hidden Int>
    Inactive reason: Unusable path
    Local AS: 65412
    Age: 4:26 Metric: 3
    Area: 0.0.0.0
    Task: OSPFv2
    Announcement bits (1): 1-LDP
    AS path: I
    ================

    Above test has been done on my simulator and M5, whereas I encountered the same issue.


    Thanks.
  • koala0808koala0808 Registered Users Posts: 6 ■□□□□□□□□□
    Hi Ryan82,

    Here you go the whole config which provides you with the interface and protocols configured:
    =======================
    [email protected]# show | no-more
    ## Last changed: 2011-12-11 19:11:28 UTC
    version 8.5R1.14;
    system {
    host-name test;
    domain-name MNCIF.net;
    root-authentication {
    encrypted-password "$1$o455j.US$XoiGr8tFjIBGwU4dRT7KT1"; ## SECRET-DATA
    }
    syslog {
    user * {
    any emergency;
    }
    file messages {
    any notice;
    authorization info;
    }
    file interactive-commands {
    interactive-commands any;
    }
    }
    }
    logical-routers {
    r1 {
    interfaces {
    fxp1 {
    unit 12 {
    vlan-id 12;
    family inet {
    address 5.5.12.1/24;
    }
    family mpls;
    }
    unit 13 {
    vlan-id 13;
    family inet {
    address 5.5.13.1/24;
    }
    family mpls;
    }
    }
    lo0 {
    unit 1 {
    family inet {
    address 1.1.1.1/32;
    }
    }
    }
    }
    protocols {
    rsvp {
    interface all;
    }
    mpls {
    inactive: no-propagate-ttl;
    interface all;
    }
    ospf {
    traffic-engineering;
    area 0.0.0.0 {
    interface fxp1.12;
    interface fxp1.13;
    interface lo0.1;
    }
    }
    }
    routing-options {
    router-id 1.1.1.1;
    autonomous-system 65412;
    }
    }
    r2 {
    interfaces {
    fxp1 {
    unit 24 {
    vlan-id 24;
    family inet {
    address 5.5.24.2/24;
    }
    family mpls;
    }
    }
    fxp2 {
    unit 12 {
    vlan-id 12;
    family inet {
    address 5.5.12.2/24;
    }
    family mpls;
    }
    }
    lo0 {
    unit 2 {
    family inet {
    address 2.2.2.2/32;
    }
    }
    }
    }
    protocols {
    rsvp {
    interface all;
    }
    mpls {
    inactive: no-propagate-ttl;
    interface all;
    }
    ospf {
    traffic-engineering;
    area 0.0.0.0 {
    interface fxp1.24;
    interface fxp2.12;
    interface lo0.2;
    }
    }
    }
    routing-options {
    router-id 2.2.2.2;
    autonomous-system 65412;
    }
    }
    r3 {
    interfaces {
    fxp1 {
    inactive: unit 34 {
    vlan-id 34;
    family inet {
    address 5.5.34.3/24;
    }
    family mpls;
    }
    unit 35 {
    vlan-id 35;
    family inet {
    address 5.5.35.3/24;
    }
    family mpls;
    }
    unit 36 {
    vlan-id 36;
    family inet {
    address 5.5.36.3/24;
    }
    family mpls;
    }
    }
    fxp2 {
    unit 13 {
    vlan-id 13;
    family inet {
    address 5.5.13.3/24;
    }
    family mpls;
    }
    }
    lo0 {
    unit 3 {
    family inet {
    address 3.3.3.3/32;
    }
    }
    }
    }
    protocols {
    rsvp {
    interface fxp2.13;
    }
    mpls {
    inactive: no-propagate-ttl;
    label-switched-path r3->r4 {
    from 3.3.3.3;
    to 4.4.4.4;
    ldp-tunneling;
    adaptive;
    primary r3r4;
    }
    path r3r4 {
    5.5.13.1 strict;
    5.5.12.2 strict;
    }
    interface fxp2.13;
    interface fxp1.35;
    interface fxp1.36;
    }
    ospf {
    traffic-engineering;
    area 0.0.0.0 {
    interface fxp1.35;
    interface fxp1.36;
    interface lo0.3;
    interface fxp2.13;
    }
    }
    ldp {
    interface fxp1.35;
    interface fxp1.36;
    interface lo0.3;
    }
    }
    routing-options {
    router-id 3.3.3.3;
    autonomous-system 65412;
    }
    }
    r4 {
    interfaces {
    fxp1 {
    unit 47 {
    vlan-id 47;
    family inet {
    address 5.5.47.4/24;
    }
    family mpls;
    }
    unit 48 {
    vlan-id 48;
    family inet {
    address 5.5.48.4/24;
    }
    family mpls;
    }
    }
    fxp2 {
    unit 24 {
    vlan-id 24;
    family inet {
    address 5.5.24.4/24;
    }
    family mpls;
    }
    inactive: unit 34 {
    vlan-id 34;
    family inet {
    address 5.5.34.4/24;
    }
    family mpls;
    }
    }
    lo0 {
    unit 4 {
    family inet {
    address 4.4.4.4/32;
    }
    }
    }
    }
    protocols {
    rsvp {
    interface fxp2.24;
    }
    mpls {
    inactive: no-propagate-ttl;
    inactive: explicit-null;
    label-switched-path r4->r3 {
    from 4.4.4.4;
    to 3.3.3.3;
    ldp-tunneling;
    primary r4r3;
    }
    path r4r3 {
    5.5.24.2 strict;
    5.5.12.1 strict;
    }
    interface fxp2.24;
    interface fxp1.47;
    interface fxp1.48;
    }
    ospf {
    traffic-engineering;
    area 0.0.0.0 {
    interface lo0.4;
    interface fxp2.24;
    }
    area 0.0.1.222 {
    interface fxp1.47;
    interface fxp1.48;
    }
    }
    ldp {
    interface fxp1.47;
    interface fxp1.48;
    interface lo0.4;
    }
    }
    routing-options {
    router-id 4.4.4.4;
    autonomous-system 65412;
    }
    }
    r5 {
    interfaces {
    fxp1 {
    unit 56 {
    vlan-id 56;
    family inet {
    address 5.5.56.5/24;
    }
    family mpls;
    }
    }
    fxp2 {
    unit 35 {
    vlan-id 35;
    family inet {
    address 5.5.35.5/24;
    }
    family mpls;
    }
    }
    lo0 {
    unit 5 {
    family inet {
    address 5.5.5.5/32;
    }
    }
    }
    }
    protocols {
    mpls {
    interface all;
    }
    ospf {
    area 0.0.0.0 {
    interface all;
    }
    }
    ldp {
    interface all;
    }
    }
    routing-options {
    router-id 5.5.5.5;
    autonomous-system 65412;
    }
    }
    r6 {
    interfaces {
    fxp2 {
    unit 36 {
    vlan-id 36;
    family inet {
    address 5.5.36.6/24;
    }
    family mpls;
    }
    unit 56 {
    vlan-id 56;
    family inet {
    address 5.5.56.6/24;
    }
    family mpls;
    }
    }
    lo0 {
    unit 6 {
    family inet {
    address 6.6.6.6/32;
    }
    }
    }
    }
    protocols {
    mpls {
    interface all;
    }
    ospf {
    area 0.0.0.0 {
    interface all;
    }
    }
    ldp {
    interface all;
    }
    }
    routing-options {
    router-id 6.6.6.6;
    autonomous-system 65412;
    }
    }
    r7 {
    interfaces {
    fxp1 {
    unit 78 {
    vlan-id 78;
    family inet {
    address 5.5.78.7/24;
    }
    family mpls;
    }
    }
    fxp2 {
    unit 47 {
    vlan-id 47;
    family inet {
    address 5.5.47.7/24;
    }
    family mpls;
    }
    }
    lo0 {
    unit 7 {
    family inet {
    address 7.7.7.7/32;
    }
    }
    }
    }
    protocols {
    mpls {
    interface all;
    }
    ospf {
    area 0.0.1.222 {
    interface all;
    }
    }
    ldp {
    interface all;
    }
    }
    routing-options {
    router-id 7.7.7.7;
    autonomous-system 65412;
    }
    }
    r8 {
    interfaces {
    fxp2 {
    unit 48 {
    vlan-id 48;
    family inet {
    address 5.5.48.8/24;
    }
    family mpls;
    }
    unit 78 {
    vlan-id 78;
    family inet {
    address 5.5.78.8/24;
    }
    family mpls;
    }
    }
    lo0 {
    unit 8 {
    family inet {
    address 8.8.8.8/32;
    }
    }
    }
    }
    protocols {
    mpls {
    interface all;
    }
    ospf {
    area 0.0.1.222 {
    interface all;
    }
    }
    ldp {
    interface all;
    }
    }
    policy-options {
    policy-statement static {
    term 1 {
    from {
    protocol static;
    route-filter 192.168.0.0/16 orlonger;
    }
    then accept;
    }
    }
    }
    routing-options {
    static {
    route 192.168.1.0/24 reject;
    }
    router-id 8.8.8.8;
    autonomous-system 65412;
    }
    }
    }
    interfaces {
    fxp0 {
    vlan-tagging;
    }
    fxp1 {
    vlan-tagging;
    }
    fxp2 {
    vlan-tagging;
    }
    fxp3 {
    vlan-tagging;
    }
    lo0 {
    unit 0;
    }
    }


    [edit]


    =======================


    Thanks.


    Kind regards
    Leo Gu
  • koala0808koala0808 Registered Users Posts: 6 ■□□□□□□□□□
    I think this issue is due to the command "ldp-tunneling".
    When I delete/deactive "ldp-tunneling" on r3, the hidden routes within inet.3 routing table of r3 are gone.


    PS: the same situation are the same on r4.




    ========================
    [edit]
    [email protected]# show logical-routers r3 protocols mpls
    inactive: no-propagate-ttl;
    label-switched-path r3->r4 {
    from 3.3.3.3;
    to 4.4.4.4;
    ldp-tunneling;
    adaptive;
    primary r3r4;
    }
    path r3r4 {
    5.5.13.1 strict;
    5.5.12.2 strict;
    }
    interface fxp2.13;
    interface fxp1.35;
    interface fxp1.36;
    ========================


    ========================
    [email protected]# run show route hidden logical-router r3


    inet.0: 21 destinations, 21 routes (21 active, 0 holddown, 0 hidden)


    inet.3: 8 destinations, 12 routes (5 active, 0 holddown, 6 hidden)
    + = Active Route, - = Last Active, * = Both


    4.4.4.4/32 [OSPF] 00:00:13, metric 3
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4
    5.5.47.0/24 [OSPF] 00:00:13, metric 4
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4
    5.5.48.0/24 [OSPF] 00:00:13, metric 4
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4
    5.5.78.0/24 [OSPF] 00:00:13, metric 5
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4
    7.7.7.7/32 [OSPF] 00:00:13, metric 4
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4
    8.8.8.8/32 [OSPF] 00:00:13, metric 4
    > to 5.5.13.1 via fxp2.13, label-switched-path r3->r4


    mpls.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
    ========================


    ========================
    [edit]
    [email protected]# show logical-routers r3 protocols mpls
    inactive: no-propagate-ttl;
    label-switched-path r3->r4 {
    from 3.3.3.3;
    to 4.4.4.4;
    inactive: ldp-tunneling;
    adaptive;
    primary r3r4;
    }
    path r3r4 {
    5.5.13.1 strict;
    5.5.12.2 strict;
    }
    interface fxp2.13;
    interface fxp1.35;
    interface fxp1.36;
    ========================


    ========================
    [edit]
    [email protected]# run show route hidden logical-router r3


    inet.0: 21 destinations, 21 routes (21 active, 0 holddown, 0 hidden)


    inet.3: 3 destinations, 3 routes (3 active, 0 holddown, 0 hidden)


    mpls.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
    ========================




    Thanks.




    Kind regards
    Leo Gu
  • AldurAldur Juniper Moderator Member Posts: 1,460
    It's been a while since I've done LDP tunneling but I think I ran into a similar issue a while back. If I recall correctly the routes were being hidden that I wanted to use for LDP tunneling because LDP didn't see it as the shortest path, as the IGP was reporting to it.

    I don't know if this is the same situation as yours, but just might be :)
    "Bribe is such an ugly word. I prefer extortion. The X makes it sound cool."

    -Bender
Sign In or Register to comment.