No RIP Routing updates

alliasneoalliasneo Member Posts: 186

Hi Everyone,

I've been working on the above and adding to it over time. I've just implemented RIP version 2 to all routers but I'm not getting any routing updates sent through. I'm only just getting to grips with WAN technologies so it's obviously something I'm missing. I'm guessing it's to do with the PPP authentication or something? But even though I added broadcast to my frame relay config it's not sending any rip updates there?



  • hiddenknight821hiddenknight821 Member Posts: 1,209 ■■■■■■□□□□
    I believe split horizon on multipoint subinterfaces are enabled by default. So try "no ip split-horizon" command in global configuration mode on the hub in the hub-and-spokes topology and go see if that works.
  • pham0329pham0329 Member Posts: 556
    ^^ what he said. no ip-split horizon is an interface level command though
  • MrBrianMrBrian Member Posts: 520
    Is the serial link between R1 and R3 up/up and you can ping across? If so, did you turn off auto-summary? Cause I don't think R1 will receive the /29 network off of R3 if auto-summary is on.. it would want to advertise /8 over to R1, but it wouldn't go through (I think).

    Also check R3's routing table to make sure you're getting the networks off of R1. If R3 and R1 are exchanging their networks properly, than at least you know you have RIP working ok across that connection.

    If R3 has the networks, but isn't passing them to its spoke routers, then try disabling split-horizon like the others said.
    Currently reading: Internet Routing Architectures by Halabi
  • Ltat42aLtat42a Member Posts: 587 ■■■□□□□□□□
    Have you tried running debug yet??
  • MrBrianMrBrian Member Posts: 520
    Correction to one thing I said earlier..

    As long as you're using version 2, auto-summary won't prevent anything within your topology. Even if you have auto-summary enabled for RIP, R1 would still receive the subnet from R3.. This is because the network connecting R1 and R3 is a subnet of the same classful network ( so even though auto-summary would be enabled, R3 advertises to R1.
    Currently reading: Internet Routing Architectures by Halabi
  • alliasneoalliasneo Member Posts: 186
    Fantastic, thanks to hiddenknight821 and pham0329. the no ip split horizon command worked a treat on the int s0/0 command and both R4 and R5 now have RIP routes.

    and I just had a major brain storm moment where I realised I deleted a router in between R1 and R3 (I had an R2 before) and connected these together and I haven't configured PPP on the R3 serial interface. Hopefully if I get this going correctly it will resolve this.

    Packet Tracer is misleading because it shows the little green light and it all looks ok. After I've configured it here I think I'll fire up my real kit and get it going....
Sign In or Register to comment.