Switch remote access
I'm having a problem gaining access to some new 2950s that I setup. I have a set IP address for all of them & I used the following code to setup access.
(config)#line console 0
(config-line)#password <console password>
(config-line)#login
(config)#line vty 0 4
(config-line)#password <telnet password>
(config-line)#login
(config)#line console 0
(config-line)#password <console password>
(config-line)#login
(config)#line vty 0 4
(config-line)#password <telnet password>
(config-line)#login
Comments
-
keenon Member Posts: 1,922 ■■■■□□□□□□what are u getting when trying to login? do u have the switch config to post?Become the stainless steel sharp knife in a drawer full of rusty spoons
-
garv221 Member Posts: 1,914keenon wrote:what are u getting when trying to login? do u have the switch config to post?
Well what I get is nothing. I telnet to all of my switches from the main 4503 router. This new batch of switches are set up correctly but I cannot even connect? I'm pretty sure I'm missing something on the router. Heres a switch though. (passwords have been changed) I added VLAN254 after I added this config. So the DB is on the switch.
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname vab-build13-2950c-1
!
enable password 5 84415m15hj48g4jr12
!
ip subnet-zero
!
no ip domain-lookup
vtp domain adgvtp
vtp mode transparent
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
vlan 913
!
interface FastEthernet0/1
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/7
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/8
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/10
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/11
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/12
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/13
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/14
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/18
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/19
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/20
switchport access vlan 913
switchport protected
speed 10
duplex half
!
interface FastEthernet0/21
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/22
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/23
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/24
switchport access vlan 913
switchport protected
speed 10
duplex half
spanning-tree portfast
!
interface FastEthernet0/25
switchport mode trunk
!
interface FastEthernet0/26
switchport mode trunk
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan254
ip address 192.168.254.48 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.254.1
ip http server
!
line con 0
password 7 044gfg48451n15
login
line vty 0 4
password 7 044gfg48451n15
login
line vty 5 15
password 7 45g5n151n5n11n
login
!
!
end -
keenon Member Posts: 1,922 ■■■■□□□□□□does the router and switch share the same address space aka same network?
is the router on an access port or trunk port?Become the stainless steel sharp knife in a drawer full of rusty spoons -
garv221 Member Posts: 1,914The router shares same address space & all the switches are connected via Fiber on trunk mode. The router is all static routes & there is an interface setup for vlan254 which is the telnet vlan.
-
keenon Member Posts: 1,922 ■■■■□□□□□□post router config
also can u ping the switch or see it in cdpBecome the stainless steel sharp knife in a drawer full of rusty spoons -
Drakonblayde Member Posts: 542Is your router setup to do intervlan routing? And have you tried setting the IP on Vlan1 instead of Vlan254 to see if you can access it that way? I've always used Vlan1 as my management vlan, and I've never had a problem reaching the router that way. Otherwise, you are gonna have to configure the router to route for vlan254= Marcus Drakonblayde
================
CCNP-O-Meter:
=[0%]==[25%]==[50%]==[75%]==[100%]
==[X]===[X]====[ ]=====[ ]====[ ]==
=CCNA==BSCI==BCMSN==BCRAN==CIT= -
tunerX Member Posts: 447 ■■■□□□□□□□If the 4503 has an interface in vlan 254 and all of your switches are successfully trunking then there should not be any problems.
The only problem I could see is if you have vlan 254 set up as the native vlan, and are inconsistent with tagging the native vlan. -
garv221 Member Posts: 1,914I can ping the router.
The router is setup to do intervlan routing. It is routing about another 20 vlans. From the switch I can get internet access with the dhcp pool I created for that vlan. I have not tried vlan1, I have not created an interface for it on the router, only 254. All the other switches run fine with this interface 254.
TurnerX- What do you mean by native vlan 254? -
tunerX Member Posts: 447 ■■■□□□□□□□The native vlan will not have a tag unless you specify that it carries it. If one switch is expecting a 254 tag in the vlan portion of the header but the other side does not put it in (because it is native, without tagging) then those two sections of the vlan will be disjoined.
-
garv221 Member Posts: 1,914tunerX wrote:The native vlan will not have a tag unless you specify that it carries it. If one switch is expecting a 254 tag in the vlan portion of the header but the other side does not put it in (because it is native, without tagging) then those two sections of the vlan will be disjoined.
Gotcha! Thanks. I'm heading to the remote location tommorow to troubleshoot all this, I'll let you all know how it comes out. Thanks! -
garv221 Member Posts: 1,914garv221 wrote:So the DB is on the switch.
Ha. Famous last words. It was on none of the 14 switches. I forgot to add them, it took about 1 mintute to realize this. So did the state active command. What I did was created a template of the config & just changed telnet psswd & address & vlan a copied it to all the switches about 4 months ago but forgot to make the vlan 254 DB. Thanks for the help.