PuTTY Default Configuration

CiscoCertsCiscoCerts Posts: 112Member
Hello Fellow CCNP'rs

Today I've been messing around with the default putty configurations - and I can't for the life of me figure out this one particular setting...

Catagory>Window I have increased the starting size from 24 rows and 80 columns to 48/85 respectively to fit all the Cisco cmds in a nice tight fit, however when I go and run a log command... for example Show Running-config PuTTY only displays 24 lines at a time and I have to keep parsing through the spacebar. Please tell me there is a way to change this default.

PS
Normally I use ZOC and have no issues with this, but would also like to be comfortable with PuTTY, as I can't seem to get ZOC to work with GNS3 happily.

Thanks in advance,
CiscoCerts

Comments

  • networker050184networker050184 Posts: 11,962Mod Mod
    Just do a term length 0 from the cli and it will spit it all out. As far as I know its not your PuTTY config that handles this.
    An expert is a man who has made all the mistakes which can be made.
  • CiscoCertsCiscoCerts Posts: 112Member
    Just do a term length 0 from the cli and it will spit it all out. As far as I know its not your PuTTY config that handles this.
    AWESOME!! Thank you very much good Sir. I will be adding this to my standard 'lab commands'.
  • networker050184networker050184 Posts: 11,962Mod Mod
    CiscoCerts wrote: »
    AWESOME!! Thank you very much good Sir. I will be adding this to my standard 'lab commands'.

    Also a good first command in scripts to gather output!
    An expert is a man who has made all the mistakes which can be made.
  • CiscoCertsCiscoCerts Posts: 112Member
    Show terminal is also helpful in matching up a terminal emulator with what is already set on the router/switch
    Router#show term
    Line 514, Location: "", Type: "vt220"
    Length: 73 lines, Width: 114 columns
    Baud rate (TX/RX) is 9600/9600
    Status: PSI Enabled, Ready, Active, No Exit Banner, Automore On
      Notify Process
    Capabilities: none
    Modem state: Ready
    Group codes:    0
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none
    Timeouts:      Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
                   00:10:00       00:15:00                       none     not set
                                Idle Session Disconnect Warning
                                  never
                                Login-sequence User Response
                                 00:00:30
                                Autoselect Initial Wait
                                  not set
    Modem type is unknown.
    Session limit is not set.
    Time since activation: 00:07:47
    Editing is enabled.
    History is enabled, history size is 20.
    DNS resolution in show commands is enabled
    Full user help is disabled
    Allowed input transports are ssh.
    Allowed output transports are lat pad telnet rlogin lapb-ta mop v120 ssh.
    Preferred transport is none.
    No output characters are padded
    No special data dispatching characters 
    
Sign In or Register to comment.