Connecting Vista computer to Samba File Server

mishymishy Member Posts: 209 ■■■□□□□□□□
My Win Vista Home premium will not connect to my Samba File Server so I can view the folders and files. I am able to connect to the fileserver from Vista for the Webmin and Extplorer but I cannot access it from Run> \\ipaddress. I am getting server cannot be accessed.

I have looked at other forums that suggest changing the (LSA) Sercurity level from 3 to 1 in the registry and done that but still has solved my problem. ( HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\)

Is there any way I can get my Vista Home Premium to connect to the file server so I can upload files?

Also where do I create a folder so that it can be accessed and used for just st

Comments

  • megatran808megatran808 Member Posts: 53 ■■■□□□□□□□
    Did you check your iptables or firewall settings on your Samba server?
    List of ports is in this link
    What ports need to be open for Samba to communicate with other windows/linux systems?

    Also did you verify the service is running smbd or nmbd?

    On your windows machine you shouldnt have to mess the registry. It should just connect via \\ipaddress.
    "Love your Job, but never fall in love with your company....because you never know when your company stops loving you!"
  • mishymishy Member Posts: 209 ■■■□□□□□□□
    Did you check your iptables or firewall settings on your Samba server?

    I am able to connect to the same server on a Windows Xp computer so I think its a setting with Vista Premium that I need to sort out.
  • kriscamaro68kriscamaro68 A+, Net+, Server+, Security+, Win7 MCP, Server 2012 Virtualization Specialist, MCSA 2012 Member Posts: 1,186 ■■■■■■■□□□
    There is a setting where it lets you get rid of vista and upgrade to windows 7 I think.

    If I remember correctly this is what I had to do back in the vista days:

    Secpol.msc
    Click on "Local Policies" --> "Security Options"
    Navigate to the policy "Network Security: LAN Manager authentication level" and open it.

    By default Windows Vista sets the policy to "NTVLM2 responses only". Change this to "LM and NTLM – use NTLMV2 session security if negotiated".
  • megatran808megatran808 Member Posts: 53 ■■■□□□□□□□
    Have you changed the Vista Security Policy?

    Looks like this is a common problem with Vista connecting to smb shares. I'm running only Windows 7 and Xp in my environment.

    Instructions.
    NTLM Passwords Linux NAS passwords - Vista Forums
    "Love your Job, but never fall in love with your company....because you never know when your company stops loving you!"
  • mishymishy Member Posts: 209 ■■■□□□□□□□
    There is a setting where it lets you get rid of vista and upgrade to windows 7 I think.

    If I remember correctly this is what I had to do back in the vista days:

    Secpol.msc
    Click on "Local Policies" --> "Security Options"
    Navigate to the policy "Network Security: LAN Manager authentication level" and open it.

    By default Windows Vista sets the policy to "NTVLM2 responses only". Change this to "LM and NTLM – use NTLMV2 session security if negotiated".

    Windows Vista Home Premium does not have the Local security policy setting hence I have had to change the registry setting and that still has not helped either. Is there any where else I can check?
  • megatran808megatran808 Member Posts: 53 ■■■□□□□□□□
    Have you checked this part of the registry?

    "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanWorkstation\Parameters
    Parameter is: EnablePlainTextPassword

    Set to 1.

    Also when using Vista. To connect to server you need to specify a domain identifier. Since most of us dont have a domain controller. The default WORKGROUP should work.
    Example WORKGROUP\username
    "Love your Job, but never fall in love with your company....because you never know when your company stops loving you!"
  • mishymishy Member Posts: 209 ■■■□□□□□□□
    Have you checked this part of the registry?

    "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanWorkstation\Parameters
    Parameter is: EnablePlainTextPassword

    Set to 1.

    Also when using Vista. To connect to server you need to specify a domain identifier. Since most of us dont have a domain controller. The default WORKGROUP should work.
    Example WORKGROUP\username

    I have checked and changed the registry setting above but I still cannot connect.
Sign In or Register to comment.