mx5 lsp down

mumuloxmumulox Member Posts: 31 ■■□□□□□□□□
Hello,

I have an MX5 router and I am trying to establish a LSP between 2 logical-system (PE1 and PE2) without success.
The topology is like this :

PE1 (100.100.100.100) - P1 (1.1.1.1) - P2 (2.2.2.2) - P3 (3.3.3.3) - PE2 (200.200.200.200)
[email protected]# show PE1 
interfaces {
    ge-1/0/8 {
        unit 0 {
            encapsulation vlan-ccc;
            vlan-id 1000;
            family ccc;
        }
    }
    lt-1/0/10 {
        unit 100 {
            encapsulation ethernet;
            peer-unit 101;
            family inet {
                address 172.22.210.100/24;
            }
            family mpls;
        }
        unit 200 {
            encapsulation ethernet;
            peer-unit 201;
            family inet {
                address 172.22.211.100/24;
            }
            family mpls;
        }
    }
    lo0 {
        unit 100 {
            family inet {
                address 100.100.100.100/32;
                address 127.0.0.1/32;
            }
        }
    }
}
protocols {
    rsvp {
        interface all;
        interface ge-1/0/8.0 {
            disable;
        }
        interface lo0.100;
    }
    mpls {
        icmp-tunneling;                 
        label-switched-path mihai {
            to 200.200.200.200;
            bandwidth 1k;
            no-cspf;
        }
        interface all;
        interface ge-1/0/8.0 {
            disable;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface all;
            interface ge-1/0/8.0 {
                disable;
            }
            interface lt-1/0/10.200 {
                metric 10000;
            }
        }
    }
    ldp {
        interface ge-1/0/8.0 {
            disable;
        }
        interface all;
    }
    l2circuit {
        neighbor 200.200.200.200 {
            interface ge-1/0/8.0 {
                virtual-circuit-id 111;
                mtu 1500;
            }
        }
    }
}
policy-options {
    policy-statement pol-load-balance {
        then {
            load-balance per-packet;
        }
    }
}                                       
routing-options {
    router-id 100.100.100.100;
    forwarding-table {
        export pol-load-balance;
    }
}


----------------------------------------

[email protected]# show P1 
interfaces {
    lt-1/0/10 {
        unit 12 {
            encapsulation ethernet;
            peer-unit 21;
            family inet {
                address 172.22.201.1/24;
            }
            family mpls;
        }
        unit 14 {
            encapsulation ethernet;
            peer-unit 41;
            family inet {
                address 172.22.202.1/24;
            }
            family mpls;
        }
        unit 101 {
            encapsulation ethernet;
            peer-unit 100;
            family inet {
                address 172.22.210.1/24;
            }
            family mpls;
        }
    }
    lo0 {
        unit 1 {
            family inet {
                address 1.1.1.1/32;
                address 127.0.0.1/32;
            }
        }
    }
}
protocols {
    rsvp {
        interface all;
    }
    mpls {
        icmp-tunneling;
        interface all;
    }
    ospf {                              
        traffic-engineering;
        area 0.0.0.0 {
            interface all;
        }
    }
    ldp {
        interface all;
    }
}
policy-options {
    policy-statement pol-load-balance {
        then {
            load-balance per-packet;
        }
    }
}
routing-options {
    router-id 1.1.1.1;
    forwarding-table {
        export pol-load-balance;
    }
}


--------------------------------------------------------------------

[email protected]# show P2    
interfaces {
    lt-1/0/10 {
        unit 21 {
            encapsulation ethernet;
            peer-unit 12;
            family inet {
                address 172.22.201.2/24;
            }
            family mpls;
        }
        unit 23 {
            encapsulation ethernet;
            peer-unit 32;
            family inet {
                address 172.22.206.2/24;
            }
            family mpls;
        }
        unit 25 {
            encapsulation ethernet;
            peer-unit 52;
            family inet {
                address 172.22.205.2/24;
            }
            family mpls;
        }
    }
    lo0 {
        unit 2 {
            family inet {
                address 2.2.2.2/32;
                address 127.0.0.1/32;
            }
        }
    }
}
protocols {
    rsvp {
        interface all;
    }
    mpls {
        icmp-tunneling;
        interface all;
    }
    ospf {                              
        traffic-engineering;
        area 0.0.0.0 {
            interface all;
        }
    }
    ldp {
        interface all;
    }
}
policy-options {
    policy-statement pol-load-balance {
        then {
            load-balance per-packet;
        }
    }
}
routing-options {
    router-id 2.2.2.2;
    forwarding-table {
        export pol-load-balance;
    }
}


----------------------------------------------------

[email protected]# show P3    
interfaces {
    lt-1/0/10 {
        unit 32 {
            encapsulation ethernet;
            peer-unit 23;
            family inet {
                address 172.22.206.3/24;
            }
            family mpls;
        }
        unit 36 {
            encapsulation ethernet;
            peer-unit 63;
            family inet {
                address 172.22.207.3/24;
            }
            family mpls;
        }
        unit 401 {
            encapsulation ethernet;
            peer-unit 400;
            family inet {
                address 172.22.212.3/24;
            }
            family mpls;
        }
    }
    lo0 {
        unit 3 {
            family inet {
                address 3.3.3.3/24;
                address 127.0.0.1/32;
            }
        }
    }
}
protocols {
    rsvp {
        interface all;
    }
    mpls {
        icmp-tunneling;
        interface all;
    }
    ospf {                              
        traffic-engineering;
        area 0.0.0.0 {
            interface all;
        }
    }
    ldp {
        interface all;
    }
}
policy-options {
    policy-statement pol-load-balance {
        then {
            load-balance per-packet;
        }
    }
}
routing-options {
    router-id 3.3.3.3;
    forwarding-table {
        export pol-load-balance;
    }
}

---------------------------------------------------------------

[email protected]# show PE2 
interfaces {
    ge-1/0/9 {
        unit 0 {
            encapsulation vlan-ccc;
            vlan-id 1000;
            family ccc;
        }
    }
    lt-1/0/10 {
        unit 400 {
            encapsulation ethernet;
            peer-unit 401;
            family inet {
                address 172.22.212.200/24;
            }
            family mpls;
        }
        unit 500 {
            encapsulation ethernet;
            peer-unit 501;
            family inet {
                address 172.22.213.200/24;
            }
            family mpls;
        }
    }
    lo0 {
        unit 200 {
            family inet {
                address 200.200.200.200/32;
                address 127.0.0.1/32;
            }
        }
    }
}
protocols {
    rsvp {
        interface all;
        interface ge-1/0/9.0 {
            disable;
        }
    }
    mpls {
        icmp-tunneling;
        interface all;                  
        interface ge-1/0/9.0 {
            disable;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface all;
            interface ge-1/0/9.0 {
                disable;
            }
        }
    }
    ldp {
        interface ge-1/0/9.0 {
            disable;
        }
        interface all;
    }
    l2circuit {
        neighbor 100.100.100.100 {
            interface ge-1/0/9.0 {
                virtual-circuit-id 111;
                mtu 1500;
            }
        }
    }
}
policy-options {
    policy-statement pol-load-balance {
        then {
            load-balance per-packet;
        }
    }
}
routing-options {
    router-id 200.200.200.200;
    forwarding-table {
        export pol-load-balance;
    }
}



---------------
[email protected]# run show route logical-system PE1 200.200.200.200                                                                                                    

inet.0: 24 destinations, 25 routes (23 active, 0 holddown, 1 hidden)
+ = Active Route, - = Last Active, * = Both

200.200.200.200/32 *[OSPF/10] 00:14:26, metric 4
                    > to 172.22.210.1 via lt-1/0/10.100

inet.3: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

200.200.200.200/32 *[LDP/9] 00:14:26, metric 1
                    > to 172.22.210.1 via lt-1/0/10.100, Push 300016


[email protected]# run show route logical-system PE2 100.100.100.100    

inet.0: 24 destinations, 24 routes (23 active, 0 holddown, 1 hidden)
+ = Active Route, - = Last Active, * = Both

100.100.100.100/32 *[OSPF/10] 01:30:49, metric 4
                    > to 172.22.212.3 via lt-1/0/10.400

inet.3: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

100.100.100.100/32 *[LDP/9] 01:30:49, metric 1
                    > to 172.22.212.3 via lt-1/0/10.400, Push 299984


[email protected]# run show mpls lsp extensive logical-system PE1 
Ingress LSP: 1 sessions

200.200.200.200
  From: 100.100.100.100, State: Dn, ActiveRoute: 0, LSPname: mihai
  ActivePath: (none)
  LSPtype: Static Configured
  LoadBalance: Random
  Encoding type: Packet, Switching type: Packet, GPID: IPv4
  Primary                    State: Dn
    Priorities: 7 0
    Bandwidth: 1000bps
    SmartOptimizeTimer: 180
   28 May 21 17:37:57.299 No Route toward dest[2 times]
   27 May 21 17:37:57.298 Originate Call
   26 May 21 17:37:57.297 Clear Call


[email protected]# run show mpls lsp extensive logical-system PE2    
Ingress LSP: 0 sessions
Total 0 displayed, Up 0, Down 0

Egress LSP: 1 sessions

200.200.200.200
  From: 100.100.100.100, LSPstate: Up, ActiveRoute: 0
  LSPname: mihai, LSPpath: Primary
  Suggested label received: -, Suggested label sent: -
  Recovery label received: -, Recovery label sent: -
  Resv style: 1 FF, Label in: 3, Label out: -
  Time left:  123, Since: Mon May 21 17:38:00 2012
  Tspec: rate 1000bps size 1000bps peak Infbps m 20 M 1500
  Port number: sender 13 receiver 59535 protocol 0
  PATH rcvfrom: 172.22.210.100 (lt-1/0/10.400) 23 pkts
  Adspec: received MTU 1500 
  PATH sentto: localclient
  RESV rcvfrom: localclient 
  Record route: 172.22.210.100 <self>  
Total 1 displayed, Up 1, Down 0




May 21 16:55:52.161105 RSVP send Path 100.100.100.100->200.200.200.200 Len=188 lt-1/0/10.100
May 21 16:55:52.161339   Session7 Len 16 200.200.200.200(port/tunnel ID 59535 Ext-ID 100.100.100.100) Proto 0
May 21 16:55:52.161367   Hop      Len 12 172.22.210.100/0x80000002
May 21 16:55:52.161390   Time     Len  8 30000 ms
May 21 16:55:52.161412   LabelRequest Len  8 EtherType 0x800
May 21 16:55:52.161437   Properties Len 12 Primary path
May 21 16:55:52.161461   SessionAttribute Len 16 Prio (7,0) flag 0x0 "mihai"
May 21 16:55:52.161485   Sender7  Len 12 100.100.100.100(port/lsp ID  12)
May 21 16:55:52.161523   Tspec    Len 36 rate 0bps size 0bps peak Infbps m 20 M 1500
May 21 16:55:52.161547   ADspec   Len 48 MTU 1500
May 21 16:55:52.161572   RecRoute Len 12  172.22.210.100
May 21 16:55:52.161692 task_send_msg: task RSVP socket 12 length 212 flags MSG_DONTROUTE(4) to 172.22.210.1 out interface lt-1/0/10.100
May 21 16:55:52.161805 task_timer_uset: timer RSVP_RSVP SESSION <Touched Processing> set to offset 45 at 16:56:37
May 21 16:55:52.167296 task_process_events: recv ready for RSVP
May 21 16:55:52.167366 task_receive_packet: task RSVP from 172.22.212.200 if lt-1/0/10.100 (ix -1610691512) msgix 376 socket 12 length 140
May 21 16:55:52.167426 RSVP recv Resv 172.22.212.200->172.22.210.100 Len=120 lt-1/0/10.100
May 21 16:55:52.167455   Session7 Len 16 200.200.200.200(port/tunnel ID 59535 Ext-ID 100.100.100.100) Proto 0
May 21 16:55:52.167480   Hop      Len 12 172.22.212.200/0x80000002
May 21 16:55:52.167502   Time     Len  8 30000 ms
May 21 16:55:52.167525   Style    Len  8 FF
May 21 16:55:52.167595   Flow     Len 36 rate 0bps size 0bps peak Infbps m 20 M 1500
May 21 16:55:52.167621   Filter7  Len 12 100.100.100.100(port/lsp ID  12)
May 21 16:55:52.167643   Label    Len  8  3
May 21 16:55:52.167668   RecRoute Len 12  172.22.212.200
May 21 16:55:52.167710 RSVP error, recv resv no path info Resv 172.22.212.200->172.22.210.100 Len=120
May 21 16:55:52.167741 RSVP error, originate ResvErr ResvErr 172.22.210.100->172.22.212.200 Len=8  code 4 subcode 0
May 21 16:55:52.167768 RSVP send ResvErr 172.22.210.100->172.22.212.200 Len=104 lt-1/0/10.100
May 21 16:55:52.167793   Session7 Len 16 200.200.200.200(port/tunnel ID 59535 Ext-ID 100.100.100.100) Proto 0
May 21 16:55:52.167816   Hop      Len 12 172.22.210.100/0x80000002
May 21 16:55:52.167840   Error    Len 12 Unknown PathErr code 4 flag 0 by 172.22.210.100
May 21 16:55:52.167862   Style    Len  8 FF
May 21 16:55:52.167891   Flow     Len 36 rate 0bps size 0bps peak Infbps m 20 M 1500
May 21 16:55:52.167916   Filter7  Len 12 100.100.100.100(port/lsp ID  12)




Any suggestion?

Thanks!

Comments

  • AldurAldur Juniper Moderator Member Posts: 1,460
    Try getting rid of the bandwidth statement on PE1, that might be causing the problem.
    "Bribe is such an ugly word. I prefer extortion. The X makes it sound cool."

    -Bender
  • mumuloxmumulox Member Posts: 31 ■■□□□□□□□□
    already tried that but nothing is changed:

    [email protected]> show mpls lsp extensive logical-system PE1
    Ingress LSP: 1 sessions

    200.200.200.200
    From: 100.100.100.100, State: Dn, ActiveRoute: 0, LSPname: mihai
    ActivePath: (none)
    LSPtype: Static Configured
    LoadBalance: Random
    Encoding type: Packet, Switching type: Packet, GPID: IPv4
    Primary State: Dn
    Priorities: 7 0
    SmartOptimizeTimer: 180


    [email protected]> show mpls lsp extensive logical-system PE2
    Ingress LSP: 0 sessions
    Total 0 displayed, Up 0, Down 0

    Egress LSP: 1 sessions

    200.200.200.200
    From: 100.100.100.100, LSPstate: Up, ActiveRoute: 0
    LSPname: mihai, LSPpath: Primary
    Suggested label received: -, Suggested label sent: -
    Recovery label received: -, Recovery label sent: -
    Resv style: 1 FF, Label in: 3, Label out: -
    Time left: 151, Since: Mon May 21 19:40:45 2012
    Tspec: rate 0bps size 0bps peak Infbps m 20 M 1500
    Port number: sender 15 receiver 59535 protocol 0
    PATH rcvfrom: 172.22.210.100 (lt-1/0/10.400) 3 pkts
    Adspec: received MTU 1500
    PATH sentto: localclient
    RESV rcvfrom: localclient
    Record route: 172.22.210.100 <self>
    Total 1 displayed, Up 1, Down 0

    Something is not right in the Record route field because PE1 and PE2 are not directly connected.
    Another problem is that a traceroute from PE1 loopback to PE2 loopback does not show the intermediate routers:

    [email protected]> traceroute logical-system PE1 200.200.200.200 source 100.100.100.100
    traceroute to 200.200.200.200 (200.200.200.200) from 100.100.100.100, 30 hops max, 40 byte packets
    1 200.200.200.200 (200.200.200.200) 0.549 ms 0.436 ms 0.413 ms

    [email protected]> show version
    Hostname: mx5t
    Model: mx5-t
    JUNOS Base OS boot [11.4R2.14]
    JUNOS Base OS Software Suite [11.4R2.14]
    JUNOS Kernel Software Suite [11.4R2.14]
    JUNOS Packet Forwarding Engine Support (MX80) [11.4R2.14]
    JUNOS Online Documentation [11.4R2.14]
    JUNOS Routing Software Suite [11.4R2.14]
  • mumuloxmumulox Member Posts: 31 ■■□□□□□□□□
    Someone (on a mailing list) informed me that there is a bug with ttl processing on LT interfaces. I reconfigured the lab using a physical loop and everything came up to normal.
    Thanks!
  • AldurAldur Juniper Moderator Member Posts: 1,460
    Very interesting, and thanks for posting what you found.
    "Bribe is such an ugly word. I prefer extortion. The X makes it sound cool."

    -Bender
  • chongch01chongch01 Member Posts: 41 ■■□□□□□□□□
    Hi,

    Appreciate if u should share the config.
    : )
  • APAAPA Member Posts: 959
    hmm interesting, thanks for posting your findings.

    I'm seeing weird TTL behaviour with 11.4 code on my SRX as well..... again when using LT interfaces, considering reconfiguring with physical loops...we'll see...

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
  • mumuloxmumulox Member Posts: 31 ■■□□□□□□□□
    PR685639 for the ttl problem. LT interfaces are useless in 11.4 in my opinion :)
Sign In or Register to comment.