Frame Relay in the real world

elderkaielderkai Member Posts: 279
Hey, guys. I've heard a few local people mention that Frame Relay isn't used at all in the real world, at least not commonly, and laugh when it's brought up. Now, I'm not sure if the people who said this are credible and I don't personally know them, but it was just kind of hard to believe that it's as faded out as they say from how prominent it is in Cisco material.

I'm not in the job market yet, so I really don't have an opinion/knowledge of it one way or another and I know that it's a rather old protocol so it's understood if it is true. I really just want to know exactly why and what replaced it(VPNs, I'd imagine) if so. Thanks for your help. :)

Comments

  • networkjutsunetworkjutsu Senior Member Member Posts: 275 ■■■□□□□□□□
    I've been to only two companies as a network guy, the first gig had several thousands of sites and were using Frame Relay. In 08 or earlier, they renegotiated the contracts with several SPs (AT&T, Sprint, Qwest, and etc) and eventually sites were moved to MPLS. There was one SP company that still delivered the circuit as Frame Relay for the MPLS, but other than that everything were straight T1 MPLS for those little sites. With my second network gig, they are using MPLS as well. We do have one more router running Frame Relay which is our backup Internet connection with several T1s bonded together.

    There are some CCIEs in Twitterverse that said Cisco should take out Frame Relay out of the content since fewer companies are running FR.
  • elderkaielderkai Member Posts: 279
    Oh, okay. Thank you for your help. :) I've seen the protocol MPLS around, the name of it at least, and have always wanted to look more into it. I don't think ROUTE material covers it, so at what point is MPLS covered? CCIP/CCSP?
  • Mrock4Mrock4 Banned Posts: 2,359 ■■■■■■■■□□
    Frame Relay still has a HUGE market hold, but it is fading. My current employer uses frame relay as well as MPLS, my previous employer only had FR. One before that was ATM.

    MPLS is covered in the CCIP.
  • RoguetadhgRoguetadhg CompTIA A+, Network+. Member Posts: 2,489 ■■■■■■■■□□
    CCIP has it. ROUTE does cover it... in the sense that you know it's there. Atleast in the OCG it does. It's a pretty cool topic, current as well.

    You beat me to it, Mrock4.
    In order to succeed, your desire for success should be greater than your fear of failure.
    TE Threads: How to study for the CCENT/CCNA, Introduction to Cisco Exams

  • elderkaielderkai Member Posts: 279
    Awesome. Sounds like I will have to read up on it some to help strengthen my WAN understandings. ^.^ Thanks a lot, guys.
  • Mrock4Mrock4 Banned Posts: 2,359 ■■■■■■■■□□
    Roguetadhg wrote: »
    You beat me to it, Mrock4.

    Finally, usually I am late to the party!
  • fluk3dfluk3d Member Posts: 141 ■■■□□□□□□□
    I've seen frame relay being used in the "last mile" from the SP to the customer
    "Imagination is more important than knowledge." - Albert Einstein
  • m3zillam3zilla Member Posts: 172
    MPLS is a service provider protocol. Unless you're going to be working for a SP, or just want to know it for your own knowledge, it's not going to help much with your day to day job duties.
  • elderkaielderkai Member Posts: 279
    I don't have a job, let alone one where it applies, but I'd like to know it just for my own knowledge. ^.^ It might be a plus if I get an internship with a local ISP, which is very likely this next month.
  • drkatdrkat Banned Posts: 703
    Oh the joys of frame.. honestly.. unless you are working for a provider dont concern yourself.. just know how to configure it on your router.

    I've worked for a few places that had frame relay networks, depends a lot on if the company had an existing infrastructure. You'll never need to really configure any of the 'core' items if you're doing LAN work. MPLS is also a provider thing.. the most you may have to do is configure vrf's in your CPE to interface with the provider.. that's also a BIG MAYBE... well shizzle let me give an example :) I love examples


    Place I worked for (CLEC) would sell customer T1 right?? well... we also had MPLS ... so the topology was as so... This is a perfect example of configuring frame-relay types and interop with MPLS

    {7600}--->DCX--->MUX--->{provider uplink}--->{LEC CO}-->{MUX}---->{Customer CPE}



    ip vrf internet
    rd 1:1

    controller T1 0/3/0
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24
    !
    controller T1 0/3/1
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24

    interface MFR1
    no ip address
    frame-relay lmi-type ansi
    !
    interface MFR1.1 point-to-point
    description => Internet
    ip vrf forwarding internet
    ip address 63.138.x.x 255.255.255.252
    ip access-group 101 in
    ip inspect DEFAULT100 out
    ip nat outside
    ip virtual-reassembly
    no cdp enable
    frame-relay interface-dlci 501 IETF
    !
    interface MFR1.2 point-to-point
    description =>MPLS
    ip address 63.139.x.x 255.255.255.252
    ip virtual-reassembly
    no cdp enable
    frame-relay interface-dlci 502 IETF

    interface FastEthernet0/0
    description LAN
    ip vrf forwarding internet
    ip address 74.11.x.x 255.255.255.240
    ip nat inside
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description $ES_LAN$
    ip address 192.168.1.254 255.255.255.0
    ip access-group 100 in
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface Serial0/3/0:0
    no ip address
    encapsulation frame-relay
    no arp frame-relay
    !
    interface Serial0/3/1:0
    no ip address
    encapsulation frame-relay
    no arp frame-relay

    ip classless
    ip route vrf internet 0.0.0.0 0.0.0.0 MFR1.1 63.138.x.x
    ip route 192.168.2.0 255.255.255.0 MFR1.2 63.139.x.x


    What this does is allow us to carry internet and mpls by just using the dlci's I guess a poor-man's QinQ for T1 :)

    NOTE: When I say internet/mpls traffic I'm really referring to vrf-lite... thought I might add this in
  • SteveO86SteveO86 Member Posts: 1,423
    Working for an MSP we have a lot of customers with many different networks from different carriers. We all joked about frame-relay until we got a customer with frame-relay (i'd say we have maybe 6-10 now). It's always fun to scroll through a config and find a frame-relay connection.

    Frame-relay has more or less been taken over by MPLS as mentioned above.
    My Networking blog
    Latest blog post: Let's review EIGRP Named Mode
    Currently Studying: CCNP: Wireless - IUWMS
  • unclericounclerico Member Posts: 237
    I used to wonder why Cisco kept frame relay in their blueprints and to me it's really just there to have you become familiar with NBMA networks and how different routing protocols are affected by them. As for MPLS, yes it is a carrier technology for the most part, but there are plenty of use cases for multi-vrf CE/VRF lite especially in large orgs. Also, understanding how MP-BGP interacts with IGPs is a plus as well as how sham-links operate or how the MPLS Superbackbone works so that you get optimal path selection in certain topologies (for example). even though I'm a route/switch guy, I'm glad I know how MPLS works.
    Preparing for CCIE Written
Sign In or Register to comment.