BGP redistribution issue.

llllvllllllllvllll MemberMember Posts: 58 ■■□□□□□□□□




I have already configure ospf on Router(1,2,3 and 4) with area 0 & my BGP configuration on Routers are as following:-




Router 1:
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 ebgp-multihop 5
neighbor 2.2.2.2 update-source Loopback1
neighbor 2.2.2.2 route-reflector-client
neighbor 2.2.2.2 next-hop-self
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 ebgp-multihop 5
neighbor 3.3.3.3 update-source Loopback1
neighbor 3.3.3.3 route-reflector-client
neighbor 3.3.3.3 next-hop-self
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 ebgp-multihop 5
neighbor 4.4.4.4 update-source Loopback1
neighbor 4.4.4.4 route-reflector-client
neighbor 4.4.4.4 next-hop-self
no auto-summary




Router 2:-
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 5
neighbor 1.1.1.1 update-source Loopback1
no auto-summary




Router 3 :-
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 5
neighbor 1.1.1.1 update-source Loopback1
no auto-summary


Router 4:-
router bgp 100
no synchronization
bgp log-neighbor-changes
network 2.2.2.0 mask 255.255.255.0
network 4.4.4.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 5
neighbor 1.1.1.1 update-source Loopback1
neighbor 1.1.1.1 next-hop-self
neighbor 5.5.5.5 remote-as 200
neighbor 5.5.5.5 ebgp-multihop 5
neighbor 5.5.5.5 update-source Loopback1
neighbor 5.5.5.5 next-hop-self
no auto-summary


Router 5:-
router bgp 200
no synchronization
bgp log-neighbor-changes
network 5.5.5.0 mask 255.255.255.0
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 ebgp-multihop 5
neighbor 4.4.4.4 update-source Loopback1
neighbor 4.4.4.4 next-hop-self
no auto-summary


Question :-
How can i get 5.5.5.5(Router's 5 loopback) into R1's routing table without redistributing IGP routes into as 200 ?
when i redistribute eBGP routes into Ospf packets for 5.5.5.5 gets drop on Router 4(when i ping from router 1,2 or 3)


any solutions?


P.S R4 & R5 have 2 static routes configured to reach each other.

Comments

  • networker050184networker050184 Went to the dark side.... Mod Posts: 11,962 Mod
    Does router 5 have a route for 5.5.5.0/24 in the routing table or do you have a /32 from the loopback?
    An expert is a man who has made all the mistakes which can be made.
  • llllvllllllllvllll Member Member Posts: 58 ■■□□□□□□□□
    R5 is not running any IGP only BGP. So its 5.5.5.0/24
  • networker050184networker050184 Went to the dark side.... Mod Posts: 11,962 Mod
    Whether it is running an IGP or not doesn't have anything to do with if you have a /24 or /32 in the routing table.

    Do you see the 5.5.5/24 route in R1 as a BGP route?

    If so I'd assume your problem is that R5 has no route back to the interface addressing you used in AS 100. The router will by default use the outgoing interface address as the source of the ping. So when you ping from R1 the source address will be in the 10.0.0/24 or 30.0.0/24 range (depending on the route it takes). When R5 gets the ping packet with this source address it has no route back which is why the pings fail.

    You have a couple solutions. Either annouce your internal link ranges via BGP to R5 or put a default route on R5. You could also advertise your loopbacks (or another stub network) into BGP from R1 and use that as the source of your pings. Remember routing is a two way operation. Just because R1 can reach R5 doesn't mean R5 can reach R1.

    Also if you aren't going to go with a full iBGP mesh you are going to want to look into route reflection.
    An expert is a man who has made all the mistakes which can be made.
  • llllvllllllllvllll Member Member Posts: 58 ■■□□□□□□□□
    Hmm thanks mate. Yes R5 was not able to route the packet back because it does not have the route back to R1.
    So i will advertise some routes in BGP and as far as route reflection goes i have used it in this scenario where R2 ,R3 & R4 are the client.

    anyways thanks for the input i was searching the answer for 2 days.
    P.S :- When i'll Pass my CCIE your name is going in my blog aswell hehe :P :)
  • JackaceJackace Senior Member Member Posts: 335
    My understanding of best practices is that you want a full mesh configuration between all IBGP peers. That would explain why you don't have routes in some of the routers.

    edit- or as networker050184 said you want route reflectors.

    Edit 2- Sorry I missed the route reflection part of your config as well when looking at things the first time. The suggestions by networker050184 are solid though.
  • networker050184networker050184 Went to the dark side.... Mod Posts: 11,962 Mod
    Yep my bad missed the reflection part of your config. Glad you got it sorted.
    An expert is a man who has made all the mistakes which can be made.
Sign In or Register to comment.