Making a FLAT network talk to a Routed Network
higherho
Member Posts: 882
in CCNA & CCENT
Hi all,
I have a flat network setup with some vlans on it. I wish for that flat network to communicate to a routed network (OSPF) with Layer 3 vlans (RVI's) on juniper. I'm having some brain farts atm, I understand that for the flat network to talk to the routed network it would also have to be routed.
If I make a Layer 3 SVI on Cisco thats connected to the juniper side I'm forgetting what else I would need to accomplish. On the Junier side all my RVI ports have inet address according to the scope I laid out. Which all are set in ospf for example;
set protocols ospf area 0.0.0.0 interface vlan.605
set protocols ospf area 0.0.0.0 interface vlan.606
etc
Now my brian is just stuck on how I can get the cisco to talk properly on the juniper?
I have a flat network setup with some vlans on it. I wish for that flat network to communicate to a routed network (OSPF) with Layer 3 vlans (RVI's) on juniper. I'm having some brain farts atm, I understand that for the flat network to talk to the routed network it would also have to be routed.
If I make a Layer 3 SVI on Cisco thats connected to the juniper side I'm forgetting what else I would need to accomplish. On the Junier side all my RVI ports have inet address according to the scope I laid out. Which all are set in ospf for example;
set protocols ospf area 0.0.0.0 interface vlan.605
set protocols ospf area 0.0.0.0 interface vlan.606
etc
Now my brian is just stuck on how I can get the cisco to talk properly on the juniper?
Comments
-
networker050184 Mod Posts: 11,962 ModAs long as they are OSPF neighbors it should work just as if it were two Cisco neighbors. Did you include your RVIs as L3 interfaces?An expert is a man who has made all the mistakes which can be made.
-
higherho Member Posts: 882Can't I setup an SVI port on Cisco give the SVI an IP to a particular subnet that is reconized in the juniper network and any ports I want to talk to the other network put them in that SVI VLAN?
-
higherho Member Posts: 882networker050184 wrote: »As long as they are OSPF neighbors it should work just as if it were two Cisco neighbors. Did you include your RVIs as L3 interfaces?
Yes the RVI's are L3 interfaces. The SVI's would also have to be the same and OSPF would have to be configured on the cisco devices correct? -
networker050184 Mod Posts: 11,962 ModKind of confused on what you are trying to do here. You don't need SVIs on the Cisco. Do an L3 link between the Cisco and Juniper and have them form an OSPF adjacency. Or are you trying to get devices off both in the same L2 domain?
A diagram and configs will help.An expert is a man who has made all the mistakes which can be made. -
higherho Member Posts: 882networker050184 wrote: »Kind of confused on what you are trying to do here. You don't need SVIs on the Cisco. Do an L3 link between the Cisco and Juniper and have them form an OSPF adjacency.
A diagram and configs will help.
Sorry for the confusion. So first create an OSPF instance on my cisco devices and then create a layer 3 link that connects to the junOS ? I will get the configs up here soon. -
higherho Member Posts: 882OSPF is set on the Cisco
router ospf 1
network 10.10.10.0 0.0.0.255 area 0
network 10.10.30.0 0.0.0.255 area 0
network 10.10.40.0 0.0.0.255 area 0
Interface 2/0/34 on both have an ip assigned to them from the 10.10.40.0 0.0.0.255 subnet. The last network is the L3 link connection between the cisco port and juniper port. -
networker050184 Mod Posts: 11,962 ModI'd just use a routed port from the Juniper to the Cisco unless you have some need for L2 connectivity there.An expert is a man who has made all the mistakes which can be made.
-
higherho Member Posts: 882I'm trying to get VLAN100 which has an IP of 10.10.10.1 /24 to communicate to all the juniper stuff which is already routed and takable to everything in that enviroment. I have no routing setup (well prior to me playing around with it).
On the Juniper I have the following on 1/0/34 which is connected to the Cisco device;
Port configuration;
set interfaces ge-1/0/34 unit 0 description TO Cisco
set interfaces ge-1/0/34 unit 0 family inet address 10.10.40.3/24
OSPF network added so that everyone in the network and other switches know about the new route;
set protocols ospf area 0.0.0.0 interface ge-1/0/34
On the cisco end I have;
no switchport
ip address 10.10.40.2 /24
router ospf 1
network 10.10.10.1 0.0.0.255 area 0
network 10.10.30.1 0.0.0.255 area 0
network 10.10.40.2 0.0.0.255 area 0
Currently on this is how the ospf looks like on the juniper;set protocols ospf area 0.0.0.0 interface ae0.0
set protocols ospf area 0.0.0.0 interface ae1.0
set protocols ospf area 0.0.0.0 interface vlan.605
set protocols ospf area 0.0.0.0 interface vlan.610
set protocols ospf area 0.0.0.0 interface vlan.604
set protocols ospf area 0.0.0.0 interface vlan.602
set protocols ospf area 0.0.0.0 interface vlan.603
set protocols ospf area 0.0.0.0 interface vlan.607
set protocols ospf area 0.0.0.0 interface vlan.608
set protocols ospf area 0.0.0.0 interface ae2.0
set protocols ospf area 0.0.0.0 interface vlan.611
set protocols ospf area 0.0.0.0 interface vlan.606
set interfaces vlan unit 602 family inet address 10.90.XXX.XXX/27
set interfaces vlan unit 603 family inet address 10.90.XXX.XXX/27
set interfaces vlan unit 604 family inet address 10.90.XXX.XX/27
set interfaces vlan unit 605 family inet address 10.90.XXX.XX/27
set interfaces vlan unit 606 family inet address 10.90.XXX.X/28
set interfaces vlan unit 607 family inet address 10.90.XX.XXX/28
set interfaces vlan unit 608 family inet address 10.90.XXX.XX/27
set interfaces vlan unit 610 family inet address 10.90.XXX.XX/28
set interfaces vlan unit 611 family inet address 10.90.XX.XXX/30
Is this incorrect? or what would be simpler? On the cisco device I have all layer 2 activity (three different VLANS). I think I'm just so tired I cannot think and I've been extremely stressed on the past two weeks. Guh I greatly appreciate your help with this. -
vanquish23 Member Posts: 224Is "routing" turned on via the Cisco router? I.E: Cisco>routingHe who SYNs is of the devil, for the devil has SYN'ed and ACK'ed from the beginning. For this purpose, that the ACK might destroy the works of the devil.
-
networker050184 Mod Posts: 11,962 ModHave OSPF neighbors formed between the two?An expert is a man who has made all the mistakes which can be made.
-
higherho Member Posts: 882When I sat and looked at the configs I realized that I was doing this the hard way. I took the OSPF out of the Cisco router then looked at routed port I made between the juniper and cisco. Went on the juniper and took that RVI and broadcasted it in OSPF then went back on the Cisco router and simply made a static route with the next hop address of the RVI so that the cisco router knows where the juniper stuff lives. Once that was done everything talked.
@Networker
i didn't
@Vanquish
To answer your question, yes ip routing is on.
@ Node Man
A flat network is layer 2 only. -
networker050184 Mod Posts: 11,962 ModWell, actually now you are doing it the hard way with statics! OSPF could do it all for you if you just configure it right.An expert is a man who has made all the mistakes which can be made.
-
higherho Member Posts: 882networker050184 wrote: »Well, actually now you are doing it the hard way with statics! OSPF could do it all for you if you just configure it right.
Its only one static route on the cisco - 10.XX.0.0 /21 which is all the subnets on the juniper side. In OSPF I would have had to still entered the networks for them to be broadcasted and much more configuration. For the amount of devices on that network OSPF would have been over kill and technically speaking not really needed. However, I do see your point and yes part of me still wants them to be neighbors and do it the OSPF way. -
martell1000 Member Posts: 389what exactly is the reason you dont want OSPF to handle it for you?
looks like a very painfull way. why dont you just let them all form relationships via ospf?!And then, I started a blog ... -
higherho Member Posts: 882So the only reason right now its setup that way is because the enviroment I have to replicate. They have a downlink to the application CORE which is juts a static route. they did not want to have multi area ospf going.
On the cisco end I realized I made everything area 0 and to form a relationship they have to be different. So I was close just some stuff I messed up on the Cisco end. -
networker050184 Mod Posts: 11,962 ModNo they need to be in the same area, not different. Sounds like you need a bit of OSPF work.
At least you got it working though!An expert is a man who has made all the mistakes which can be made. -
higherho Member Posts: 882Thanks I will post again when I have the OSPF figured out. Your right my OSPF is rusty in some areas Practice makes perfect but I wish I could solely focus on networking.
-
higherho Member Posts: 882I meant to update this a while back (March 4th is when I changed everything from static to routing). All I just did was make a static neighbor relationship and all the routes came about. I just forgot my commands at the time which if you don't use it you lose it. Everything is much easier now networking wise.