Simulator Setup

up2thetimeup2thetime Member Posts: 154
Hey guys,

I'm building an Olive here and was having some trouble on this page:
Olive reloaded or how to emulate Juniper routers | GNS3


Qemu keep saying that it is unable to boot from the CD when using this command:


qemu -m 256 -hda olive-base.img -cdrom 4.11-RELEASE-i386-miniinst.iso \-boot d -localtime

I placed the ISO on my desktop and modified the command to:

qemu -m 256 -hda olive-base.img /home/user1/Desktop/4.11-RELEASE-i386-miniinst.iso \ -boot d -localtime

and

qemu -m 256 -hda olive-base.img /home/user1/Desktop/4.11-RELEASE-i386-miniinst.iso


I have also tried to boot from FreeBSD9.

Still no luck. I think the problem is that Qemu cannot find the ISO. Anyone know of a solution? I also mounted the ISO and tried pointing to the mounted directory. That didn't work either. Thanks guys.



Comments

  • ccnxjrccnxjr Member Posts: 304
    Can you try :
    qemu [COLOR=#660033]-m[/COLOR] 256 [COLOR=#660033]-hda[/COLOR] olive-base.img [COLOR=#660033]-cdrom[/COLOR] /home/user1/Desktop/4.11-RELEASE-i386-miniinst.iso [COLOR=#660033]-boot[/COLOR] d [COLOR=#660033]-localtime[/COLOR]
    

    let me know the outcome....

    Also, what OS are you using? Fedora ? Ubuntu?
  • up2thetimeup2thetime Member Posts: 154
    ccnxjr wrote: »
    Can you try :
    qemu [COLOR=#660033]-m[/COLOR] 256 [COLOR=#660033]-hda[/COLOR] olive-base.img [COLOR=#660033]-cdrom[/COLOR] /home/user1/Desktop/4.11-RELEASE-i386-miniinst.iso [COLOR=#660033]-boot[/COLOR] d [COLOR=#660033]-localtime[/COLOR]
    

    let me know the outcome....

    Also, what OS are you using? Fedora ? Ubuntu?

    Thanks!! It worked!! I was able to get FreeBSD installed. I am using Ubuntu 12.10.

    I ended up going with FreeBSD-9.1 instead of 4.11-miniinst.iso. The only issue I am having is that I cannot get the FreeBSD install to talk to my host machine. I followed the steps found here:
    Olive reloaded or how to emulate Juniper routers | GNS3

    I even started up FreeBSD, and manually set the ip address of ed0 to be on the same subnet as my host machine by using:
    ifconfig ed0 192.168.1.100 up. I also set the mac address. However, the two still won't talk. I hope this isn't because I went with 9.1 instead of 4.11. Please let me know.

    Thank you again.
  • ccnxjrccnxjr Member Posts: 304
    Hrmm,

    I believe quemu sets up a different subnet than the host.
    Haven't had the time to test it out, personally I passed the JunOS image to qemu as an ISO file.

    I'll look into it.

    In the mean time try the following:
    qemu -m 256 -net nic,model=e1000 -hda olive-base.img -localtime -net user
    

    Log in to your qemu virtual machine, then tell FreeBSD to get an ip address using DHCP like this :
    dhclient em0
    
    where "em0" is your nic

    then figure out where your gateway is like so:
    netstat -r
    

    The host machine is the gateway, so whatever ip address you get for a default gateway that should be the ip address of your host machine.

    Give it a shot!
  • ccnxjrccnxjr Member Posts: 304
    Just tried hacking through it, I'd stick with FreeBSD 4.11 or 7.4, there's a bit more work involved in setting things up with FreeBSD 9.1
    The install package is barfing on the partition labels.
    There's a hack around it, but haven't got the time to test it out at the moment.
    All you really need is a base install, JunOS will pretty much **** everything and replace the current kernel with it's own.
Sign In or Register to comment.