How do You manage your home lab.

EdTheLadEdTheLad Posts: 2,112Member
I have built a lab which consists of 8 routers.I have the eth ports on all routers connected to a hub which is also connected to a wireless router so i can connect to my lab from anywhere in my house.
This setup would be ideal if i had 2 eth ports on every router which is not the case.Are there any other good alternative methods to manage the routers via serial or console ports? Maybe there is an external device which can be added to manage connections using serial or console ports??
Let me know if your using a better setup!
Networking, sometimes i love it, mostly i hate it.Its all about the $$$$

Comments

  • keenonkeenon Posts: 1,921Member ■■■■□□□□□□
    get a 2509 access router. it has a 8 low speed sync cables for connecting to console port on your routers.. if u have an old computer install RD or some other app that will allow u to connect to it and connect that PC to the 2509.. that how i do it at home.


    PC - remote desktop
    |com port|
    -2509-
    router a
    router b
    router c
    ....
    ....
    ....
    ....
    ....



    icon_wink.gif
    Become the stainless steel sharp knife in a drawer full of rusty spoons
  • QUIX0TICQUIX0TIC Posts: 277Member
    I agree. I have a 2511-RJ which allows me to connect to all my routers with one device. It helps especially when you want to have remote access to your home lab.
    "To realize one's destiny is a person's only obligation."
  • EdTheLadEdTheLad Posts: 2,112Member
    Great this was what i was looking for, so i can buy either 2509,2510,2511,2512 and also an octal cable.Is there a special config i
    need in order to manage the 8 console sessions through this router?
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • QUIX0TICQUIX0TIC Posts: 277Member
    Yes there is... when I get home I will edit this post and send to you.
    "To realize one's destiny is a person's only obligation."
  • netadminnetadmin Posts: 11Member ■□□□□□□□□□
    is there any online home lab available for free of cost?
  • wildfirewildfire Posts: 654Member
    I have posted the config from my own terminal server below, I have it setup on a lan connection so when I telent to it, it runs a menu system to connect to other devices



    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Host
    !
    enable secret 5 ******
    enable password password
    !
    !
    !
    !
    !
    ip subnet-zero
    no ip domain-lookup
    ip host c2 2002 10.0.0.1
    ip host c4 2004 10.0.0.1
    ip host c5 2005 10.0.0.1
    ip host c6 2006 10.0.0.1
    ip host c7 2007 10.0.0.1
    ip host c8 2008 10.0.0.1
    ip host c9 2009 10.0.0.1
    ip host c10 2010 10.0.0.1
    ip host c11 2011 10.0.0.1
    ip host c12 2012 10.0.0.1
    ip host c13 2013 10.0.0.1
    ip host c14 2014 10.0.0.1
    ip host c15 2015 10.0.0.1
    ip host c16 2016 10.0.0.1
    ip host c1 2001 10.0.0.1
    ip host c3 2003 10.0.0.1
    !
    !
    !
    process-max-time 200
    !
    interface Loopback66
    ip address 10.0.0.1 255.255.255.255
    no ip directed-broadcast
    !
    interface Ethernet0
    ip address 192.168.10.2 255.255.255.0
    no ip directed-broadcast
    no ip mroute-cache
    no mop enabled
    !
    interface Serial0
    no ip address
    no ip directed-broadcast
    no ip mroute-cache
    shutdown
    !
    interface Serial1
    no ip address
    no ip directed-broadcast
    no ip mroute-cache
    shutdown
    !
    ip classless
    no ip http server
    !
    !
    menu cserver title Welcome to Cisco-Engineer.com Rack
    If you have problems connecting to your device
    clear the connection via cl+# (ie:cl1) and try again.

    To exit back out to the menu press "CTRL+SHIFT+6"
    then "X". You must then clear the connection and
    begin a new console session to re-connect to
    that device.
    1 - Connect to 3620
    2 - Connect to 4500
    3 - Connect to 2501_1
    4 - Connect to 2501_2
    5 - Connect to 2504_1
    6 - Connect to 2504_2
    7 - Connect to 2520
    8 - Connect to 2612
    p2 - console ports 9-16 | show - show lines in use
    Exit - logout | menuexit - exit menu
    menu cserver prompt Please enter command or selection:
    menu cserver command 1 tn c1
    menu cserver command 2 tn c2
    menu cserver command 3 tn c3
    menu cserver command 4 tn c4
    menu cserver command 5 tn c5
    menu cserver command 6 tn c6
    menu cserver command 7 tn c7
    menu cserver command 8 tn c8
    menu cserver command cl1 cl1
    menu cserver command cl2 cl2
    menu cserver command cl3 cl3
    menu cserver command cl4 cl4
    menu cserver command cl5 cl5
    menu cserver command cl6 cl6
    menu cserver command cl7 cl7
    menu cserver command cl8 cl8
    menu cserver command p2 menu cserver2
    menu cserver command menuexit menu-exit
    menu cserver command exit exit
    menu cserver command show show line tty 1 16 | include \*
    menu cserver options show pause
    menu cserver clear-screen
    menu cserver single-space
    !
    menu cserver2 title Welcome to Cisco-Engineer.com
    If you have problems connecting to your device
    clear the connection via cl+# (ie:cl1) and try again.

    To exit back out to the menu press "CTRL+SHIFT+6"
    then "X". You must then clear the connection and
    begin a new console session to re-connect to
    that device.
    9 - Connect to 2950 Cat
    10 - Conenct to 7007
    11 - Connect to 1924_1
    12 - Connect to 1924_2
    13 - Connect to 1720
    14 - Connect to 1601_1
    15 - Connect to 1601_2
    16 - Connect to 1603
    p1 - console ports 1-8 | show - show lines in use
    Exit - logout |
    menu cserver2 command 9 tn c9
    menu cserver2 command 10 tn c10
    menu cserver2 command 11 tn c11
    menu cserver2 command 12 tn c12
    menu cserver2 command 13 tn c13
    menu cserver2 command 14 tn c14
    menu cserver2 command 15 tn c15
    menu cserver2 command 16 tn c16
    menu cserver2 command cl9 cl9
    menu cserver2 command cl10 cl10
    menu cserver2 command cl11 cl11
    menu cserver2 command cl12 cl12
    menu cserver2 command cl13 cl13
    menu cserver2 command cl14 cl14
    menu cserver2 command cl15 cl15
    menu cserver2 command cl16 cl16
    menu cserver2 command p1 menu-exit
    menu cserver2 command exit exit
    menu cserver2 command show show line tty 1 16 | include \*
    menu cserver2 options show pause
    menu cserver2 clear-screen
    menu cserver2 single-space
    snmp-server engineID local 00000009020000107BE82862
    snmp-server community public RO
    snmp-server community private view v1default RO
    snmp-server host 192.168.10.1 private
    banner motd
    Welcome to the Cisco-Engineer.com Rack (C)2005
    Please read the Terms and Conditions at www.Cisco-Engineer.com/terms.html
    Disconnect if you are not authorised
    DO NOT Earse Flash
    Dont Erase Startup Configs only erase the running config
    If you are going to set any passwords use cisco
    If you have any problems Email [email protected]
    Ensure you have familiarised yourself with the Rack layout
    Good Luck!

    alias exec cl1 clear line 1
    alias exec cl2 clear line 2
    alias exec cl3 clear line 3
    alias exec cl4 clear line 4
    alias exec cl5 clear line 5
    alias exec cl6 clear line 6
    alias exec cl7 clear line 7
    alias exec cl8 clear line 8
    alias exec cl9 clear line 9
    alias exec cl10 clear line 10
    alias exec cl11 clear line 11
    alias exec cl12 clear line 12
    alias exec cl13 clear line 13
    alias exec cl14 clear line 14
    alias exec cl15 clear line 15
    alias exec cl16 clear line 16
    alias exec tn telnet
    privilege exec level 0 clear line
    privilege exec level 1 clear
    !
    line con 0
    transport input none
    line 1 16
    no exec
    exec-timeout 0 0
    transport input all
    telnet break-on-ip
    telnet sync-on-break
    telnet ip-on-break
    flowcontrol hardware
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    password ******
    login
    autocommand menu cserver
    !
    end
    Looking for CCIE lab study partnerts, in the UK or Online.
Sign In or Register to comment.