HSRP Load Balancing
Hello guys,
i have two questions regarding HSRP Load Balancing.
=====================
Question #1
=====================
There is one vlan in network. one subnet for that one vlan. There are 2 Core Switches. Half of the traffic should pass through Core Switch-1 and the other half should pass through Core Switch-2.
vlan 10, subnet 10.10.10.0/24
For Load Balancing there will be two groups. Group 1, Group 2.
Group 1 Virtual IP = 10.10.10.1
Group 2 Virtual IP = 10.10.10.2
Configuration would be
Core Switch-1
interface vlan 10
ip address 10.10.10.3 255.255.255.0
standby 1 ip 10.10.10.1
standby 1 priority 150
standby 1 preempt
standby 2 ip 10.10.10.2
standby 2 priority 100
Core Switch-2
interface vlan 10
ip address 10.10.10.4 255.255.255.0
standby 1 ip 10.10.10.1
standby 1 priority 100
standby 2 ip 10.10.10.2
standby 2 priority 150
standby 2 preempt
Now the question is when I create DHCP pool for this network, it should be like below ?
ip dhcp pool LAN-1
network 10.10.10.0 255.255.255.128
default-router 10.10.10.1
dns-server ........
domain-name ..........
ip dhcp pool LAN-2
network 10.10.10.128 255.255.255.128
default-router 10.10.10.2
dns-server ......
domain-name ......
===================
Question-2
====================
Load Balancing for multiple vlans can be done easily on Multilayer switches by using SVIs.
like for example we have 2 vlans (Vlan 100, vlan 200).
Core Switch-1 active for vlan 100 and standby for vlan 200.
Core Switch 2 Active for vlan 200 and standby for vlan 100.
Core Switch-1
interface vlan 100
ip address 100.100.100.3 255.255.255.0
standby 100 ip 100.100.100.1
standby 100 preempt
standby 100 priority 150
interface vlan 200
ip address 200.200.200.3 255.255.255.0
standby 200 ip 200.200.200.1
standby 200 priority 100
Core Switch-2
interface vlan 100
ip address 100.100.100.4 255.255.255.0
standby 100 ip 100.100.100.1
standby 100 priority 100
interface vlan 200
ip address 200.200.200.3 255.255.255.0
standby 200 ip 200.200.200.1
standby 200 priority 150
standby 200 preempt
what if we want to do load balancing for multiple vlans and we have two routers instead of core switches ? how it can be done using Router interfaces ?
thank you for your time
i have two questions regarding HSRP Load Balancing.
=====================
Question #1
=====================
There is one vlan in network. one subnet for that one vlan. There are 2 Core Switches. Half of the traffic should pass through Core Switch-1 and the other half should pass through Core Switch-2.
vlan 10, subnet 10.10.10.0/24
For Load Balancing there will be two groups. Group 1, Group 2.
Group 1 Virtual IP = 10.10.10.1
Group 2 Virtual IP = 10.10.10.2
Configuration would be
Core Switch-1
interface vlan 10
ip address 10.10.10.3 255.255.255.0
standby 1 ip 10.10.10.1
standby 1 priority 150
standby 1 preempt
standby 2 ip 10.10.10.2
standby 2 priority 100
Core Switch-2
interface vlan 10
ip address 10.10.10.4 255.255.255.0
standby 1 ip 10.10.10.1
standby 1 priority 100
standby 2 ip 10.10.10.2
standby 2 priority 150
standby 2 preempt
Now the question is when I create DHCP pool for this network, it should be like below ?
ip dhcp pool LAN-1
network 10.10.10.0 255.255.255.128
default-router 10.10.10.1
dns-server ........
domain-name ..........
ip dhcp pool LAN-2
network 10.10.10.128 255.255.255.128
default-router 10.10.10.2
dns-server ......
domain-name ......
===================
Question-2
====================
Load Balancing for multiple vlans can be done easily on Multilayer switches by using SVIs.
like for example we have 2 vlans (Vlan 100, vlan 200).
Core Switch-1 active for vlan 100 and standby for vlan 200.
Core Switch 2 Active for vlan 200 and standby for vlan 100.
Core Switch-1
interface vlan 100
ip address 100.100.100.3 255.255.255.0
standby 100 ip 100.100.100.1
standby 100 preempt
standby 100 priority 150
interface vlan 200
ip address 200.200.200.3 255.255.255.0
standby 200 ip 200.200.200.1
standby 200 priority 100
Core Switch-2
interface vlan 100
ip address 100.100.100.4 255.255.255.0
standby 100 ip 100.100.100.1
standby 100 priority 100
interface vlan 200
ip address 200.200.200.3 255.255.255.0
standby 200 ip 200.200.200.1
standby 200 priority 150
standby 200 preempt
what if we want to do load balancing for multiple vlans and we have two routers instead of core switches ? how it can be done using Router interfaces ?
thank you for your time
Comments
-
networker050184 Mod Posts: 11,962 ModI wouldn't use HSRP in the first scenario. There are other protocols designed for this rather than hacking HSRP together.
You set it up exactly the same way on a router. Just use the interface that serves as the hosts gateway.An expert is a man who has made all the mistakes which can be made. -
razam Member Posts: 39 ■■□□□□□□□□how it can be done on router ?
using secondary keyword after the ip address is assigned.
for example in my scenario it would be like this ?
=========
Router-1
==========
interface gig 0/0
ip address 100.100.100.3 255.255.255.0
ip address 200.200.200.3 255.255.255.0 secondary
standby 100 ip 100.100.100.1
standby 100 preempt
standby 100 priority 150
standby 200 ip 200.200.200.1
standby 200 priority 100
=========
Router-2
==========
interface gig 0/0
ip address 100.100.100.4 255.255.255.0
ip address 200.200.200.4 255.255.255.0 secondary
standby 100 ip 100.100.100.1
standby 100 priority 100
standby 200 ip 200.200.200.1
standby 200 priority 150
standby 200 preempt
not sure about this solution with router .. please confirm. -
networker050184 Mod Posts: 11,962 ModWhen you use a router for 802.1q what are you going to create for each VLAN?An expert is a man who has made all the mistakes which can be made.
-
razam Member Posts: 39 ■■□□□□□□□□thank you for the suggestion, i got your point
have to create sub-interfaces (int gig 0/0.100 , int gig 0/0.200) with encapsulation dot1q vlan-id -
Jackace Member Posts: 335On your DHCP pool you should exclude the addresses you have statically assigned. Also the default router for each pool should be in the subnet defined by that pool.