Help with Network Share reconnect at login

TeKniquesTeKniques OSCE, OSCP, CISSP, CISA, SSCP, MCSE (03), Security+, Network+, A+, Project+Member Posts: 1,262 ■■■■□□□□□□
Hi everyone. I'm at the point where I want to kill Win 2000 and XP.

Situation: Several new PC's in the company (yes we just started upgrading to Win XP from 98 icon_redface.gif ) have mapped network drives to them that require user name and password to access. So they are all connected and mapped and work just fine.

Problem: Every friggin time the computer reboots you have to supply the password credentials for each damn mapped share. Why won't it just save the stuff and automatically login during reboot? Yes, I have selected the 'reconnect at login' option when mapping the drive and Yes I have tried the 'net use' command.

Ex: net use /persistent:yes

Here's the real kicker. I have a Windows 98 machine that has mapped network drives and when I choose the 'connect automatically at start up' option it remembers the password. So I must be missing something. Someone please help. icon_cool.gif

Thanks,
-TeK

Comments

  • jmc724jmc724 Member Posts: 415
    Are you in a win2000 domain environment? If yes create a group policy to map the drives its call the logon/logoff script.

    If not then get a dc.
    What next?
  • jheal00jheal00 Member Posts: 17 ■□□□□□□□□□
    The behavior you describe sounds like you are using Windows XP Home Edition. If that is the case, this is by design.
  • johnnynodoughjohnnynodough Member Posts: 634
    what type of box is hosting the shares?
    Go Hawks - 7 and 2

    2 games againts San Fran coming up, oh yeah baby, why even play? just put then in the win category and call it good :p
  • TeKniquesTeKniques OSCE, OSCP, CISSP, CISA, SSCP, MCSE (03), Security+, Network+, A+, Project+ Member Posts: 1,262 ■■■■□□□□□□
    jmc724 wrote:
    Are you in a win2000 domain environment? If yes create a group policy to map the drives its call the logon/logoff script.

    If not then get a dc.

    No we are using a Workgroup environment spread to 6 locations. Sweet isn't it icon_lol.gif
    jheal00 wrote:
    The behavior you describe sounds like you are using Windows XP Home Edition. If that is the case, this is by design.

    Yes, the machines are Win XP Home, but the problem is that the same thing happens on Windows 2000 Pro machines as well. We don't have any Win XP Pro licenses for me to check if that is the case there. But why can the Win 98 machines reconnect with no password prompt?
    what type of box is hosting the shares?

    Several: FreeBSD x 2, NCR-Unix, and Windows Server 2003 for the web share.

    I appreciate all the replies and suggestions. Thanks guys.
  • johnnynodoughjohnnynodough Member Posts: 634
    The reason Win98 has no password prompt is because it is treating the shares like NetBios shares, Win2k and XP prefer NTFS shares.
    Go Hawks - 7 and 2

    2 games againts San Fran coming up, oh yeah baby, why even play? just put then in the win category and call it good :p
  • johnnynodoughjohnnynodough Member Posts: 634
    Im pretty sure in Win2k there is a client you can install, client for unix systems or something to that effect, you have to enable it on the add/remove windows components. Im not seeing it by default on XP, but I am sure it is out there. You just need to enable XP and 2K to connect to a NetBios share.
    Go Hawks - 7 and 2

    2 games againts San Fran coming up, oh yeah baby, why even play? just put then in the win category and call it good :p
  • keatronkeatron Security Tinkerer Member Posts: 1,213 ■■■■■■□□□□
    What you are describing is a fundamental problem with workgroups. On the machine which hosts the share you are connecting to, create an account for each User trying to connect. This should take care of your issue.
  • johnnynodoughjohnnynodough Member Posts: 634
    That needs to be done on the windows boxes, but the devices that are hosting the shares are UNIX.
    Go Hawks - 7 and 2

    2 games againts San Fran coming up, oh yeah baby, why even play? just put then in the win category and call it good :p
  • TeKniquesTeKniques OSCE, OSCP, CISSP, CISA, SSCP, MCSE (03), Security+, Network+, A+, Project+ Member Posts: 1,262 ■■■■□□□□□□
    The reason Win98 has no password prompt is because it is treating the shares like NetBios shares, Win2k and XP prefer NTFS shares.

    Thank you that does explain it.
    keatron wrote:
    What you are describing is a fundamental problem with workgroups. On the machine which hosts the share you are connecting to, create an account for each User trying to connect. This should take care of your issue.

    Tell me about it, it's not fun. There are so many old clients using Win 95/98 that we have just started upgrading, but since we just buy new computers with Win XP home already installed we have to continue using workgroup. The company doesn't want to fork out the cash for Win XP pro licenses even though it's a mere upgrade with the new comps. I don't make these decisions icon_rolleyes.gif

    I will see if I can find something that Johnny was talking about with the netBIOS client. With the Win 2003 machine, if I create individual accounts even though were not on a domain this will work theoretically? I thought user accounts only applied to a domain environment, but hey, that's why I'm studying 290 right icon_lol.gif

    Thanks again for the suggestions, I will give them a try.
  • keatronkeatron Security Tinkerer Member Posts: 1,213 ■■■■■■□□□□
    Unix? I didn't read anything about Unix in the initial post.
  • johnnynodoughjohnnynodough Member Posts: 634
    With the Win 2003 machine, if I create individual accounts even though were not on a domain this will work theoretically?

    Is the only seamless way it will work for connecting to windows shares, of course besides having a domain.
    Go Hawks - 7 and 2

    2 games againts San Fran coming up, oh yeah baby, why even play? just put then in the win category and call it good :p
  • johnnynodoughjohnnynodough Member Posts: 634
    You intrigued my interest, so much so that I actually did a little checking around. You need to install "Services for UNIX"

    Win2k
    http://www.microsoft.com/technet/prodtechnol/windows2000pro/deploy/confeat/w2kpunix.mspx

    WinXP
    http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/Default.asp?url=/resources/documentation/Windows/XP/all/reskit/en-us/prci_unx_rjai.asp


    These in addition to Keatrons suggestion of configure identical user accounts (usernames and passwords of course) should make your drive mappings seamless.
    Go Hawks - 7 and 2

    2 games againts San Fran coming up, oh yeah baby, why even play? just put then in the win category and call it good :p
  • TeKniquesTeKniques OSCE, OSCP, CISSP, CISA, SSCP, MCSE (03), Security+, Network+, A+, Project+ Member Posts: 1,262 ■■■■□□□□□□
    Just thought I would update the situation.

    It is fixed thanks to Johnny and Keatron. Absolutely what they both said 100% corrects the problem if anyone has a similar problem.

    It's actually a little easier in Unix. Switch to root and create a user account with full permissions (the computer you are trying to connect to the share) and re-map the network share with those credentials and it works perfectly.

    Thanks again for your help guys. icon_cool.gif

    -TeK
Sign In or Register to comment.