Sub-interfaces Issue

Unidade01Unidade01 Posts: 22Member ■□□□□□□□□□
Hello,

I started studying this month for the ccna exam and I've found answers to most questions on the oddom book, but now i'm stuck on a lab I created with packet tracer!

I have two switches linked together by trunk ports and then both of them connected to a router. I was able to create sub interfaces for de first switch but when I try to create for the second I get a message saying the subnets overlap with the previous created sub interfaces!

Both switches have the same vlans, I was trying to have them both connected to the router for redundancy.

Any help would be much appreciated. Thanks

Comments

  • networker050184networker050184 Posts: 11,962Mod Mod
    You can't have two interfaces in the same subnet. Post up your configs and a diagram maybe we can show you where you went wrong.
    An expert is a man who has made all the mistakes which can be made.
  • Unidade01Unidade01 Posts: 22Member ■□□□□□□□□□
    I was trying replicate the fa 0/0 config on the Fa 1/0 hoping it would make redundant routes. It didn't went as expected.

    When i try to assign the ip 192.168.1.2 to the sub interface fa 1/0.10 the router says the subnets overlap

    FastEthernet0/0 unassigned YES unset up up

    FastEthernet0/0.10 192.168.1.1 YES manual up up

    FastEthernet0/0.20 192.168.2.1 YES manual up up

    FastEthernet0/0.30 192.168.3.1 YES manual up up


    FastEthernet1/0 unassigned YES unset administratively down down

    FastEthernet1/0.10 unassigned YES unset down down

    FastEthernet1/0.30 unassigned YES unset down down
  • Unidade01Unidade01 Posts: 22Member ■□□□□□□□□□
    so i gave up connecting the second switch to the router but i still can't ping between vlans. I can ping the sub-interfaces and the computers in the same vlans but not between vlans.

    the port in the switch is configured as a trunk

    Router config

    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.1.1 255.255.255.0
    !
    interface FastEthernet0/0.20
    encapsulation dot1Q 20
    ip address 192.168.2.1 255.255.255.0
    !
    interface FastEthernet0/0.30
    encapsulation dot1Q 30
    ip address 192.168.3.1 255.255.255.0
    !
    interface FastEthernet1/0
    no ip address
    duplex auto
    speed auto
    !
    interface Serial2/0
    no ip address
    clock rate 2000000
    shutdown
    !
    interface Serial3/0
    no ip address
    clock rate 2000000
    shutdown
    !
    interface FastEthernet4/0
    no ip address
    shutdown
    !
    interface FastEthernet5/0
    no ip address
    shutdown
    !
    ip classless
  • Vask3nVask3n Posts: 517Member
    Do the clients have their default gateway set to their respective subinterface?
    Working on MS-ISA at Western Governor's University
  • Mrock4Mrock4 Posts: 2,360Banned
    Check to make sure your router has a route to the other VLAN- ie:

    VLAN 10 route to VLAN 20 router:

    ip route 192.168.2.0 255.255.255.0 192.168.1.1

    You'll need to also ensure that your VLAN 20 router has a route back to VLAN 10.
  • Unidade01Unidade01 Posts: 22Member ■□□□□□□□□□
    Vask3n wrote: »
    Do the clients have their default gateway set to their respective subinterface?

    that was the problem now i can ping all computers in all vlans. Was so worried about the switch and router config that i overlooked something so simple!

    This shows the importance of labs! Seems simple in the book but try to implement and there will be a rock to make trip
Sign In or Register to comment.