EIGRP-Hub not distributing Spoke routes
mallyg27
Member Posts: 139
in CCNA & CCENT
I have a hub and spoke setup over frame relay with EIRP. For some reason my hub is not sending the routes it learned from spoke to the other spoke and vice versa. I disabled split-horizon and neighbors are formed correctly. Can Anyone see something wrong?
R1(Hub)
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
ip address 10.1.2.1 255.255.255.0
!
interface Loopback2
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.1 multipoint
ip address 172.16.124.1 255.255.255.248
no ip split-horizon
ip summary-address eigrp 25 10.1.0.0 255.255.252.0 5
snmp trap link-status
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.3 101 broadcast
no frame-relay inverse-arp
!
!
router eigrp 25
network 10.1.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
R2(Spoke)
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
interface Loopback0
ip address 10.3.1.1 255.255.255.0
!
interface Loopback1
ip address 10.3.2.1 255.255.255.0
!
interface Loopback2
ip address 10.3.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.1 multipoint
ip address 172.16.124.3 255.255.255.248
ip summary-address eigrp 25 10.3.0.0 255.255.252.0 5
snmp trap link-status
frame-relay map ip 172.16.124.1 201 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 25
network 10.3.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
R3(Spoke)
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.2.1.1 255.255.255.0
!
interface Loopback1
ip address 10.2.3.1 255.255.255.0
!
interface Loopback2
ip address 10.2.2.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.1 multipoint
ip address 172.16.124.2 255.255.255.248
ip summary-address eigrp 25 10.2.0.0 255.255.252.0 5
snmp trap link-status
frame-relay map ip 172.16.124.1 202 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 25
network 10.2.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
R1(Hub)
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
ip address 10.1.2.1 255.255.255.0
!
interface Loopback2
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.1 multipoint
ip address 172.16.124.1 255.255.255.248
no ip split-horizon
ip summary-address eigrp 25 10.1.0.0 255.255.252.0 5
snmp trap link-status
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.3 101 broadcast
no frame-relay inverse-arp
!
!
router eigrp 25
network 10.1.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
R2(Spoke)
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
interface Loopback0
ip address 10.3.1.1 255.255.255.0
!
interface Loopback1
ip address 10.3.2.1 255.255.255.0
!
interface Loopback2
ip address 10.3.3.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.1 multipoint
ip address 172.16.124.3 255.255.255.248
ip summary-address eigrp 25 10.3.0.0 255.255.252.0 5
snmp trap link-status
frame-relay map ip 172.16.124.1 201 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 25
network 10.3.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
R3(Spoke)
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 10.2.1.1 255.255.255.0
!
interface Loopback1
ip address 10.2.3.1 255.255.255.0
!
interface Loopback2
ip address 10.2.2.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.1 multipoint
ip address 172.16.124.2 255.255.255.248
ip summary-address eigrp 25 10.2.0.0 255.255.252.0 5
snmp trap link-status
frame-relay map ip 172.16.124.1 202 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 25
network 10.2.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
Comments
-
Zartanasaurus Member Posts: 2,008 ■■■■■■■■■□Real hardware/GNS3 or packet tracer? As I learned in another thread some time ago, packet tracer doesn't (didn't) support the eigrp version of no split-horizon.Currently reading:
IPSec VPN Design 44%
Mastering VMWare vSphere 5 42.8% -
Gngogh Member Posts: 165 ■■■□□□□□□□it is very wierd how packet tracer works, on a frame-relay multipoint network you have to disable split-horizon on the interface for the routes to propagate, but in packet tracer you dont need to, the routes will propagate with split-horizon enable, in fact you cannot disable it in packet tracer.