GNS3 up/up
I am doing the labs from the cisco handbook. This is the 4th one I have done lab.
Is there the possibility of a GNS3 bug that would cause an interface to drop to up/down 30 secs after going to up/up when it is activated.
I know GNS3 ignores the clock rates but I tried taking that on and off too.
I am using the configs from the book. R1-R2 is fine. R2-R3
R3(config)#in s1/1
R3(config-if)#no sh
R3(config-if)#shut
R3(config-if)#no
*Mar 1 00:31:08.783: %LINK-5-CHANGED: Interface Serial1/1, changed state to administratively down
R3(config-if)#no shut
R3(config-if)#
*Mar 1 00:31:16.911: %LINK-3-UPDOWN: Interface Serial1/1, changed state to up
*Mar 1 00:31:17.911: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up
R3(config-if)#
*Mar 1 00:31:42.327: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to down
c3725-adventerprisek9-mz.124-12.image
R2:
Current configuration : 1682 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 192.168.200.1 255.255.255.252
!
interface Loopback5
ip address 192.168.200.5 255.255.255.252
!
interface Loopback9
ip address 192.168.200.9 255.255.255.252
!
interface Loopback13
ip address 192.168.200.13 255.255.255.252
!
interface Loopback17
ip address 192.168.200.17 255.255.255.252
!
interface Loopback21
ip address 192.168.200.21 255.255.255.252
!
interface Loopback25
ip address 192.168.200.25 255.255.255.252
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
bandwidth 64
ip address 192.168.100.2 255.255.255.248
serial restart-delay 0
!
interface Serial1/1
bandwidth 64
ip address 10.1.1.2 255.255.255.248
serial restart-delay 0
clock rate 64000
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 100
network 10.0.0.0
network 192.168.100.0
network 192.168.200.0
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R3:
Current configuration : 1737 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 192.168.1.1 255.255.254.0
!
interface Loopback5
ip address 192.168.5.5 255.255.254.0
!
interface Loopback9
ip address 192.168.9.9 255.255.254.0
!
interface Loopback13
ip address 192.168.13.13 255.255.254.0
!
interface Loopback17
ip address 192.168.17.17 255.255.254.0
!
interface Loopback21
ip address 192.168.21.21 255.255.254.0
!
interface Loopback25
ip address 192.168.25.25 255.255.254.0
!
interface Loopback100
ip address 10.1.3.1 255.255.255.252
!
interface Loopback172
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
bandwidth 64
ip address 10.1.1.3 255.255.255.248
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 100
network 10.0.0.0
network 172.16.0.0
network 192.168.0.0 0.0.31.255
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
thanks !
Is there the possibility of a GNS3 bug that would cause an interface to drop to up/down 30 secs after going to up/up when it is activated.
I know GNS3 ignores the clock rates but I tried taking that on and off too.
I am using the configs from the book. R1-R2 is fine. R2-R3
R3(config)#in s1/1
R3(config-if)#no sh
R3(config-if)#shut
R3(config-if)#no
*Mar 1 00:31:08.783: %LINK-5-CHANGED: Interface Serial1/1, changed state to administratively down
R3(config-if)#no shut
R3(config-if)#
*Mar 1 00:31:16.911: %LINK-3-UPDOWN: Interface Serial1/1, changed state to up
*Mar 1 00:31:17.911: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up
R3(config-if)#
*Mar 1 00:31:42.327: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to down
c3725-adventerprisek9-mz.124-12.image
R2:
Current configuration : 1682 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 192.168.200.1 255.255.255.252
!
interface Loopback5
ip address 192.168.200.5 255.255.255.252
!
interface Loopback9
ip address 192.168.200.9 255.255.255.252
!
interface Loopback13
ip address 192.168.200.13 255.255.255.252
!
interface Loopback17
ip address 192.168.200.17 255.255.255.252
!
interface Loopback21
ip address 192.168.200.21 255.255.255.252
!
interface Loopback25
ip address 192.168.200.25 255.255.255.252
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
bandwidth 64
ip address 192.168.100.2 255.255.255.248
serial restart-delay 0
!
interface Serial1/1
bandwidth 64
ip address 10.1.1.2 255.255.255.248
serial restart-delay 0
clock rate 64000
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 100
network 10.0.0.0
network 192.168.100.0
network 192.168.200.0
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R3:
Current configuration : 1737 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 192.168.1.1 255.255.254.0
!
interface Loopback5
ip address 192.168.5.5 255.255.254.0
!
interface Loopback9
ip address 192.168.9.9 255.255.254.0
!
interface Loopback13
ip address 192.168.13.13 255.255.254.0
!
interface Loopback17
ip address 192.168.17.17 255.255.254.0
!
interface Loopback21
ip address 192.168.21.21 255.255.254.0
!
interface Loopback25
ip address 192.168.25.25 255.255.254.0
!
interface Loopback100
ip address 10.1.3.1 255.255.255.252
!
interface Loopback172
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
bandwidth 64
ip address 10.1.1.3 255.255.255.248
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 100
network 10.0.0.0
network 172.16.0.0
network 192.168.0.0 0.0.31.255
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
thanks !
Comments
I tried a fresh interface with just ip address configured manually with the same result.
I saw this here:
GNS3 • View topic - FAQ and Known Issues
"
Why my serial connection works though the interfaces are both DCE?
GNS3/Dynamips doesn't emulate the physical layer which is why the serial connections work even though they are both DCE."
c3725-adventerprisek9-mz.124-12.image
thanks
I fixed it by loading another slot of serial interfaces.
How often do people have buggy issues with GNS3 ?