Options

Having problem line protocol is down

kadshahkadshah Member Posts: 388 ■■■□□□□□□□
This is driving me nuts. I've successfully configured eigrp many times
but for some reason I can't get it to work this time maybe someone could help me locate the problem. I'm using RouterSim Vis 5.0.
I just created a small network of 4 routers. Here is the name and IP of each router:

Bob-
s0/0 192.168.10.1 255.255.255.252
s0/1 192.168.10.13 255.255.255.252

Susan-
s0/0 192.168.10.2 255.255.255.252
s0/1 192.168.10.5 255.255.255.252

Jenny-
s0/0 192.168.10.6 255.255.255.252
s0/1 192.168.10.9 255.255.255.252

Jack-
s0/0 192.168.10.10 255.255.255.252
s0/1 192.168.10.14 255.255.255.252


I've turned on EIGRP AS 10 on all routers and advertised the network number. In the sh ip route nothing is coming up and when I run the sh ip int I get serial line up protocol down.
I think it might be the DCE/DTE. I've run the sh controller on each router
but still I'm unsure about how this should be setup. I know that a back to back router one should be DCE the other DTE but how should this be setup when you have 4 routers in a loop environment?





BOB Con0 is now available



Press RETURN to get started!



BOB>en
BOB#sh run

Building configuration...
Current configuration : 625 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname BOB
!
!
!
ip subnet-zero
!
!
!
!
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/0
ip address 192.168.10.1 255.255.255.252
no ip directed-broadcast
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/1
ip address 192.168.10.13 255.255.255.252
no ip directed-broadcast
!
router eigrp 10
network 192.168.10.0
!
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end








SUSAN Con0 is now available



Press RETURN to get started!



SUSAN>en
SUSAN#sh run

Building configuration...
Current configuration : 625 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SUSAN
!
!
!
ip subnet-zero
!
!
!
!
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/0
ip address 192.168.10.2 255.255.255.252
no ip directed-broadcast
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/1
ip address 192.168.10.5 255.255.255.252
no ip directed-broadcast
!
router eigrp 10
network 192.168.10.0
!
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end







JENNY Con0 is now available



Press RETURN to get started!



JENNY>en
JENNY#sh run

Building configuration...
Current configuration : 625 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname JENNY
!
!
!
ip subnet-zero
!
!
!
!
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/0
ip address 192.168.10.6 255.255.255.252
no ip directed-broadcast
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/1
ip address 192.168.10.9 255.255.255.252
no ip directed-broadcast
!
router eigrp 10
network 192.168.10.0
!
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end






JACK Con0 is now available



Press RETURN to get started!



JACK>en
JACK#sh run

Building configuration...
Current configuration : 625 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname JACK
!
!
!
ip subnet-zero
!
!
!
!
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/0
ip address 192.168.10.10 255.255.255.252
no ip directed-broadcast
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/1
ip address 192.168.10.14 255.255.255.252
no ip directed-broadcast
!
router eigrp 10
network 192.168.10.0
!
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Comments

  • Options
    HumperHumper Member Posts: 647
    Did you set the clock rate on one of the serial interfaces? DCE router will have a clock rate of xxx and the DTE router will ajust to that value accordingly. You only need to set it on one router.
    Now working full time!
  • Options
    loboernestoloboernesto Member Posts: 94 ■■□□□□□□□□
    You only need to set it on one router.

    ^^that's right, but maybe a bit confusing. You need to set the clock rate on one interface for each each pair of DCE/DTE serial interfaces. If you have 4 routers connected as you said, four of the serial interfaces must have the clock rate command entered (the DCE interfaces). If you did the show controllers serial x you will know which ones are the DCE interfaces that need to be configured with the command.
    Cheers.[/quote]
  • Options
    kadshahkadshah Member Posts: 388 ■■■□□□□□□□
    This is what I have. Any other suggestions?


    Jack-
    s0/0 DTE
    s0/1 DCE

    Bob-
    s0/0 DCE
    s0/1 DTE

    Jenny-
    s0/1 DCE
    s0/0 DTE

    Susan-
    s0/1 DCE
    s0/1 DTE

    No output on the sh ip route. icon_cry.gif



    xlc37571.jpg
  • Options
    kadshahkadshah Member Posts: 388 ■■■□□□□□□□
    Here's some more info with the sh ip protocols command.


    SUSAN#sh ip protocols
    Routing Protocol is "eigrp 10"
    Outgoing update filter list for all interfaces is not set
    Incoming update filter list for all interfaces is not set
    Default networks flagged in outgoing updates
    Default networks accepted from incoming updates
    EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    EIGRP maximum hop count 100
    EIGRP maximum metric variance 1
    Redistributing: eigrp 10
    Automatic network summarization is in effect
    Maximum path: 4
    Routing for networks:
    192.168.10.0
    192.168.10.4
    Routing information sources:
    Gateway Distance Last Update
    Distance: internal 90 external 170



    JENNY>en
    JENNY#sh ip protocols
    Routing Protocol is "eigrp 10"
    Outgoing update filter list for all interfaces is not set
    Incoming update filter list for all interfaces is not set
    Default networks flagged in outgoing updates
    Default networks accepted from incoming updates
    EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    EIGRP maximum hop count 100
    EIGRP maximum metric variance 1
    Redistributing: eigrp 10
    Automatic network summarization is in effect
    Maximum path: 4
    Routing for networks:
    192.168.10.4
    192.168.10.8
    Routing information sources:
    Gateway Distance Last Update
    Distance: internal 90 external 170

    BOB>en
    BOB#sh ip protocols
    Routing Protocol is "eigrp 10"
    Outgoing update filter list for all interfaces is not set
    Incoming update filter list for all interfaces is not set
    Default networks flagged in outgoing updates
    Default networks accepted from incoming updates
    EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    EIGRP maximum hop count 100
    EIGRP maximum metric variance 1
    Redistributing: eigrp 10
    Automatic network summarization is in effect
    Maximum path: 4
    Routing for networks:
    192.168.10.0
    192.168.10.12
    Routing information sources:
    Gateway Distance Last Update
    Distance: internal 90 external 170


    JACK>en
    JACK#sh ip protocols
    Routing Protocol is "eigrp 10"
    Outgoing update filter list for all interfaces is not set
    Incoming update filter list for all interfaces is not set
    Default networks flagged in outgoing updates
    Default networks accepted from incoming updates
    EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    EIGRP maximum hop count 100
    EIGRP maximum metric variance 1
    Redistributing: eigrp 10
    Automatic network summarization is in effect
    Maximum path: 4
    Routing for networks:
    192.168.10.12
    192.168.10.8
    Routing information sources:
    Gateway Distance Last Update
    Distance: internal 90 external 170
  • Options
    darwinismdarwinism Member Posts: 59 ■■□□□□□□□□
    serial line up protocol down has nothing to do with how you configure EIGRP. Can you do a "show cdp neighbors". If not, then you are trying to troubleshoot one layer too high. As other people have mentioned, check your clock-rate and encapsulation configurations. It appears your problem lies @ layer 2 and not 3.
    If you are living in the Columbus, OH area and studying for the CCNA click the following link.

    CCNA looking for study partners in Columbus, OH
  • Options
    mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    kadshah wrote:
    No output on the sh ip route.
    Did you get past the protocol down issues? Are you now working on a different routing issue?

    When I do configurations like that (real routers or simulator), I usually connect Serial 0 on one router to Serial 1 on another router -- and just make all Serial 0 the DCE end. Saved time figuring out router name and cable connections so I could just concentrate on trying new stuff.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • Options
    HumperHumper Member Posts: 647
    Could also be the simulator but I highly doubt you have configured the clock rates correctly as I do not see them in your configurations.
    Now working full time!
  • Options
    wildfirewildfire Member Posts: 654
    the command sh int controller will shot you if the end is DCE or DTE,
    Looking for CCIE lab study partnerts, in the UK or Online.
  • Options
    kadshahkadshah Member Posts: 388 ■■■□□□□□□□
    It's working now. Funny cause I did set the clock rate twice and it
    didn't work. I just got home rebooted my rig and set the clock rate again
    and it worked. icon_rolleyes.gif Maybe the simulator is a little buggy. Thanks anyway for your all your help
    I usually connect Serial 0 on one router to Serial 1 on another router -- and just make all Serial 0 the DCE end.
    Nice little tip icon_cool.gif

    Peace smiles,

    -k
  • Options
    mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    kadshah wrote:
    It's working now. Funny cause I did set the clock rate twice and it didn't work.
    I like the interface on RouterSim... but I had more problems with functionality than with Boson -- and I gave up on Boson. And it's annoying debugging problems only to find out they are flakey software problems -- not router configuration problems.

    I still like the concept of the simulators -- they just still don't seem to have delivered on their marketing.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • Options
    SkribblaSkribbla Member Posts: 1 ■□□□□□□□□□
    serial up, line down is a clocking, framing or encapsualtion pronlem. you have on your list of info 4 routers each with dce and dte.. on each communicating device (all four of em) on serial 0/0 of all four routers put clock rate 64 and see the magic
Sign In or Register to comment.