CCNPv7 Skill based exam question

k31453k31453 Member Posts: 34 ■■□□□□□□□□
Has anyone got configuration for CCNPv7 Sba(skill based assessment) answers?

I am struggling with IPV6 for BGP.

Comments

  • negru_tudornegru_tudor Senior Member Member Posts: 473 ■■■□□□□□□□
    is this netacad stuff or something? not a lot of people (that I know of anyway) go for netacad studies after CCNA..mostly either do self-study, bootcamps or a mix.
    2017-2018 goals:
    [X] CIPTV2 300-075
    [ ] SIP School SSCA
    [X] CCNP Switch 300-115 [X] CCNP Route 300-101 [X] CCNP Tshoot 300-135
    [ ] LPIC1-101 [ ] LPIC1-102 (wishful thinking)
  • fredrikjjfredrikjj Member Posts: 879
    What kind of problem are you having with IPv6 and BGP?
  • k31453k31453 Member Posts: 34 ■■□□□□□□□□
    fredrikjj wrote: »
    What kind of problem are you having with IPv6 and BGP?

    I have given this topology:



    Following instructions were given:

    MP-BGP
    1. Enable EBGP between R3 and R4. R3 is in BGP AS 65101 with the router ID 3.3.3.3 and R4 is in BGP AS 65401 with the router ID 4.4.4.4.
    2. Advertise R3’s G0/0 interface and R4’s G0/0 interface for IPv4 and IPv6 into BGP.
    3. Modify the weight attributes on R3 and R4 so that both routers prefer the primary link between autonomous systems.


    OSPFv3 with Address Families
    1. On R2 and R3 configure the OSPFv3 address families for IPv4 and IPv6. Use the router identifier 2.2.2.2 on R2 and 3.3.3.3 on R3 for both address families.
    2. On R2, enable the G0/0 interface G0/0 in OSPF area 1 and the connection between R2 and R3 in OSPF area 0.
    3. On R3, enable the G0/0 interface G0/0 in OSPF area 0 and the connection between R2 and R3.
    4. Although there are no other routers in area 1, configure area 1 as a totally stubby area.
    5. Propagate an IPv4 and IPv6 default route from R3 into the OSPFv3 domain. Note: No default IPv4 or IPv6 static routes are configured on R3.

    I have sort out how to do ospf however, How i can configure BGP.

    Does instruct specify to run ipv6 and ipv4 session differently on BGP or I have to choose either to run ipv6 traffic over IPv4 or vise versa.
    Also, if I choose to carry ipv6 traffic over ipv4 should I use loopback address as sending bgp traffic (i.e. update-source) or should I choose connected link.

    How do I configure this when we have redundant link ?

    Should I configure this topology like below example?
  • fredrikjjfredrikjj Member Posts: 879
    1. I have sort out how to do ospf however, How i can configure BGP. Does instruct specify to run ipv6 and ipv4 session differently on BGP or I have to choose either to run ipv6 traffic over IPv4 or vise versa.

    You can run ipv6 over an ipv4 BGP session by going to the ipv6 address family and activating the neighbor. It looks something like this:

    router bgp 100
    neighbor 192.168.1.1 remote-as 200
    address-family ipv6 unicast
    neighbor 192.168.1.1 activate

    However, you'll run into issues with the BGP IPv6 next hop of the IPv6 prefixes that you receive over this session. In IOS, they will get the invalid next hop ::FFFF:192.168.1.1, which is not a valid next hop. You can fix this by configuring an inbound route map that adjusts the next hop of IPv6 prefixes to a valid global IPv6 address, however, that seems really ugly to me. Instead, configure 1 IPv6 BGP session and 1 IPv4 session and use them for their respective address families. It'll probably look very similar to this:

    router bgp 100
    no bgp default ipv4-unicast
    neighbor 192.168.1.1 remote-as 200
    neighbor 2001:2:3::4 remote-as 200
    address-family ipv4 unicast
    neighbor 192.168.1.1 activate
    address-family ipv6 unicast
    neighbor 2001:2:3::4 activate

    By doing it this way, the next hop values follow standard BGP behavior.

    2. Also, if I choose to carry ipv6 traffic over ipv4 should I use loopback address as sending bgp traffic (i.e. update-source) or should I choose connected link.

    Whether you use loopback addresses as update-source depends on what kind of topology that you have. It's not a specific issue with regards to IPv6 prefixes over an IPv4 session.

    3. How do I configure this when we have redundant link ? Should I configure this topology like below example?

    You have 2 different scenarios there, one is eBGP and the other is iBGP. This changes BGP's default handling of the TTL of packets and this in turn changes how you configure the sessions when you have redundant links (notice the ebgp-multihop command in one of the examples). There is also the issue of IGP routing domains which impacts how the BGP routers discover the route to their neighbor's loopback. You need static routes in one of the examples, but not in the other, why?
  • spiderjerichospiderjericho CCNA, CCNP Enterprise, CISSP, CASP, SEC+, Pentest+, CYSA+, CISA, CGEIT, CRISC, CISM, VCP 6.7 San DiegoRegistered Users, Member Posts: 869 ■■■■■□□□□□
    Let's just make sure we're not assisting in solving a quiz/test problem for the OP. Not trying to flame but as a former/current Netacad instructor, some of us actually use SBA for grading. Some do not, so if that's the case I apologize.
Sign In or Register to comment.