VTP Question

iprouteiproute Member Posts: 269
I have two 2912 XL switches and I simply can't get VTP to replicate vlan info from one switch to another. I can't figure out what I'm doing wrong. Any help would be appreciated.

I've set one switch to VTP client (SW_B) and one to VTP server (SW_A). I've set the VTP domain and VTP domain password (optional, I know). The two switches are connected to each other via a cross-over cable on FA0/8 (both switches). A router isn't required, is it?

Here's the config and relevant info:

SW-A: SHOW RUN
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Switch_A
!
enable secret 5 XXX
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/9
 switchport access vlan 2
!
interface FastEthernet0/10
 switchport access vlan 2
!
interface FastEthernet0/11
 switchport access vlan 2
!
interface FastEthernet0/12
 switchport access vlan 2
!
interface VLAN1
 ip address 10.7.82.251 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
!
line con 0
 password 7 XXX
 login
 transport input none
 stopbits 1
line vty 0 4
 password 7 XXX
 login
line vty 5 15
 password 7 XXX
 login
!
end

SW-A Other:
Switch_A#show vtp status
VTP Version                     : 2
Configuration Revision          : 9
Maximum VLANs supported locally : 68
Number of existing VLANs        : 6
VTP Operating Mode              : Server
VTP Domain Name                 : stuff
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Enabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x16 0xFF 0x63 0x8E 0x7D 0xD4 0x55 0x74
Configuration last modified by 10.7.82.251 at 3-1-93 02:39:51

Switch_A#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
2    VLAN0002                         active    Fa0/9, Fa0/10, Fa0/11, Fa0/12
1002 fddi-default                     active
1003 trcrf-default                    active
1004 fddinet-default                  active
1005 trbrf-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 trcrf 101003     4472  1005   3276   -        -    srb      0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trbrf 101005     4472  -      -      15       ibm  -        0      0

VLAN AREHops STEHops Backup CRF
---- ------- ------- ----------
1003 7       7       off

SW-B: SHOW RUN
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Switch_B
!
enable secret 5 XXX
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface VLAN1
 ip address 10.7.82.252 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
!
line con 0
 password 7 XXX
 login
 transport input none
 stopbits 1
line vty 0 4
 password 7 XXX
 login
line vty 5 15
 password 7 XXX
 login
!
end

SW-B Other:
Switch_B#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 68
Number of existing VLANs        : 5
VTP Operating Mode              : Client
VTP Domain Name                 : stuff
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Enabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x03 0x4F 0xD8 0xA5 0x68 0xF2 0xC8 0xE8
Configuration last modified by 10.7.82.252 at 3-1-93 01:03:39

Switch_B#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
1002 fddi-default                     active
1003 trcrf-default                    active
1004 fddinet-default                  active
1005 trbrf-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 trcrf 101003     4472  1005   3276   -        -    srb      0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trbrf 101005     4472  -      -      15       ibm  -        0      0

VLAN AREHops STEHops Backup CRF
---- ------- ------- ----------
1003 7       7       off

Am I confused about what VTP does?

1,000,000 apologizes if this is something dumb and simply overlooked.
CCNP Progress
ROUTE [X] :: SWITCH [X] :: TSHOOT [X]

Comments

  • DW [banned]DW [banned] Inactive Imported Users Posts: 240
  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    iproute wrote:
    I've set the VTP domain and VTP domain password (optional, I know).
    Switch_A#show vtp status
    MD5 digest                      : 0x16 0xFF 0x63 0x8E 0x7D 0xD4 0x55 0x74
    
    Switch_B#show vtp status
    MD5 digest                      : 0x03 0x4F 0xD8 0xA5 0x68 0xF2 0xC8 0xE8
    

    If you had the same password on each switch, shouldn't the MD5 hashes should be the same?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • iprouteiproute Member Posts: 269
    mikej412 wrote:
    iproute wrote:
    I've set the VTP domain and VTP domain password (optional, I know).
    Switch_A#show vtp status
    MD5 digest                      : 0x16 0xFF 0x63 0x8E 0x7D 0xD4 0x55 0x74
    
    Switch_B#show vtp status
    MD5 digest                      : 0x03 0x4F 0xD8 0xA5 0x68 0xF2 0xC8 0xE8
    

    If you had the same password on each switch, shouldn't the MD5 hashes should be the same?

    Perhaps, but see below. I'm not 100% sure.

    stuff.jpg
    CCNP Progress
    ROUTE [X] :: SWITCH [X] :: TSHOOT [X]
  • DW [banned]DW [banned] Inactive Imported Users Posts: 240
  • mwgoodmwgood Member Posts: 293
    It might be that you have not yet enabled trunking.

    Try switchport mode trunk on both switches for your trunk link.
  • iprouteiproute Member Posts: 269
    mwgood wrote:
    It might be that you have not yet enabled trunking.

    Try switchport mode trunk on both switches for your trunk link.
    Both switches have trunking enabled on int fa0/8.
    CCNP Progress
    ROUTE [X] :: SWITCH [X] :: TSHOOT [X]
  • mwgoodmwgood Member Posts: 293
    iproute wrote:
    Both switches have trunking enabled on int fa0/8.

    Not according to the output in your show vlan brief commands. What you posted for the results for that command indicates that the fa0/8 ports are access ports in vlan 1.

    "switchport trunk encapsulation dot1q" is the only command on fa0/8 that you list in your config - which is not sufficient to turn on trunking.

    Please try a "show int status" to verify trunking.
  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    iproute wrote:
    mwgood wrote:
    It might be that you have not yet enabled trunking.

    Try switchport mode trunk on both switches for your trunk link.
    Both switches have trunking enabled on int fa0/8.
    In your original post you have the trunking encapsulation set..... and that's it. The 2912's probably predate DTP (Dynamic Trunking Protocol) so you have to manually tell the port to be a trunk with the switchport mode trunk command.
    switchport trunk encap isl
    switchport mode trunk

    sh int trunk
    Darby's sample used isl encapsulation (and the range command which you don't have). And as Darby showed -- use the show interfaces trunk command to verify the establishment of the trunk.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • iprouteiproute Member Posts: 269
    Alas, the problem is discovered. I would have swore up and down a few minutes ago that the "switchport mode trunk" command didn't work on these switches. I was under the assumption that enabling trunk encapsulation automatically enabled trunking. Anyway, output of show int status:
    Switch_A#show int status
    
    Port    Name               Status       Vlan     Duplex Speed   Type
    ------- ------------------ ------------ -------- ------ ------- ----
    Fa0/1                      connected    1        A-Full   A-100 100BaseTX/FX
    Fa0/2                      connected    1        A-Full   A-100 100BaseTX/FX
    Fa0/3                      notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/4                      notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/5                      notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/6                      notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/7                      notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/8                      connected    trunk    A-Full   A-100 100BaseTX/FX
    Fa0/9                      notconnect   2          Auto    Auto 100BaseTX/FX
    Fa0/10                     notconnect   2          Auto    Auto 100BaseTX/FX
    Fa0/11                     notconnect   2          Auto    Auto 100BaseTX/FX
    Fa0/12                     notconnect   2          Auto    Auto 100BaseTX/FX
    
    
    Switch_B#show int status
    
    Port    Name               Status       Vlan     Duplex Speed   Type
    ------- ------------------ ------------ -------- ------ ------- ----
    Fa0/1                      connected    1        A-Half    A-10 100BaseTX/FX
    Fa0/2                      connected    1        A-Half    A-10 100BaseTX/FX
    Fa0/3                      notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/4                      notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/5                      notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/6                      notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/7                      notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/8                      connected    trunk    A-Full   A-100 100BaseTX/FX
    Fa0/9                      notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/10                     notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/11                     notconnect   1          Auto    Auto 100BaseTX/FX
    Fa0/12                     notconnect   1          Auto    Auto 100BaseTX/FX
    


    VTP is now working! Note that VLAN0002 now exists on switch-b as well.
    Switch_A#show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7
    2    VLAN0002                         active    Fa0/9, Fa0/10, Fa0/11, Fa0/12
    
    
    Switch_B#show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/9,
                                                    Fa0/10, Fa0/11, Fa0/12
    2    VLAN0002                         active
    

    Thanks for the help guys; it's much appreciated!
    CCNP Progress
    ROUTE [X] :: SWITCH [X] :: TSHOOT [X]
  • mwgoodmwgood Member Posts: 293
    Excellent.

    Notice that fa0/8 no longer appears in your show vlan output. When a port becomes a trunk - it is no longer assigned to a vlan, so it is an indication that trunking has been turned on when it disappears from the sh vlan brief output. It follows that if the port IS listed, then it's NOT a trunk.

    Also - show int status is a very useful command to get a quick overview of your switch ports.
  • Paul BozPaul Boz Member Posts: 2,620 ■■■■■■■■□□
    #show interface trunk

    is another good "show" command for learning about switchport status.
    CCNP | CCIP | CCDP | CCNA, CCDA
    CCNA Security | GSEC |GCFW | GCIH | GCIA
    pbosworth@gmail.com
    http://twitter.com/paul_bosworth
    Blog: http://www.infosiege.net/
  • iprouteiproute Member Posts: 269
    Show Int Status is actually a command that I hadn't used prior to this exercise icon_redface.gif

    Thanks for helping out with that.

    Show Int Trunk doesn't work on the 2912-XL-EN, unless I'm typoing again heh. I did VPN into work to test it on my 2950's there, where it worked.

    Thanks for all the help.
    CCNP Progress
    ROUTE [X] :: SWITCH [X] :: TSHOOT [X]
  • NetstudentNetstudent Member Posts: 1,693 ■■■□□□□□□□
    wow, what an informational thread.
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • markzabmarkzab Member Posts: 619
    Netstudent wrote:
    wow, what an informational thread.

    Agreed. Sticky this. icon_idea.gif

    icon_wink.gif
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
Sign In or Register to comment.