Laptop + DHCP problem

DannybearDannybear Member Posts: 21 ■□□□□□□□□□
Fellow IT Monkeys..

I have a Dell Laptop with windows XP Home installed, and for some obsecure reason it will not pick up a IP address from any network - even ones i know work!

Run down of whats happened:

User had loads of spyware on the laptop, so ran adaware, spybot etc all worked fine after that. Took it back to the house and plugged it into router. Its a talktalk router and the user said they would speak to talktalk directly to reset it up. No problem i said and left.

All went wrong from i'm not sure what the talktalk people got them to do, but now it wont obtain a IP address from a DHCP server / router. This is either wireless or plugged directly into a router. At first i thought it might be the talktalk router at fault so i took a draytek vigor round to test. Plugged router into laptop - didnt work. Took laptop home to my wireless network still wont get a IP address and now in my office the same thing is happening. Gives it a 169 address.

i have:
disabled / enabled both wireless and network card
ipconfig /release and renew
Set laptop to obtain ip and dns automatically (even if you put a manual one in still dosnt work)
Tried a route print as the dell network assistant said it was a problem with the routing on the good that is i dont know though

I'm stumped!



  • sprkymrksprkymrk Member Posts: 4,884 ■■■□□□□□□□
    If it's not a harware problem try this from a cmd prompt:

    netsh interface ip reset C:\iplog.txt

    The last part is a log file, you can direct it anywhere and call it whatever you want (C:\Temp\myfile.txt, etc.) but it is a required parameter.

    This is the same as removing and reinstalling TCP/IP.

    If it is a routing problem (doubtful) do this:

    route delete *
    All things are possible, only believe.
  • DannybearDannybear Member Posts: 21 ■□□□□□□□□□
    Thanks for that - i have done the command, rebooting laptop now just incase and see what happens. Am i meant to do anything else after typing that command?
  • shednikshednik Member Posts: 2,005
    Actually I was told after clearing tcp/ip its recommened you reboot, any way after that you should be good...if not

    I'd try removing the device formt he device manager and resinstalling the drivers...if its giving a 169 address from apipa when it should recieve an ip from dhcp it sounds like a device issue to me. try the latest drivers and let us know how that goes for ya!
  • Megadeth4168Megadeth4168 Member Posts: 2,157
    Another thing to try if all else fails is to run Winsockxpfix... Run a Google search for this utility, it's free and has worked for me in the past.

    Good Luck!
  • KGhaleonKGhaleon Member Posts: 1,346 ■■■□□□□□□□
    Running the WinsockFix has helped me in the past. If that doesn't work, I'd suggest reinstalling the drivers for that device.

    I did have one strange occurence when using winsockfix with a customer who brought his company laptop to me(why didn't he take it to his companies IT department? bah). He had practically a dozen domains listed, which he could sign into. When I did the Winsockfix, over half those domains disappeared and it had to be completely reconfigured by his company since it wouldn't allow us to sign in.

    Present goals: MCAS, MCSA, 70-680
  • thesemantheseman Member Posts: 230
    I agree with the WinSockFix utility suggestions. If that doesn't work, like mentioned before, trying uinstalling/reinstalling the network drivers. Though, the fact that both the wireless and wired cards are having an issue is a bit disconcerting.
  • KGhaleonKGhaleon Member Posts: 1,346 ■■■□□□□□□□
    Do you have another laptop that you can test? If it's happening on both interfaces then it may just be the network device.

    Present goals: MCAS, MCSA, 70-680
  • DannybearDannybear Member Posts: 21 ■□□□□□□□□□
    I tried the command as listed above, rebooted but still no joy. I have my own laptop sat next to me which works at my house and on my company LAN.

    I'm going to try the others now - thanks guys, really appreciate it icon_cool.gif
  • DannybearDannybear Member Posts: 21 ■□□□□□□□□□
    woohoo...Seems to be working, using both the wireless and with a CAT5 cable plugged in.

    I removed both cards, downloaded drivers from Dell website and reinstalled, ran the winsockfix utility and it seems to be working icon_cool.gif
  • shednikshednik Member Posts: 2,005
Sign In or Register to comment.