Options

slow speed with cisco 3620

kozlojakkozlojak Member Posts: 3 ■□□□□□□□□□
I have a 4-5mb connection with my linksys router, however when I set my cisco 3620 up with NAT I can only get 1.5-1.7mb any ideas off hand?
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$FDNE$g8RmVxZLygVR6I08l4N031
!
no aaa new-model
ip subnet-zero
!
!
ip cef
ip dhcp excluded-address 10.10.1.1 10.10.1.100
!
ip dhcp pool INTERNAL
network 10.10.1.0 255.255.255.0
default-router 10.10.1.1
dns-server 64.71.255.198
!
!
partition flash 2 16 8
!
!
!
!
interface Ethernet0/0
ip address dhcp
ip nat outside
logging event subif-link-status
full-duplex
!
interface Serial0/0
no ip address
logging event subif-link-status
shutdown
no fair-queue
!
interface TokenRing0/0
no ip address
logging event subif-link-status
shutdown
ring-speed 16
!
interface Ethernet1/0
ip address 10.10.1.1 255.255.255.0
ip nat inside
logging event subif-link-status
full-duplex
!
interface Ethernet1/1
no ip address
logging event subif-link-status
shutdown
half-duplex
!
ip nat inside source list 1 interface Ethernet0/0 overload
no ip http server
ip classless
!
!
access-list 1 permit 10.10.1.0 0.0.0.255
banner motd
****************************************************************
*
* WARNING: System is RESTRICTED to authorized personnel ONLY!
* Unauthorized use of this system will be logged and
* prosecuted to the fullest extent of the law.
*
* If you are NOT authorized to use this system, LOG OFF NOW!
*
****************************************************************
!
line con 0
line aux 0
line vty 0
password
login
line vty 1 4
login
!
!
end

Comments

  • Options
    dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    Half duplex ethernet perhaps. If you're talking about the transfer rate in Megabytes per second:

    10,000,000 bits per second / 8 = 1,250,000 Bytes/second or roughly 1.25 Megabytes per second.

    Or it could be an interface problem, perhaps you could look at the output of show interface and look for a high error rate. I f you're connected via a crossover to the modem or csu/dsu you may want to try setting full duplex.

    Other than that it looks okay.
    The only easy day was yesterday!
  • Options
    malcyboodmalcybood Member Posts: 900 ■■■□□□□□□□
    kozlojak wrote:
    I have a 4-5mb connection with my linksys router, however when I set my cisco 3620 up with NAT I can only get 1.5-1.7mb any ideas off hand?
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Internet
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$FDNE$g8RmVxZLygVR6I08l4N031
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    ip cef
    ip dhcp excluded-address 10.10.1.1 10.10.1.100
    !
    ip dhcp pool INTERNAL
    network 10.10.1.0 255.255.255.0
    default-router 10.10.1.1
    dns-server 64.71.255.198
    !
    !
    partition flash 2 16 8
    !
    !
    !
    !
    interface Ethernet0/0
    ip address dhcp
    ip nat outside
    logging event subif-link-status
    full-duplex
    !
    interface Serial0/0
    no ip address
    logging event subif-link-status
    shutdown
    no fair-queue
    !
    interface TokenRing0/0
    no ip address
    logging event subif-link-status
    shutdown
    ring-speed 16
    !
    interface Ethernet1/0
    ip address 10.10.1.1 255.255.255.0
    ip nat inside
    logging event subif-link-status
    full-duplex
    !
    interface Ethernet1/1
    no ip address
    logging event subif-link-status
    shutdown
    half-duplex
    !
    ip nat inside source list 1 interface Ethernet0/0 overload
    no ip http server
    ip classless
    !
    !
    access-list 1 permit 10.10.1.0 0.0.0.255
    banner motd
    ****************************************************************
    *
    * WARNING: System is RESTRICTED to authorized personnel ONLY!
    * Unauthorized use of this system will be logged and
    * prosecuted to the fullest extent of the law.
    *
    * If you are NOT authorized to use this system, LOG OFF NOW!
    *
    ****************************************************************
    !
    line con 0
    line aux 0
    line vty 0
    password
    login
    line vty 1 4
    login
    !
    !
    end

    dtlokee beat me to it but half duplex on int eth 1/1 jumps right out at me from the config output.
  • Options
    malcyboodmalcybood Member Posts: 900 ■■■□□□□□□□
    Just to add, I would also try setting the ethernet port 1/0???? that connects to the Linksys to auto duplex unless you know 100% that your linksys is set to full duplex.

    If there is a duplex mismatch between the linksys and 3620 or the 3620 port and a host it can cause slow connection speeds.

    the command to set it to auto is just duplex auto from the interface config mode
  • Options
    kozlojakkozlojak Member Posts: 3 ■□□□□□□□□□
    e 1/0 is full duplex as it should be connected to a cisco switch. e0/0 will only work in half if i set to full it will not communicate to the internet at all it is connected to a webstar cable modem. if i put it to full duplex i can ping but can not open any web pages it just times out.

    when I debug I am getting alote of "IP ARP" traffic is this a problem?

    is it possable the cable modem is to blame even thow it will work fine with the linksys?
  • Options
    dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    Hmmm I missed it before, you don't have a default route in the config you've posted. If you're getting lots of arp requests could be the souce of the problem.
    The only easy day was yesterday!
  • Options
    kozlojakkozlojak Member Posts: 3 ■□□□□□□□□□
    the default route is there the router creates it on its own after it gets an ip from the dhcp. i have also set a default rout manually but still have the same problem, is there anyway around the arp problem?
  • Options
    cambeicambei Member Posts: 62 ■■■□□□□□□□
    I know you said it is cable, but on ADSL in the UK, dropping the MTU to about 1458 or even 1432 can improve speeds dramatically as the packets are less likely to need to be fragmented.
Sign In or Register to comment.