Options

HSRP and VLANs

rakemrakem Member Posts: 800
hey people...
say i have the following VLAN config on a router:

interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.1.24.2 255.255.255.192
ip helper-address 10.1.24.3
no snmp trap link-status
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 10.1.24.65 255.255.255.192
ip helper-address 10.1.24.3
no snmp trap link-status
!
interface FastEthernet0/0.4
encapsulation dot1Q 4
ip address 10.1.24.129 255.255.255.192
ip helper-address 10.1.24.3

so we have three VLANS defined here.

if i want to use HSRP on this whole network would i need to have a different HSRP standby group for each vlan and then use a virtual IP addresses for each vlan, so the config would be something like the following:

interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.1.24.2 255.255.255.192
ip helper-address 10.1.24.3
standby 1 ip 10.1.24.3 <

interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 10.1.24.65 255.255.255.192
ip helper-address 10.1.24.3
standby 2 ip 10.1.24.66 <

interface FastEthernet0/0.4
encapsulation dot1Q 4
ip address 10.1.24.129 255.255.255.192
ip helper-address 10.1.24.3
standby 3 ip 10.1.24.130 <

obviously i need more HSRP commands to finish it off, but do i have it right with the groups and IP addresses?

thanks
CCIE# 38186
showroute.net

Comments

  • Options
    dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    You could use the same group address on the same router provided they are all connected to different data-links (or VLANs in this case) but I normally would set them as you have with different group numbers on each interface. Using the same group address *may* result in problems with other routers because the MAC address for the group is derived from the group number in the form of 0000.0C07.ACxy where the xy is the group number in Hex.
    The only easy day was yesterday!
Sign In or Register to comment.