Weird issue when trying to install XP on old machine...

/usr/usr Member Posts: 1,768
I'm trying to rebuild this machine for a client so they can give it away. I tried formatting and reinstalling XP using all existing hardware, but I got an error telling me a file could not be copied. Naturally, since it's an old machine, I suspect the hard drive or cd-rom drive.

I have tried 3 different cd-rom drives, two different hard drives, and two different copies of XP that I know are good. Yet I'm still getting "The file dbeng.dll was not copied correctly".

The file isn't always the same.

Any ideas? Am I looking at bad RAM? I honestly don't know what else would cause the installation to fail like this when I have replaced the key components to installing the OS.


  • sthomassthomas Member Posts: 1,240 ■■■□□□□□□□
    I would say at this point you may be looking at bad RAM, unless the CD's you have tried to install Windows XP from are scratched up.
    Working on: MCSA 2012 R2
  • j938j938 Member Posts: 101
    I think it could be the CD itself but you can elminate that problem if there was another cd you could use.

    Also its not highly suggested but why dont you just skip the file and cross your fingers and hope it installs successfully.

    If that dont work
    After all that try to delete the partition on there and reformat it again normally

    Last try I would suggest it win 98 then upgrade to XP ???????
    Growth is limited.
  • theICEtheICE Member Posts: 84 ■■□□□□□□□□
    I would use ntfs 5.0 which Allows you to use the ntfs file system with dos, and copy the i386 folder to the harddrive, and use it to try to install it on the computer.
  • SlowhandSlowhand MCSE: Cloud Platform and Infrastructure, MCSA: Windows Server 2003/2012/2016, CCNA Routing & Switchi Bay Area, CaliforniaMod Posts: 5,161 Mod
    If it isn't always the same file that fails to copy, it's very likely that the problem comes from bad RAM or failing memory slots on the motherboard. It's still possible that the CD may be damaged, but using different media would eliminate that option. Try using another disk, if the errors still happen then you know that it's a memory issue.

    Free Microsoft Training: Microsoft Learn
    Free PowerShell Resources: Top PowerShell Blogs
    Free DevOps/Azure Resources: Visual Studio Dev Essentials

    Let it never be said that I didn't do the very least I could do.
Sign In or Register to comment.