EIGRP Lab Trouble

buemae808buemae808 Member Posts: 15 ■□□□□□□□□□
I'm trying to do an EIGRP lab with three routers and frame relay. I'm setting up the hub (R1) and spoke (R2, R3) topology using R1, R2, R3 serial 0/0/0 interfaces. I can't get R2 and R3 to see each others loopbacks but I can ping each other's serial interfaces. Am I leaving something out?

R1#sh run
Building configuration...

Current configuration : 1113 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 172.12.123.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.2 122 broadcast
frame-relay map ip 172.12.123.3 123 broadcast
no frame-relay inverse-arp
!
interface Serial0/1/0
no ip address
shutdown
clock rate 2000000
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 172.12.123.0 0.0.0.255
auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end


R2#sh run
Building configuration...

Current configuration : 1075 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 172.12.123.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.1 221 broadcast
frame-relay map ip 172.12.123.3 221
!
interface Serial0/1/0
no ip address
shutdown
clock rate 2000000
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 172.12.123.0 0.0.0.255
auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end


R3#sh run
Building configuration...

Current configuration : 1103 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 172.12.123.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.1 321 broadcast
frame-relay map ip 172.12.123.2 321
no frame-relay inverse-arp
!
interface Serial0/1/0
no ip address
shutdown
clock rate 2000000
!
router eigrp 1
network 3.3.3.3 0.0.0.0
network 172.12.123.0 0.0.0.255
auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Comments

  • PlazmaPlazma Member Posts: 503
    the 1st thing i would suggest is turn off auto-summary via no auto-summary (this is IMHO an annoying feature set by default)
    CCIE - COMPLETED!
  • buemae808buemae808 Member Posts: 15 ■□□□□□□□□□
    Q. Why are routes received from one neighbor on a point-to-multipoint interface that runs EIGRP not propagated to another neighbor on the same point-to-multipoint interface?


    A. The split horizon rule prohibits a router from advertising a route through an interface that the router itself uses to reach the destination. In order to disable the split horizon behavior, use the no ip split-horizon eigrp as-number interface command. Some important points to remember about EIGRP split horizon are:

    * Split horizon behavior is turned on by default.
    * When you change the EIGRP split horizon setting on an interface, it resets all adjacencies with EIGRP neighbors reachable over that interface.
    * Split horizon should only be disabled on a hub site in a hub-and-spoke network.
    * Disabling split horizon on the spokes radically increases EIGRP memory consumption on the hub router, as well as the amount of traffic generated on the spoke routers.
    * The EIGRP split horizon behavior is not controlled or influenced by the ip split-horizon command.
  • kpjunglekpjungle Member Posts: 426
    buemae808 wrote:
    Q. Why are routes received from one neighbor on a point-to-multipoint interface that runs EIGRP not propagated to another neighbor on the same point-to-multipoint interface?


    A. The split horizon rule prohibits a router from advertising a route through an interface that the router itself uses to reach the destination. In order to disable the split horizon behavior, use the no ip split-horizon eigrp as-number interface command. Some important points to remember about EIGRP split horizon are:

    * Split horizon behavior is turned on by default.
    * When you change the EIGRP split horizon setting on an interface, it resets all adjacencies with EIGRP neighbors reachable over that interface.
    * Split horizon should only be disabled on a hub site in a hub-and-spoke network.
    * Disabling split horizon on the spokes radically increases EIGRP memory consumption on the hub router, as well as the amount of traffic generated on the spoke routers.
    * The EIGRP split horizon behavior is not controlled or influenced by the ip split-horizon command.

    Did you fix it using subinterfaces (point to point)?
    Studying for CCNP (All done)
  • buemae808buemae808 Member Posts: 15 ■□□□□□□□□□
    Someone told me to try using the "no ip split-horizon eigrp 1" command on the serial interface of the hub router which worked
  • nicklauscombsnicklauscombs Member Posts: 885
    buemae808 wrote:
    Someone told me to try using the "no ip split-horizon eigrp 1" command on the serial interface of the hub router which worked
    yes, this is what was causing your issues
    WIP: IPS exam
Sign In or Register to comment.