You know you spend too much time on the IOS when....

GT-RobGT-Rob Member Posts: 1,090
You try typing on the computer, and use the [Tab] key to finish your words.

"I need to goto the st[Tab]"
"I need to goto the sto[Tab]"
hmmm. Oh..right
"I need to goto the store"

Or you forget how to spell something, and you use the context sensitive help '?'. It never works in real life icon_sad.gif


  • shednikshednik Member Posts: 2,005
    icon_lol.gificon_lol.gif I've found myself doing that on occasion
  • cisco_troopercisco_trooper Too many Member Posts: 1,441 ■■■■□□□□□□
    "sho ip int bri" in a command prompt, constantly.
  • LuckycharmsLuckycharms Member Posts: 267
    I use to do that alot... now I just type half a word and hit enter... and sit there wondering why it didn't work...

    ipco - doesn't work as well as ipconfig /all -- example...
    The quality of a book is never equated to the number of words it contains. -- And neither should be a man by the number of certifications or degree's he has earned.
  • rfult001rfult001 Member Posts: 407
    Have that problem with *nix as well...
  • GT-RobGT-Rob Member Posts: 1,090
    Ya I also find myself wondering why 'trace' doesn't work from a *nix box lol
  • empc4000xlempc4000xl Member Posts: 322
    yeah the tabbling. I even do that in instant messages. and words that I know I can type into a router, I sometimes just put the shorthand. What a nerd
  • keenonkeenon Member Posts: 1,922 ■■■■□□□□□□
    i find myself doing the commands in dos prompt, trace just doesn't seem to work without the rt
    Become the stainless steel sharp knife in a drawer full of rusty spoons
  • gorebrushgorebrush Member Posts: 2,743 ■■■■■■■□□□
    trace is a common one.

    And sometimes when I havent fully setup my router (i.e. no ip-domain lookup)

    It tries to resolve tracert.

    LOL it didn't like me calling my router a homosexual.
  • tmlerdaltmlerdal Member Posts: 80 ■■□□□□□□□□
    my problem is always with closing the sessions. I'll be in an instant message session with one of my co-workers then type 'exit' to close the window.

    Only to smack my head and call myself a moron.
  • ilcram19-2ilcram19-2 Banned Posts: 436
    when you type exit to move back to the previous directory is DOS
    c:\> cd windows


    will close the ms-dos windows
  • SlowhandSlowhand MCSE: Cloud Platform and Infrastructure / Core Infrastructure, MCSA: Windows Server 2003/2012/2016 Bay Area, CaliforniaMod Posts: 5,161 Mod
    I'll do pretty much all of the above on one occasion or another. If I spend a great deal of time on the IOS, I'm typing stuff like eth0 or config t in DOS or in IM. If I spend time on the Windows command-prompt, I'm swearing at the IOS and wondering why it just won't run a trace route (tracert) or change directories. When I'm on a Linux or Unix box, I'm just totally screwed. And as for the IMs, my friends, girlfriend, and family know by now that "exit" is a sign I'm about to log off, "ping" is my attempt at getting their attention, and that they have exactly three seconds to guess which device it is that I just gave them the password for when I type in the wrong window, before I'm scrambling to change it.

    I think the most embarrasing, however, is when I fire up the IOS and can't for the life of me figure out why the "/me" command doesn't work. . .

    Free Microsoft Training: Microsoft Learn
    Free PowerShell Resources: Top PowerShell Blogs
    Free DevOps/Azure Resources: Visual Studio Dev Essentials

    Let it never be said that I didn't do the very least I could do.
  • tmlerdaltmlerdal Member Posts: 80 ■■□□□□□□□□
    I think my absolute worst is when I'd end up working on a Novell NetWare server, be connected via rconip or whatever, and end up typing exit to close. Had some of the server folks later start asking, what's with this exit on the console as a bad command....OH crap..that's me being stupid thinking I was closing out of my telnet session.

    They eventually learned to ignore it.
  • ccnpninjaccnpninja Senior Member EuropeMember Posts: 1,010 ■■■□□□□□□□
    ...when I issue an "enable " at the "c:>" prompt.
  • redwarriorredwarrior Member Posts: 285
    I've done almost all of these, but I think the best one I've done was when I started talking in "IOS shorthand" to my family after a week of particularly loooonng nights spent working. I think I told my husband to "sh me tv" one time...then I passed out for the weekend. icon_lol.gif

    CCNP Progress


    BSCI - In Progress <--My Cisco Blog
  • GT-RobGT-Rob Member Posts: 1,090
    ugh, I noticed another one today.

    When ever I type a question, I put a space in before the question mark.

    "how are you today ?"

    As if I am trying to see if there are any more options on that command lol
  • NetwurkNetwurk Member Posts: 1,155 ■■■■■□□□□□
    I like the CTRL + A command that takes you to the beginning of the line. For some reason it doesn't work in Notepad, but I keep trying.


    Some of the Cisco stuff is based on things that worked in Unix, but I forget if CTRL + A is one of them.

    For a long time I used CTRL + C to get out of Cisco IOS screen outputs until I finally realized that any key except the space bar works.
  • APAAPA Member Posts: 959
    haha I can admit to this one....

    Or sometimes if I'm troubleshooting on a windows box I'll know I want ipconfig /all but I'll end up typing

    sh ipconfig /all


    and traceroute......why oh why did windows make it tracert!!!!

    CCNA | CCNA:Security | CCNP | CCIP
  • NetwurkNetwurk Member Posts: 1,155 ■■■■■□□□□□
    A.P.A wrote:
    and traceroute......why oh why did windows make it tracert!!!!

    Because back in the early DOS days they had to make their commands different than Unix for fear of being sued.
  • redwarriorredwarrior Member Posts: 285
    Ya know, they have a nifty tool for windows that you can install that will force a command prompt to translate linux commands...I wish that they had something similar for IOS commands for windows. Now THAT would be cool until I tried to do a "sh run" on my laptop...that output would probably be nuts!!! icon_lol.gif

    CCNP Progress


    BSCI - In Progress <--My Cisco Blog
Sign In or Register to comment.