My RIP doubts

EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
These statements really bug me, i started a post regarding this along time ago but never got an answer, so second chance is a charm.

From Cisco RIP config guide:

Automatic summary will override the configured summary address feature on a given interface except when both of the following conditions are true:

•The configured interface summary address and the IP address of the configured interface share the same major network (the classful, nonsubnetted portion of the IP address).

•Split horizon is not enabled on the interface.

If split horizon is enabled, neither automatic summary nor interface summary addresses (those configured with the ip summary-address rip router configuration command) are advertised.

My test below doesn't replicate these statements, any idea's?

I've also read in other doc's that if you must be careful where you summarize due to split-horizon.It said that if you were summarizing say 10.0.0.0/16 on R1 and neighbor router R2 sent a route to R1s interface 10.0.1.1/30 this would break the split-horizon rule and the summary would not be advertised.Doesn't work like this as far as my testing goes.


A straight walk through from top to bottom any opinions in regards to the opening statements?


R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
passive-interface Loopback0
network 1.0.0.0
network 10.0.0.0
no auto-summary
!


R2
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 10.0.0.0
no auto-summary
!


R1#sh ip int fa0/0
FastEthernet0/0 is up, line protocol is up
Internet address is 10.0.0.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF Fast switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is disabled
BGP Policy Mapping is disabled
WCCP Redirect outbound is disabled
WCCP Redirect inbound is disabled
WCCP Redirect exclude is disabled


R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 10.0.0.1, 00:11:39
[120/1] via 10.0.0.1, 00:00:00, FastEthernet0/0
10.0.0.0/24 is subnetted, 3 subnets
R 10.1.2.0 [120/1] via 10.0.0.1, 00:00:00, FastEthernet0/0
R 10.1.1.0 [120/1] via 10.0.0.1, 00:00:00, FastEthernet0/0
C 10.0.0.0 is directly connected, FastEthernet0/0



R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int fa0/0
R1(config-if)#ip summ
R1(config-if)#ip summary-address rip 10.1.0.0 255.255.0.0
R1(config-if)#


R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 10.0.0.1, 00:13:33
[120/1] via 10.0.0.1, 00:00:09, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
R 10.1.2.0/24 [120/1] via 10.0.0.1, 00:00:35, FastEthernet0/0
R 10.1.1.0/24 [120/1] via 10.0.0.1, 00:00:35, FastEthernet0/0
C 10.0.0.0/24 is directly connected, FastEthernet0/0
R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:09, FastEthernet0/0
R2#clear ip rou
R2#clear ip route *
R2#sh ip rou
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 10.0.0.1, 00:00:03, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/24 is directly connected, FastEthernet0/0
R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:03, FastEthernet0/0
R2#



R1(config-if)#no ip split-horizon
R1(config-if)#end
R1#
*Mar 1 00:19:10.987: %SYS-5-CONFIG_I: Configured from console by console
R1#sh ip int fa0/0
FastEthernet0/0 is up, line protocol is up
Internet address is 10.0.0.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is disabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF Fast switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is disabled
BGP Policy Mapping is disabled
WCCP Redirect outbound is disabled
WCCP Redirect inbound is disabled
WCCP Redirect exclude is disabled
R1#



R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 10.0.0.1, 00:00:00, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/24 is directly connected, FastEthernet0/0
R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:00, FastEthernet0/0
R2#clear ip rou
R2#clear ip route *
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 10.0.0.1, 00:00:16, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/24 is directly connected, FastEthernet0/0
R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:16, FastEthernet0/0
Networking, sometimes i love it, mostly i hate it.Its all about the $$$$

Comments

  • dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    In your example you turned off auto-summary so I think the "Automatic summary will override the configured summary address feature on a given interface except when both of the following conditions are true" won't apply. Turn it back on and see if you can get the configured summary to be advertised by meeting both of the conditions.



    But in reading what you had posted about split horizion I also thought About this:

    10.1.1.0/24 ---- (E0 R1 E1) ---- 10.1.2.0/24 ---- (E0 R2 E1)
    1.1.1.0/24
    (E0 R3 E1) 10.1.0.0/16

    In this case auto-summary would advertise the 10.0.0.0/8 route out of R2 E1 and out of R3 E0 since they are not the same major network. I would suppose this could cause issues with split horizion since they are effectively both the same route.

    Thanks for the question Ed, you always seem to get me thinking.
    The only easy day was yesterday!
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    I cant believe i turned off auto-summary, just from habit icon_smile.gif.
    I did this test previously with auto-summary but as the network maintans its major network the auto-summary /8 route isnt sent.The summary was sent however with and without split-horizon.I'm off to bed, i rerun it again tomorrow and log with auto-summary on.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    The test performed again with auto-summary enabled.

    R1
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.255
    !
    interface Loopback1
    ip address 10.1.1.1 255.255.255.0
    !
    interface Loopback2
    ip address 10.1.2.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 10.0.0.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router rip
    version 2
    passive-interface Loopback0
    network 1.0.0.0
    network 10.0.0.0
    no auto-summary
    !


    R2
    !
    interface FastEthernet0/0
    ip address 10.0.0.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router rip
    version 2
    network 10.0.0.0
    no auto-summary
    !


    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    R 1.0.0.0/8 [120/1] via 10.0.0.1, 00:00:06, FastEthernet0/0
    10.0.0.0/24 is subnetted, 3 subnets
    R 10.1.2.0 [120/1] via 10.0.0.1, 00:00:06, FastEthernet0/0
    R 10.1.1.0 [120/1] via 10.0.0.1, 00:00:06, FastEthernet0/0
    C 10.0.0.0 is directly connected, FastEthernet0/0

    R1#sh ip int fa0/0
    FastEthernet0/0 is up, line protocol is up
    Internet address is 10.0.0.1/24
    Broadcast address is 255.255.255.255
    Address determined by setup command
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Multicast reserved groups joined: 224.0.0.9
    Outgoing access list is not set
    Inbound access list is not set
    Proxy ARP is enabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is enabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP CEF switching is enabled
    IP CEF Fast switching turbo vector
    IP multicast fast switching is enabled
    IP multicast distributed fast switching is disabled
    IP route-cache flags are Fast, CEF
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Policy routing is disabled
    Network address translation is disabled
    BGP Policy Mapping is disabled
    WCCP Redirect outbound is disabled
    WCCP Redirect inbound is disabled
    WCCP Redirect exclude is disabled


    R1(config)#int fa0/0
    R1(config-if)#ip summary-address rip 10.1.0.0 255.255.0.0


    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    R 1.0.0.0/8 [120/1] via 10.0.0.1, 00:00:10, FastEthernet0/0
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    R 10.1.2.0/24 [120/1] via 10.0.0.1, 00:00:36, FastEthernet0/0
    R 10.1.1.0/24 [120/1] via 10.0.0.1, 00:00:36, FastEthernet0/0
    C 10.0.0.0/24 is directly connected, FastEthernet0/0
    R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:08, FastEthernet0/0


    R2#clear ip route *
    R2#sh ip rou
    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    R 1.0.0.0/8 [120/1] via 10.0.0.1, 00:00:07, FastEthernet0/0
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.0.0.0/24 is directly connected, FastEthernet0/0
    R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:07, FastEthernet0/0



    R1(config-if)#no ip split-horizon
    R1(config-if)#
    R1#sh ip int fa0/0
    FastEthernet0/0 is up, line protocol is up
    Internet address is 10.0.0.1/24
    Broadcast address is 255.255.255.255
    Address determined by setup command
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Multicast reserved groups joined: 224.0.0.9
    Outgoing access list is not set
    Inbound access list is not set
    Proxy ARP is enabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is disabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is enabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP CEF switching is enabled
    IP CEF Fast switching turbo vector
    IP multicast fast switching is enabled
    IP multicast distributed fast switching is disabled
    IP route-cache flags are Fast, CEF
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Policy routing is disabled
    Network address translation is disabled
    BGP Policy Mapping is disabled
    WCCP Redirect outbound is disabled
    WCCP Redirect inbound is disabled
    WCCP Redirect exclude is disabled



    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    R 1.0.0.0/8 [120/1] via 10.0.0.1, 00:00:18, FastEthernet0/0
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.0.0.0/24 is directly connected, FastEthernet0/0
    R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:18, FastEthernet0/0


    R2#clear ip route *
    R2#show ip rou
    R2#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    R 1.0.0.0/8 [120/1] via 10.0.0.1, 00:00:05, FastEthernet0/0
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.0.0.0/24 is directly connected, FastEthernet0/0
    R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:05, FastEthernet0/0
    R2#


    Automatic summary will override the configured summary address feature on a given interface except when both of the following conditions are true:

    •The configured interface summary address and the IP address of the configured interface share the same major network (the classful, nonsubnetted portion of the IP address).
    •Split horizon is not enabled on the interface.

    My problem with this statement is, if the configured interface summary 10.1.0.0/16 shares the same major network i.e.10.x.x.x as the interface 10.0.0.1, i.e. it does, auto summarization wont occur due to no change occuring in the major network boundary.As seen above the manual summary is being received by R2 with and without split horizon on R1 fa0/0.


    If split horizon is enabled, neither automatic summary nor interface summary addresses (those configured with the ip summary-address rip router configuration command) are advertised.

    As seen above this statement is untrue.


    These types of indiscrepencies really bog me down.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    The test performed again with auto-summary enabled.

    R1
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.255
    !
    interface Loopback1
    ip address 10.1.1.1 255.255.255.0
    !
    interface Loopback2
    ip address 10.1.2.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 10.0.0.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router rip
    version 2
    passive-interface Loopback0
    network 1.0.0.0
    network 10.0.0.0
    !


    R2
    !
    interface FastEthernet0/0
    ip address 10.0.0.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router rip
    version 2
    network 10.0.0.0
    !


    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    R 1.0.0.0/8 [120/1] via 10.0.0.1, 00:00:06, FastEthernet0/0
    10.0.0.0/24 is subnetted, 3 subnets
    R 10.1.2.0 [120/1] via 10.0.0.1, 00:00:06, FastEthernet0/0
    R 10.1.1.0 [120/1] via 10.0.0.1, 00:00:06, FastEthernet0/0
    C 10.0.0.0 is directly connected, FastEthernet0/0

    R1#sh ip int fa0/0
    FastEthernet0/0 is up, line protocol is up
    Internet address is 10.0.0.1/24
    Broadcast address is 255.255.255.255
    Address determined by setup command
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Multicast reserved groups joined: 224.0.0.9
    Outgoing access list is not set
    Inbound access list is not set
    Proxy ARP is enabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is enabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP CEF switching is enabled
    IP CEF Fast switching turbo vector
    IP multicast fast switching is enabled
    IP multicast distributed fast switching is disabled
    IP route-cache flags are Fast, CEF
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Policy routing is disabled
    Network address translation is disabled
    BGP Policy Mapping is disabled
    WCCP Redirect outbound is disabled
    WCCP Redirect inbound is disabled
    WCCP Redirect exclude is disabled


    R1(config)#int fa0/0
    R1(config-if)#ip summary-address rip 10.1.0.0 255.255.0.0


    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    R 1.0.0.0/8 [120/1] via 10.0.0.1, 00:00:10, FastEthernet0/0
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    R 10.1.2.0/24 [120/1] via 10.0.0.1, 00:00:36, FastEthernet0/0
    R 10.1.1.0/24 [120/1] via 10.0.0.1, 00:00:36, FastEthernet0/0
    C 10.0.0.0/24 is directly connected, FastEthernet0/0
    R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:08, FastEthernet0/0


    R2#clear ip route *
    R2#sh ip rou
    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    R 1.0.0.0/8 [120/1] via 10.0.0.1, 00:00:07, FastEthernet0/0
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.0.0.0/24 is directly connected, FastEthernet0/0
    R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:07, FastEthernet0/0



    R1(config-if)#no ip split-horizon
    R1(config-if)#
    R1#sh ip int fa0/0
    FastEthernet0/0 is up, line protocol is up
    Internet address is 10.0.0.1/24
    Broadcast address is 255.255.255.255
    Address determined by setup command
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Multicast reserved groups joined: 224.0.0.9
    Outgoing access list is not set
    Inbound access list is not set
    Proxy ARP is enabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is disabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is enabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP CEF switching is enabled
    IP CEF Fast switching turbo vector
    IP multicast fast switching is enabled
    IP multicast distributed fast switching is disabled
    IP route-cache flags are Fast, CEF
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Policy routing is disabled
    Network address translation is disabled
    BGP Policy Mapping is disabled
    WCCP Redirect outbound is disabled
    WCCP Redirect inbound is disabled
    WCCP Redirect exclude is disabled



    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    R 1.0.0.0/8 [120/1] via 10.0.0.1, 00:00:18, FastEthernet0/0
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.0.0.0/24 is directly connected, FastEthernet0/0
    R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:18, FastEthernet0/0


    R2#clear ip route *
    R2#show ip rou
    R2#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    R 1.0.0.0/8 [120/1] via 10.0.0.1, 00:00:05, FastEthernet0/0
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.0.0.0/24 is directly connected, FastEthernet0/0
    R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:05, FastEthernet0/0
    R2#


    Automatic summary will override the configured summary address feature on a given interface except when both of the following conditions are true:

    •The configured interface summary address and the IP address of the configured interface share the same major network (the classful, nonsubnetted portion of the IP address).
    •Split horizon is not enabled on the interface.

    My problem with this statement is, if the configured interface summary 10.1.0.0/16 shares the same major network i.e.10.x.x.x as the interface 10.0.0.1, i.e. it does, auto summarization wont occur due to no change occuring in the major network boundary.As seen above the manual summary is being received by R2 with and without split horizon on R1 fa0/0.


    If split horizon is enabled, neither automatic summary nor interface summary addresses (those configured with the ip summary-address rip router configuration command) are advertised.

    As seen above this statement is untrue.


    These types of indiscrepencies really bog me down.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • dtlokeedtlokee Member Posts: 2,378 ■■■■□□□□□□
    It looks like you are trying to summarize the 10.x.x.x major network which in this scenario would not be subject to auto-summary becasue the Ethernet interface is in the same major network. The 1.1.1.1 loopback however is getting summarized via auto-summary. Try adding the "ip summary-address rip 1.1.0.0 255.255.0.0" to r1's ethernet and see if that will advertise it as 1.1.0.0/16 or the auto summary which is 1.0.0.0/8
    The only easy day was yesterday!
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    dtlokee wrote: »
    It looks like you are trying to summarize the 10.x.x.x major network which in this scenario would not be subject to auto-summary becasue the Ethernet interface is in the same major network. The 1.1.1.1 loopback however is getting summarized via auto-summary. Try adding the "ip summary-address rip 1.1.0.0 255.255.0.0" to r1's ethernet and see if that will advertise it as 1.1.0.0/16 or the auto summary which is 1.0.0.0/8

    But then it doesn't adhere to one of the clauses:
    •The configured interface summary address and the IP address of the configured interface share the same major network (the classful, nonsubnetted portion of the IP address).
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • SepiraphSepiraph Member Posts: 179 ■■□□□□□□□□
    EdTheLad wrote: »
    Automatic summary will override the configured summary address feature on a given interface except when both of the following conditions are true:

    •The configured interface summary address and the IP address of the configured interface share the same major network (the classful, nonsubnetted portion of the IP address).
    •Split horizon is not enabled on the interface.

    My problem with this statement is, if the configured interface summary 10.1.0.0/16 shares the same major network i.e.10.x.x.x as the interface 10.0.0.1, i.e. it does, auto summarization wont occur due to no change occuring in the major network boundary.As seen above the manual summary is being received by R2 with and without split horizon on R1 fa0/0.

    The statement said automatic summary will override the configured summary address feature EXCEPT when both conditions are true. In this case, they are so it did not override the configured statement on the interface, hence you still see in R2:

    R 10.1.0.0/16 [120/1] via 10.0.0.1, 00:00:16, FastEthernet0/0

    The statement did NOT say that auto summary won't occur as a whole on the router.
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Looking at this again i think i've been misunderstanding the statements.I was believing both statements had to match simultaneously, where if i look at each as a separate entity it makes sense.I'd have to lab it up again and see what happens to the 1.0.0.0 address regarding manual summary and split-horizon, but no time at the moment.

    Looks like a possible case of bad grammar on Cisco's part, the statement should probably read as folows:

    Automatic summary will override the configured summary address feature on a given interface except when the following conditions are true:

    1)The configured interface summary address and the IP address of the configured interface share the same major network (the classful, nonsubnetted portion of the IP address).

    2) In the case that rule number 1 is false , when Split horizon is diasbled on the interface.

    If split horizon is enabled, neither automatic summary nor interface summary addresses (those configured with the ip summary-address rip router configuration command) are advertised.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
Sign In or Register to comment.