Options

Static and RIP

surfthegeckosurfthegecko Member Posts: 149
Hi,

Could somebody (once again) please clarify a couple of things for me.

Static Routing:
When setting up a static route do you use the full subnet mask or the standard class mask.
For example:
ip route 172.16.3.0 255.255.255.0 172.16.1.2
or
ip route 172.16.3.0 255.255.0.0 172.16.1.2

RIP Routing:
Do you always advertise the networks as classful networks
For Example:
10.10.7.0 should be defined as 'network 10.0.0.0'
&
192.168.3.0 should be defined as 'network 192.168.3.0'

Thanks
Nick

Comments

  • Options
    meadITmeadIT Member Posts: 581 ■■■■□□□□□□
    Static Routing:
    When setting up a static route do you use the full subnet mask or the standard class mask.
    For example:
    ip route 172.16.3.0 255.255.255.0 172.16.1.2
    or
    ip route 172.16.3.0 255.255.0.0 172.16.1.2

    You would use the classless mask: ip route 172.16.3.0 255.255.255.0 172.16.1.2

    Think about it this way, since it is a static address, R1 wouldn't know what or how many interfaces are on R3, so you need to tell it with the proper subnet mask.
    RIP Routing:
    Do you always advertise the networks as classful networks
    For Example:
    10.10.7.0 should be defined as 'network 10.0.0.0'
    &
    192.168.3.0 should be defined as 'network 192.168.3.0'

    Thanks
    Nick

    Unlike static, each router is telling other routers what networks it has attached to it. Therefore, you put in the classful mask, telling it to advertise all networks in that range. It then figures out which networks are connected to it using its inteface address and mask and then advertises those networks using RIP***.


    ***Edit: Remember that this is for Rip V2. Rip V1 will only advertise classful networks, but the "network 10.x.x.x" command is still the same.
    CERTS: VCDX #110 / VCAP-DCA #500 (v5 & 4) / VCAP-DCD #10(v5 & 4) / VCP 5 & 4 / EMCISA / MCSE 2003 / MCTS: Vista / CCNA / CCENT / Security+ / Network+ / Project+ / CIW Database Design Specialist, Professional, Associate
  • Options
    surfthegeckosurfthegecko Member Posts: 149
    Excellant.

    Thats how I had it mapped in my head so thats another tick.

    Thanks MeadIT
  • Options
    tech-airmantech-airman Member Posts: 953
    surfthegecko,
    Hi,

    Could somebody (once again) please clarify a couple of things for me.

    Static Routing:
    When setting up a static route do you use the full subnet mask or the standard class mask.
    For example:
    ip route 172.16.3.0 255.255.255.0 172.16.1.2
    or
    ip route 172.16.3.0 255.255.0.0 172.16.1.2

    It depends on which destination network you want to statically configure, 172.16.3.0 or 172.16.0.0. Static route configuration is where you're specifically configuring a route to a specific network, nothing more, nothing less. Nothing more as in static route configuration does NOT include the subnets below the network address configured. Nothing less as in the static route configuration does NOT include any kind of summary address.
    RIP Routing:
    Do you always advertise the networks as classful networks
    For Example:
    10.10.7.0 should be defined as 'network 10.0.0.0'
    &
    192.168.3.0 should be defined as 'network 192.168.3.0'

    Thanks
    Nick

    No.

    Source:
    1. Cisco IOS IP Routing Protocols Command Reference - RIP Commands [Support] - Cisco Systems
  • Options
    meadITmeadIT Member Posts: 581 ■■■■□□□□□□


    Hmmm....my CCNA material didn't go over this scenario. Is this how you would keep a RIP router from advertising all of its interfaces? Example: You have two interfaces with the address 10.10.1.1/16 and 10.20.1.1/16. You want to advertise the 10.10.0.0/16 network with RIP, but not the 10.20.0.0/16 network, so instead of "network 10.0.0.0" you would use "network 10.10.0.0"? This would only advertise that network through RIP?

    Thanks for that link tech-airman!
    CERTS: VCDX #110 / VCAP-DCA #500 (v5 & 4) / VCAP-DCD #10(v5 & 4) / VCP 5 & 4 / EMCISA / MCSE 2003 / MCTS: Vista / CCNA / CCENT / Security+ / Network+ / Project+ / CIW Database Design Specialist, Professional, Associate
  • Options
    tim100tim100 Member Posts: 162
    meadIT wrote: »
    Hmmm....my CCNA material didn't go over this scenario. Is this how you would keep a RIP router from advertising all of its interfaces? Example: You have two interfaces with the address 10.10.1.1/16 and 10.20.1.1/16. You want to advertise the 10.10.0.0/16 network with RIP, but not the 10.20.0.0/16 network, so instead of "network 10.0.0.0" you would use "network 10.10.0.0"? This would only advertise that network through RIP?

    Thanks for that link tech-airman!

    In RIP when you use the network statement you always have to specify the classful network. Even if you don't specify the classful network and you add "network 10.10.0.0" the IOS software will automatically correct it and when you do a "show run" you will see the classful network 10.0.0.0. In order to suppress the advertisement of a specific network in RIP you can use a distribute list. You can also use an offset list to add to the RIP metric - The network will still be advertised to the neighbor router but it won't show up in the routing table of the neighbor router if the metric adds up to 16.
  • Options
    meadITmeadIT Member Posts: 581 ■■■■□□□□□□
    tim100 wrote: »
    In RIP when you use the network statement you always have to use the specify the classful network. Even if you don't specify the classful network and you add "network 10.10.0.0" the IOS software will automatically correct it and when you do a "show run" you will see the classful network 10.0.0.0. In order to suppress the advertisement of a specific network in RIP you can use a distribute list. You can also use an offset list to add to the RIP metric - The network will still be advertised to the neighbor router but it won't show up in the routing table of the neighbor router if the metric adds up to 16.

    Well now I'm all confused. In the link that tech-airman provided, it shows the examples:
    [B]Examples [/B]
     
    The following example defines RIP as the routing protocol to be used on all interfaces connected to networks 10.99.0.0 and 192.168.7.0: 
    router rip
     network 10.99.0.0
     network 192.168.7.0
    

    Why do they use "network 10.99.0.0" instead of "network 10.0.0.0"?
    CERTS: VCDX #110 / VCAP-DCA #500 (v5 & 4) / VCAP-DCD #10(v5 & 4) / VCP 5 & 4 / EMCISA / MCSE 2003 / MCTS: Vista / CCNA / CCENT / Security+ / Network+ / Project+ / CIW Database Design Specialist, Professional, Associate
  • Options
    tim100tim100 Member Posts: 162
    meadIT wrote: »
    Well now I'm all confused. In the link that tech-airman provided, it shows the examples:
    [B]Examples [/B]
     
    The following example defines RIP as the routing protocol to be used on all interfaces connected to networks 10.99.0.0 and 192.168.7.0: 
    router rip
     network 10.99.0.0
     network 192.168.7.0
    

    Why do they use "network 10.99.0.0" instead of "network 10.0.0.0"?

    you can enter the configuration in this manner as stated in this document but it will automatically be corrected to the classful network. If you have other interfaces in that particular classful network they will automatically be included in the RIP process.
  • Options
    tech-airmantech-airman Member Posts: 953
    meadIT,
    meadIT wrote: »
    Hmmm....my CCNA material didn't go over this scenario. Is this how you would keep a RIP router from advertising all of its interfaces?

    Let's say for the sake of this discussion you've got a standard issue blasted router so you're starting from scratch. So let's start configuring the router...
    Router>enable
    Router#configuration terminal
    Router(config)#interface fastethernet 0/0
    Router(config-if)#ip address 192.168.1.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#exit
    Router#
    

    At this point, not only did you configure an interface but you also created a routing table entry. You can see this by the following command...
    Router#show ip route
    

    You should see a Connected route to 192.168.1.0/24. Now, let's configure RIP.
    Router#configuration terminal
    Router(config)#router rip
    Router(config-router)#network 192.168.1.0
    Router(config-router)#exit
    Router(config)#exit
    Router#
    

    Now at this point, you've now got a configured interface and RIP configured. A rather boring situation because there's only one interface involved but there's a point I'm trying to make. As soon as you typed "Router(config-router)#network 192.168.1.0" and pushed enter, what the router did was basically ask any Connected route "hey, are you on the 192.168.1.0 sub/network?" At this point, the FastEthernet interface answered the call and basically said to RIP "Yep, I'm on the 192.168.1.0 sub/network." At this point, the Connected route to 192.168.1.0/24 gets included into RIP. You can verify this by typing the following...
    Router#show ip route
    

    You should now see instead of a Connected route to 192.168.1.0/24 but a RIP route to 192.168.1.0/24. Now, let's continue this experiment by configuring the FastEthernet 0/1 interface.
    Router#configuration terminal
    Router(config)#interface fastethernet 0/1
    Router(config-if)#ip address 192.168.2.1 255.255.255.0
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#exit
    Router#
    

    Now go back and type the following...
    Router#show ip route
    

    You should now see two routes:
    1. R 192.168.1.0/24
    2. C 192.168.2.0/24

    So, in conclusion, when you type in "network x.x.x.x" for RIP, it asks around the Connected routes to become "promoted" from Connected to RIP. The Connected routes are automatically created when you configure the IP address for the interface.
    meadIT wrote: »
    Example: You have two interfaces with the address 10.10.1.1/16 and 10.20.1.1/16. You want to advertise the 10.10.0.0/16 network with RIP, but not the 10.20.0.0/16 network, so instead of "network 10.0.0.0" you would use "network 10.10.0.0"? This would only advertise that network through RIP?

    I would imagine so.
    meadIT wrote: »
    Thanks for that link tech-airman!

    Don't thank me, thank Cisco. :)
  • Options
    kryollakryolla Member Posts: 785
    both of these routes will be connected because their are directly connected. You will only see R for routes learned via RIP from another router. All the network statment does is put that interface in the RIP process. Since the network statement is classful use the passive interface to stop sending RIP from the interface.
    You should now see two routes:
    R 192.168.1.0/24
    C 192.168.2.0/24
    Studying for CCIE and drinking Home Brew
Sign In or Register to comment.