Utilising an 857W Router for Wireless only

gorebrushgorebrush Member Posts: 2,743 ■■■■■■■□□□
Odd question, but I wonder if I could do the following.

At the moment, I cannot use any router other than the one my ISP provides. This is fine, but the Wireless is diabolical on it.

I have a Cisco 857W sitting around, and I would like to use the Wireless on this device.

So

Internet ----> ISP Router ----> Cisco 857W ---> Wireless Access

Can this be done by simply creating a BVI for the wireless and switchports on the 857 thus bridging those parts? (i.e. I dont want to use the DSL port on the 857 at all, but simply bridge the FastEthernet and Dot11Radio)

Thanks!

David

Comments

  • gojericho0gojericho0 Member Posts: 1,059 ■■■□□□□□□□
    Yup, thats how I have mine setup. check out the config guide for commands
  • tech-airmantech-airman Member Posts: 953
    gorebrush wrote: »
    Odd question, but I wonder if I could do the following.

    At the moment, I cannot use any router other than the one my ISP provides. This is fine, but the Wireless is diabolical on it.

    I have a Cisco 857W sitting around, and I would like to use the Wireless on this device.

    So

    Internet ----> ISP Router ----> Cisco 857W ---> Wireless Access

    Can this be done by simply creating a BVI for the wireless and switchports on the 857 thus bridging those parts? (i.e. I dont want to use the DSL port on the 857 at all, but simply bridge the FastEthernet and Dot11Radio)

    Thanks!

    David

    gorebush,

    What wireless technology/technologies are used by your wireless hosts?
  • gorebrushgorebrush Member Posts: 2,743 ■■■■■■■□□□
    Well my wireless host... is my iPhone.

    Oh, and my works laptop, but I rarely use that over wireless.

    iPhone supports WEP, WPA1+2.

    Not sure if I quite need to go as far as WPA2 considering it is a home network.

    Though the thought of being able to leverage the 857 as a switch and wireless AP is quite saucy.

    Thanks for your help guys.
  • gorebrushgorebrush Member Posts: 2,743 ■■■■■■■□□□
    Can anyone provide any hints on what I need to do for a configuration?

    I guess I need to bridge VLAN1 and Dot11Radio0 together?

    If someone could help it would be much appreciated, this is getting on my nerves now.
  • kryollakryolla Member Posts: 785
    if you just want all the interfaces and dot11 interface to be in same broadcast domain as your isp router then you can set up a simple transparent bridge

    turn off ip routing and get rid of all ip addresses
    global config mode bridge 1 protocol ieee
    under each interface bridge-group 1

    I have IRB set up for my 851W just like gojericho0 below but unless you are doing routing you don't need it. If you are just basically setting up a switch you can configure transparent bridging.
    Studying for CCIE and drinking Home Brew
  • gojericho0gojericho0 Member Posts: 1,059 ■■■□□□□□□□
    this is how i setup my interfaces


    interface Dot11Radio0.1
    description Wireless Office Network
    encapsulation dot1Q 1 native
    ip flow ingress
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    no ip address
    ip virtual-reassembly
    bridge-group 1
    bridge-group 1 spanning-disabled
    !
    interface BVI1
    ip address 192.168.1.1 255.255.255.0
    ip access-group 100 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    !
  • tech-airmantech-airman Member Posts: 953
    gorebrush wrote: »
    Well my wireless host... is my iPhone.

    Oh, and my works laptop, but I rarely use that over wireless.

    iPhone supports WEP, WPA1+2.

    Not sure if I quite need to go as far as WPA2 considering it is a home network.

    Though the thought of being able to leverage the 857 as a switch and wireless AP is quite saucy.

    Thanks for your help guys.

    gorebush,

    I was actually asking about which type of 802.11 it uses. Does it use:
    1. 802.11a
    2. 802.11b
    3. 802.11g
    4. 802.11n
    5. Some of the above?
    6. All of the above?
    7. None of the above?
    8. Other?
  • gorebrushgorebrush Member Posts: 2,743 ■■■■■■■□□□
    Thanks for your replies!

    @ gojericho

    That's what I had in my mind, but I kept getting in knots over it. That is superb.

    @ tech-airman

    Sorry, it is 802.11b/g I believe.

    Thanks all!! :D
  • kryollakryolla Member Posts: 785
    do you know the difference between transparent bridging, CRB, and IRB. You are setting a BVI interface to represent you bridge ports sort of like an SVI represents your vlan ports and then the BVI does the routing. So for my setup I have my dot11 and fastethernet ports bridged and the BVI does the routing between my lan and my wan port which connects to my cable ISP.
    (i.e. I dont want to use the DSL port on the 857 at all, but simply bridge the FastEthernet and Dot11Radio)
    Studying for CCIE and drinking Home Brew
  • gorebrushgorebrush Member Posts: 2,743 ■■■■■■■□□□
    kryolla wrote: »
    do you know the difference between transparent bridging, CRB, and IRB. You are setting a BVI interface to represent you bridge ports sort of like an SVI represents your vlan ports and then the BVI does the routing. So for my setup I have my dot11 and fastethernet ports bridged and the BVI does the routing between my lan and my wan port which connects to my cable ISP.

    Haven't got as far as learning about CRB/IRB Transparent yet.

    But thanks for tip.
  • gorebrushgorebrush Member Posts: 2,743 ■■■■■■■□□□
    For those who are interested: -

    Building configuration...

    Current configuration : 1634 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 857WAP
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret ...
    !
    no aaa new-model
    !
    resource policy
    !
    !
    !
    ip cef
    !
    !
    !
    !
    !
    !
    bridge irb
    !
    !
    interface ATM0
    no ip address
    shutdown
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
    no ip address
    !
    broadcast-key change 60
    !
    !
    encryption mode ciphers tkip
    !
    ssid CISCO
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 0 <<removed>>
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    rts threshold 2312
    power local cck 20
    power local ofdm 17
    beacon period 1000
    station-role root
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    no ip address
    ip virtual-reassembly
    bridge-group 1
    bridge-group 1 spanning-disabled
    !
    interface BVI1
    ip address 172.16.0.254 255.255.255.0
    !
    ip default-gateway 172.16.0.1
    ip route 0.0.0.0 0.0.0.0 172.16.0.1
    !
    no ip http server
    no ip http secure-server
    !
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    logging synchronous
    no modem enable
    line aux 0
    line vty 0 4
    exec-timeout 30 0
    password .....
    logging synchronous
    login
    !
    scheduler max-task-time 5000
    end
  • kryollakryolla Member Posts: 785
    looks good but a lot of un-needed config for your purpose. If you were using the DSL port then you have the right config.
    Studying for CCIE and drinking Home Brew
  • gojericho0gojericho0 Member Posts: 1,059 ■■■□□□□□□□
    good jobicon_thumright.gif

    it took me a little to get the hang of the bvi interface since i never used it before
  • gorebrushgorebrush Member Posts: 2,743 ■■■■■■■□□□
    kryolla wrote: »
    looks good but a lot of un-needed config for your purpose. If you were using the DSL port then you have the right config.

    Can always use it as a backup :)
Sign In or Register to comment.