ISDN Configuration Question

polmpolm Member Posts: 34 ■■□□□□□□□□
I have a virtual lab program that I am using to study for my CCNA. Here is a diagram of the lab: http://fox302.com/userdata/polm/files/pics/Screenshot.jpg

I am attempting to configure the ISDN connections Router1-->Gateway, and Router2-->Gateway.

Currently I have the configurations such that I can ping from Router1-->Gateway, Router2-->Gateway, Gateway-->Router1, but pings are failing from Gateway-->Router2.

When I run "debug isdn q931" while pinging Gateway-->Router2,I can see that the Gateway router is attempting to user the Dialer1 interface and dial string 1000001 to connect to Router2. Why would it do this when I setup Dialer2 as the connection for Router2 ?

Here are the related config options:

Gateway:
!
isdn switch-type primary-5ess
!
interface Serial3/0:15
bandwidth 64
no ip address
dialer pool-member 1
!
interface Dialer1
bandwidth 56
ip address 10.30.0.1 255.255.255.0
encapsulation hdlc
dialer remote-name router1
dialer string 1000001
dialer pool 1
!
interface Dialer2
bandwidth 56
ip address 10.35.0.1 255.255.255.0
encapsulation hdlc
dialer remote-name router2
dialer string 1000002
dialer pool 1
!
dialer-list 1 protocol ip permit

Router1
!
isdn switch-type basic-5ess
!
interface BRI3/0
bandwidth 64
ip address 10.30.0.2 255.255.255.0
encapsulation hdlc
dialer string 5555555
dialer-group 1
!
dialer-list 1 protocol ip permit

Router2
!
isdn switch-type basic-5ess
!
interface BRI0/0
bandwidth 16
ip address 10.35.0.2 255.255.255.0
dialer string 5555555
dialer-group 1
!
dialer-list 1 protocol ip permit

Comments

  • wildfirewildfire Member Posts: 654
    You need to configure the statement

    encapsulation hdlc in router 2
    also you shoulf set the bandwidths to the same ammount! Gateway trying to send to much to router 2
    Looking for CCIE lab study partnerts, in the UK or Online.
  • tunerXtunerX Member Posts: 447 ■■■□□□□□□□
    Try this. It works for me. I can dial Router1->Gateway, Router2->Gateway, Gateway->Router1, and Gateway->Router2

    I am using PRI/T1, I think you are using PRI/E1 since your control/signalling channel is number 15. Anyway, you just need to substitue "Serial 2/0:23" with "Serial 3/0:15"

    I had to configure "dialer caller string" on the gateway so I could receive calls and the router would know which dialer profile to assign the call to. This could just be a requirent of my IOS (c3640-jk8s-mz.122-15.T9.bin), but I don't think so. The router needs a way to assign the incoming call to a dialer interface so your addresses line up. You could try assigning your dialers with an unnumbered interface pointing to loopback zero. This way you can save on subnets.

    I did not see a dialer-group statement on your dialer profiles (interfaces). You need to have a dialer-list mapped or you will never get the interface from Gateway->Router1 or Gateway->Router2 to come up.

    The bandwidth statement doesn't matter because that is only used for multilink, QOS, routing protocols, and several other types of services.

    The default encapsulation should be hdlc so you shouldn't be forced to set the encap. It doesn't hurt though. I set mine up the same way, Router 1 had encap specified and Router 2 did not. I could still dial and ping between them.

    Gateway config

    isdn switch-type primary-5ess

    controller T1 2/0
    framing esf
    linecode b8zs
    pri-group timeslots 1-24

    interface Serial2/0:23
    no ip address
    dialer pool-member 1
    isdn switch-type primary-5ess
    no cdp enable

    interface Dialer1
    bandwidth 64
    ip address 10.30.0.1 255.255.255.0
    dialer pool 1
    dialer remote-name 2610_1
    dialer string 4081111111
    dialer caller 4081111111
    dialer-group 1

    interface Dialer2
    bandwidth 64
    ip address 10.35.0.1 255.255.255.0
    dialer pool 1
    dialer remote-name 2610_2
    dialer string 4082222221
    dialer caller 4082222221
    dialer-group 1

    dialer-list 1 protocol ip permit


    Router1 config

    isdn switch-type basic-5ess

    interface BRI0/0
    bandwidth 64
    ip address 10.30.0.2 255.255.255.0
    encapsulation hdlc
    dialer string 4071111123
    dialer-group 1
    isdn switch-type basic-5ess

    dialer-list 1 protocol ip permit


    Router2 config

    isdn switch-type basic-5ess

    interface BRI0/0
    bandwidth 64
    ip address 10.35.0.2 255.255.255.0
    encapsulation hdlc
    dialer string 4071111123
    dialer-group 1
    isdn switch-type basic-5ess

    dialer-list 1 protocol ip permit
  • polmpolm Member Posts: 34 ■■□□□□□□□□
    I just got word back from the makers of the Virtual Lab.

    Appartently there is a flaw in the application that only allows a single dialer. They are working to fix and will hope to include in the next update.
  • Fu LoserFu Loser Member Posts: 123
    I do not believe ISDN is on the CCNA exam.

    I just checked and did not see it under the exams topics/objectives.

    Please double check this, I just would not want to see you load on information you really do not need.
  • polmpolm Member Posts: 34 ■■□□□□□□□□
    Fu Loser wrote:
    I do not believe ISDN is on the CCNA exam.

    I just checked and did not see it under the exams topics/objectives.

    Please double check this, I just would not want to see you load on information you really do not need.

    actually my approach has been to load it all on, and then some. I'm going for complete and utter understanding of all potential topics.
Sign In or Register to comment.