EIGRP Advertising routes

mzinzmzinz Member Posts: 328
Can EIGRP only share routes that are directly connected?

I have a hub router with several spokes. The hub router has a static route to a network that is not directly connected.

I have the network listed in EIGRP, but other routers are not able to pick it up. When I added a static route to one of the remote routers (pointing at the hub), everything worked fine.
_______LAB________
2x 2950
2x 3550
2x 2650XM
2x 3640
1x 2801

Comments

  • kryollakryolla Member Posts: 785
    yes unless you redistribute static or advertise a summary
    Studying for CCIE and drinking Home Brew
  • mzinzmzinz Member Posts: 328
    Got it, that makes sense.

    For some reason, though, I still can't get it to work, even with redistributing static:
    router eigrp 55
    redistribute static route-map Static-Routes-ACL
    passive-interface GigabitEthernet0/0
    passive-interface GigabitEthernet0/1
    network 10.0.202.0 0.0.0.255
    network 10.10.1.0 0.0.0.255
    <...>

    #sh access-list Static-Routes-ACL
    Standard IP access list Static-Routes-ACL
    10 permit 10.10.59.0, wildcard bits 0.0.0.255 (3 matches)
    20 permit 10.10.50.0, wildcard bits 0.0.0.255
    <...>

    When I go onto a router that has a neighbor relationship, all networks show up except the ones in the Static-Routes-ACL... Any idea why?
    _______LAB________
    2x 2950
    2x 3550
    2x 2650XM
    2x 3640
    1x 2801
  • kryollakryolla Member Posts: 785
    do you have a topology drawing and what does sh ip route and sh route-map say. You have 3 matches in your ACL so that should be advertised.
    Studying for CCIE and drinking Home Brew
  • mzinzmzinz Member Posts: 328
    I've tried both Standard and extended ACL's. Maybe I should try just "redistribute static" and see if all of them show up...
    _______LAB________
    2x 2950
    2x 3550
    2x 2650XM
    2x 3640
    1x 2801
  • SysAdmin4066SysAdmin4066 Member Posts: 443
    I'm curious to know how a summary address would advertise a route into EIGRP without redistribution Kryolla? The only way I can think of this working is to redist static routes on the hub router.
    In Progress: CCIE R&S Written Scheduled July 17th (Tentative)

    Next Up: CCIE R&S Lab
  • SysAdmin4066SysAdmin4066 Member Posts: 443
    I'd be interested in seeing a topology as well...
    In Progress: CCIE R&S Written Scheduled July 17th (Tentative)

    Next Up: CCIE R&S Lab
  • kryollakryolla Member Posts: 785
    you can advertise a summary as long as you have 1 route in the routing table. So the summary will be advertised via EIGRP to downstream neighbors and when you receive traffic back the static route which is more specific than the summary will get it to the next hop. All other routes contained in the summary will go to the bit bucket if you choose or the router will send an ICMP unreachable.

    Off topic are you still in the core I got out back in 99 hoorah
    Studying for CCIE and drinking Home Brew
  • SysAdmin4066SysAdmin4066 Member Posts: 443
    What would the config for that look like? I tried it on the hub router from the interface config mode (ip summary-address) and that didnt work. I also tried it from the spoke router that has the loopback. Neither worked, only the redistribute static on the hub router.

    Not in the Corps anymore, in from 2000 to 2004. Oohrah Devildog, once a Marine, always a Marine. Off topic, what was your MOS?
    In Progress: CCIE R&S Written Scheduled July 17th (Tentative)

    Next Up: CCIE R&S Lab
  • kryollakryolla Member Posts: 785
    ip summary-address eigrp 1 0.0.0.0 0.0.0.0 :)

    I think my MOS was 2532 but its been so long Multi-Channel radio operator
    Studying for CCIE and drinking Home Brew
  • SysAdmin4066SysAdmin4066 Member Posts: 443
    So a default route then? or are the 0s standing in for a network and subnet? Basically the setup I tested out was 3 routers, 2 as spokes and one as a hub connecting the two together. I setup one serial network as 192.168.0.x and the other side as 10.x.x.x. I then set up a loopback net on one of the spoke routers and set up EIGRP to advertise all networks except the loopback on the spoke router. I set a static route on the hub to the loopback through the connected spoke and was able to ping to the loopback (20.20.20.20/24) from the hub, but was unable to ping from the other spoke (obviously because it didnt have a route).

    I then input the command ip summary-address eigrp 1 20.20.20.0 255.255.255.0 first on the hub router to no avail. Then I tried the same command on the spoke with the loopback installed and still no route advertisement. I then did a redistribute static on the hub with the static route to the loopback and was able to see a route to it on the other non-connected spoke. So how should I done that via advertisement instead?

    I was a 4066 small comp spec. Eventually we were reclassed to 0621 I think, IT specialist or something like that. It was litterally a few months before I EASed so it didnt matter.
    In Progress: CCIE R&S Written Scheduled July 17th (Tentative)

    Next Up: CCIE R&S Lab
  • kryollakryolla Member Posts: 785
    it wont look pretty but basically you can set up a loopback address with an ip address less specific than the static route and advertise it into eigrp. So when traffic comes in the more specific static route will take precedence over the loopback address. Also set up a null route with the prefix from the loopback address. Its easier to just redistribute static lol

    For you example set up a static route
    ip route 20.20.20.0 255.255.255.0 xxxxxx
    int lo100
    ip add 20.20.20.254 255.255.252.0
    ip route 20.20.20.0 255.255.252.0 null0
    router eigrp 1
    net 20.20.20.254 0.0.0.0
    pass lo100
    Studying for CCIE and drinking Home Brew
  • mzinzmzinz Member Posts: 328
    Just got off the phone with TAC... Looks like it's a bug in my 3845 code... bummer.
    _______LAB________
    2x 2950
    2x 3550
    2x 2650XM
    2x 3640
    1x 2801
  • BURDY53BURDY53 Member Posts: 1 ■□□□□□□□□□
    When configuring EIGRP, do the network commands pertain only to the ip addresses only on the router its configured on? Or do they include networks on other routers within the same AS?
    Thanks!
  • UndyUndy Member Posts: 37 ■■□□□□□□□□
    mzinz wrote: »
    Got it, that makes sense.

    For some reason, though, I still can't get it to work, even with redistributing static:
    router eigrp 55
    redistribute static route-map Static-Routes-ACL
    passive-interface GigabitEthernet0/0
    passive-interface GigabitEthernet0/1
    network 10.0.202.0 0.0.0.255
    network 10.10.1.0 0.0.0.255
    <...>

    #sh access-list Static-Routes-ACL
    Standard IP access list Static-Routes-ACL
    10 permit 10.10.59.0, wildcard bits 0.0.0.255 (3 matches)
    20 permit 10.10.50.0, wildcard bits 0.0.0.255
    <...>

    When I go onto a router that has a neighbor relationship, all networks show up except the ones in the Static-Routes-ACL... Any idea why?


    Are you trying to use an access-list in place of a route-map in your redistribution statement?

    Try writing a route-map to match the access-list.


    route-map my-map-name permit 10
    match ip address Static-Routes-ACL

    redistribute static route-map my-map-name metric 10000 10 100 1 1500
  • Forsaken_GAForsaken_GA Member Posts: 4,024
    BURDY53 wrote: »
    When configuring EIGRP, do the network commands pertain only to the ip addresses only on the router its configured on? Or do they include networks on other routers within the same AS?
    Thanks!

    It's a little misleading, I guess. Network commands don't specify what networks you want EIGRP to propagate. It tries to match those network statements to routes that are associated with directly connected interfaces. Ie, if fa0/0 is configured as 10.0.0.1/24, and I enter network 10.0.0.0, it matches the fa0/0 interface, and then propagates the route. If I enter network 11.0.0.0, and I have no interfaces configured with that, then it won't propagate it (unless it's received from a different EIGRP neighbor)

    Where this gets a little fuzzy is when you use static routes. Static routes that are pointed towards directly connected interfaces will match, as those routes are associated with an interface. If the next hop is specified as an IP, and not an interface, then it won't match:

    Example -

    router eigrp 1
    network 192.168.50.0

    No interfaces are configured with an IP that matches, but I have a static route like so -

    ip route 192.168.50.0 255.255.255.0 fa0/0

    Since the static route is pointed at fa0/0, then the EIGRP logic matches, and the router will announce the route.

    If the static route had been defined thusly:

    ip route 192.168.50.0 255.255.255.0 10.0.0.1

    Then it would not have matched, and the router will not announce the route.
  • MrBrianMrBrian Member Posts: 520
    Where this gets a little fuzzy is when you use static routes. Static routes that are pointed towards directly connected interfaces will match, as those routes are associated with an interface. If the next hop is specified as an IP, and not an interface, then it won't match:

    Example -

    router eigrp 1
    network 192.168.50.0

    No interfaces are configured with an IP that matches, but I have a static route like so -

    ip route 192.168.50.0 255.255.255.0 fa0/0

    Since the static route is pointed at fa0/0, then the EIGRP logic matches, and the router will announce the route.

    If the static route had been defined thusly:

    ip route 192.168.50.0 255.255.255.0 10.0.0.1

    Then it would not have matched, and the router will not announce the route.

    Interesting stuff! So it propagates the first ip route example you gave because the "fa0/0" argument is the local interface out which you're telling the router to forward packets out of to get to the 192.168.50.0 net, correct? Which is why with (I think) in ios 12.3 and above, you can enable the routing protocol as an interface subcommand (at least with ospf you can).

    So the EIGRP routing logic will check its local interfaces, against its network/wildcard commands, I get that. However, its possible that it has no interfaces with that net (like 192.168.50.0 in your example), but it has that net mapped in a static route to one of its outgoing interfaces (fa0/0 in your example), and it will end up propagating it this way? I'm gonna have to lab all this to verify, sounds cool though..

    I just started reading 'ROUTE' so please excuse me if I'm off base a little lol
    Currently reading: Internet Routing Architectures by Halabi
  • Forsaken_GAForsaken_GA Member Posts: 4,024
    MrBrian wrote: »
    Interesting stuff! So it propagates the first ip route example you gave because the "fa0/0" argument is the local interface out which you're telling the router to forward packets out of to get to the 192.168.50.0 net, correct? Which is why with (I think) in ios 12.3 and above, you can enable the routing protocol as an interface subcommand (at least with ospf you can).

    So the EIGRP routing logic will check its local interfaces, against its network/wildcard commands, I get that. However, its possible that it has no interfaces with that net (like 192.168.50.0 in your example), but it has that net mapped in a static route to one of its outgoing interfaces (fa0/0 in your example), and it will end up propagating it this way? I'm gonna have to lab all this to verify, sounds cool though..

    I just started reading 'ROUTE' so please excuse me if I'm off base a little lol

    It's not just EIGRP, but the implications of pointing a static route to an interface vs. a next-hop IP address has other implications as well, particularly in route redistribution. But there are a few subtle things that may make you scratch your head. For most intents and purposes, pointing a static route to an interface makes IOS treat that route as though it were a directly connected interface.

    You want real fun? Find a busy border router, and give it a static default route pointing to an ethernet interface instead of a next hop IP address.

    Let me know how long it takes the router to slow down, and then finally crash ;)
Sign In or Register to comment.