Halp a noob!

Agent6376Agent6376 Member Posts: 201
I'm working on familiarizing myself with the Cisco IOS and I've ran into my first roadblock that honestly I know is going to be simple and I'm going to feel goofy as hell for needing to ask you guys for help on this.

I'm going to post the configs for each of these routers and hopefully someone can help me understand why I cannot ping 192.168.1.1 from the 192.168.2.0/24 network.

From the 192.168.2.0/24 network I:
CAN Ping 192.168.1.200
CAN Ping 192.168.4.200
CAN Ping 172.16.10.1
CANNOT Ping 192.168.1.1

Halp icon_redface.gif

Router 1=CCENT
Router 2=Cisco

Router 1's running config:

CCENT#show run
Building configuration...
Current configuration:
!
version 11.2
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname CCENT
!
!
username Joey privilege 15 password 7 04560409022042
ip dhcp-server 192.168.200.1
!
interface Loopback1
ip address 192.168.4.200 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.200 255.255.255.0
loopback
!
interface Serial0
ip address 172.16.10.1 255.255.255.0
encapsulation ppp
loopback
clockrate 9600
!
interface Serial1
no ip address
shutdown
!
router igrp 1
network 192.168.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1 permanent
ip route 192.168.2.0 255.255.255.0 Serial0
ip route 192.168.3.0 255.255.255.0 Serial0
access-list 1 permit any
access-list 50 permit any
banner motd ^C Welcome to Joey's Cisco Lab! ^C
!
line con 0
line aux 0
line vty 0 4
login local
transport input telnet
!
end
CCENT#

Router 2's running config:

Cisco#show run
Building configuration...
Current configuration:
!
version 11.3
service password-encryption
!
hostname Cisco
!
!
username Joey privilege 15 password 7 060B002E414F07
partition flash 2 8 8
!
no ip domain-lookup
!
interface Loopback1
ip address 192.168.3.200 255.255.255.0
!
interface Ethernet0
ip address 192.168.2.200 255.255.255.0
!
interface Serial0
ip address 172.16.20.1 255.255.255.0
encapsulation ppp
!
interface Serial1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.10.1 permanent
ip route 192.168.1.0 255.255.255.0 172.16.10.1
ip route 192.168.4.0 255.255.255.0 192.168.1.200
!
line con 0
line aux 0
line vty 0 4
password 7 141A1D04010524
login local
!


Any help is appreciated!

TIA TE

Comments

  • jeesarejeesare Member Posts: 28 ■□□□□□□□□□
    Not sure if this is relevant to your problem but "ip route 0.0.0.0 0.0.0.0 192.168.1.1", I don't see an interface with this IP.
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    I think you need to draw out a topology diagram and look at your addressing.Is 192.168.1.1 another device connected via a switch? Why are you using ppp between the routers, why have you configured the link with different network addresses on each side, this will work with ppp but just makes life complicated.
    You igrp network statement is incorrect, some of you static routes dont make sense.All in all you probably need to go back and learn about subneting before trying to config a router.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Agent6376Agent6376 Member Posts: 201
    I appreciate the responses, however brutal they are.

    Router 1 is connected to my home router that has the ip address of 192.168.1.1. I'm trying to see how I would route the traffic from the 192.168.2.0 subnet to allow internet access via my home router.

    I'm using ppp between the routers because it's either that or HDLC and honestly I didn't understand why it would be an issue if I chose PPP over HDLC-maybe you could explain.

    The different addresses on each side simulate (to me at least) public and private IP addresses. Yes 172.16.x.y addresses are still private, but it's just a different scheme than good ol' 192.168.x.y.

    How is my igrp statement incorrect, maybe this is why things aren't working?

    Which static routes don't make sense?

    I know how to subnet, so I also don't see how that helps me at all.

    Ed, your statements really don't accomplish anything. If your intention was to help, you failed.

    If anyone has constructive criticism and could answer the orginal question in my first post, I'd appreciate it.
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Forgetting about the complexities of PPP, as i couldn't be bothered to explain, config the encapsulation between the routers as HDLC.Now try and ping between the routers, you will see it fails as the routers are on different subnets.
    IGRP is a classless protocol, 192.168.0.0 is a class C network address which will enable igrp on all interfaces that fall within 192.168.0.x/24,since you do not have any interfaces with a 192.168.0.x address igrp will not be enabled anywhere.

    P.S. Did i make you cry?
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Agent6376Agent6376 Member Posts: 201
    Almighty Ed! How nice of you to actually bring in information that can help someone who already stated that they are new to these studies. I'll change the encapsulation to HDLC and put the routers on the same subnet for kicks.

    Disabling IGRP shouldn't be an issue, but again you're not answering the question.

    IGRP is doing nothing, so that's not what's stopping me from pinging.
    Even though PPP is enabled (and you don't have time to explain it's complexites you busy devil you) I was still able to communicate with the remote router, so the encapsulation isn't the issue either.

    P.S. E-Thugs are fail.
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    I'm such a nice guy i gonna help you more!
    You have a router 192.168.1.1/24, where is is conected? If its connected to CCNET it must be connected to e0, since e0 is already connected to Cisco e0 there must be a switch in between these routers to provide an additional port.Cisco e0 is configured with the wrong ip address, it must be on teh same network as CCENT.
    The problem you have is the addressing is all screwed up, PPP can work off different subnets but ethernet cant.If you fix the addressing and have the correct static routes or enable IGRP correctly it will work.
    Next time provide a "show cdp neighbor" so at least we can see whats connected where.Normally if the addressing was correct we could work this out from the config.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Agent6376Agent6376 Member Posts: 201
    The routers are connected to one another via their serial interfaces.

    CCENT router is connected to 192.168.1.1 via e0 and connected to Cisco via s0

    Cisco router is connected to PC via e0 and CCENT via s0.
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Ok, since you can ping 192.168.1.200 you know you dont have a routing issue in your core.Now the big question is does your home router have a route to 192.168.2.0/24 ? If not you need to add it to use next-hop 192.168.1.200
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • Agent6376Agent6376 Member Posts: 201
    You're the man! My packets knew how to get there, but not how to get back.

    Thank you for the help!
Sign In or Register to comment.