Frame-relay issue

skyborne98skyborne98 Member Posts: 9 ■□□□□□□□□□
I am using my 2 3640 routers for this lab. The weird thing that is happening is the interfaces are up and up. However CDP and ping will not work across the interfaces. Keep in mnd that the routers were reset to factory defaults prior to implementing this config

So what gives?

Here are my configs
Router 1 S3/1 and s3/3
enable
config t
Hostname R1
no ip domain-lookup
frame-relay switching
interface s3/1
ip address 192.168.3.253 255.255.255.252
encap frame-relay
frame-relay intf-type DCE
frame-relay lmi-type ansi
frame-relay map ip 192.168.3.254 102 broadcast cisco
clock rate 64000
bandwidth 64
no shut
exit
router rip
network 192.168.3.252
exit
line con 0
logging synchronous
exit

Router 2 S0/0
enable
config t
hostname R2
no ip domain-lookup
interface s0/0
ip address 192.168.3.254 255.255.255.252
encap frame-relay
frame-relay intf-type DTE
frame-relay lmi-type ansi
frame-relay map ip 192.168.3.253 201 broadcast cisco
bandwidth 64
no shut
exit
router rip
network 192.168.3.252
line con 0
logging synchronous
exit

Comments

  • tim100tim100 Member Posts: 162
    On R1 remove:

    frame-relay map ip 192.168.3.254 102 broadcast cisco

    and add:

    frame-relay interface-dlci 201

    On R2 you can remove:

    frame-relay map ip 192.168.3.253 201 broadcast cisco

    since you did not configure a "no frame-relay inverse-arp" statement
  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    skyborne98 wrote: »
    I am using my 2 3640 routers for this lab.
    What's the purpose of the lab? Do you have a 3rd switch configured as a frame relay switch? Or is it just these two routers configured back-to-back?

    Are you trying to configure one router to act as a frame relay switch and still talk IP to another router attached using frame relay?

    Or are you trying to configure 2 routers to communicate using frame relay encapsulation back-to-back? In which case the trick is to disable LMI with the no keepalive command and to configure the same DLCI on both sides.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • skyborne98skyborne98 Member Posts: 9 ■□□□□□□□□□
    Purpose is just to learn back to back routing for Frame relay. This is actually part of a CCNA course, however Packet tracer will not support this config and this is on my final hands on exam. The final is a 3 router circle configured w/ 3 serial links HDLC/pppw/chap and frame-relay... I can do the first two, but not the third (Frame-Relay).

    The current config, due to lack of serial interfaces is a 3 router chain with ppp with chap and then the second link being frame relay.

    So if i understand the first reply about "no frame-relay inverse-arp" statement broadcasts are currently blocked. Which I have to do anyways on the security portion of the test, by disabling services such as cdp and icmp. So what I really need to do is hang a webserver off an ip on each router and see if i can get to them... via http

    Does that sound about right?
  • tim100tim100 Member Posts: 162
    skyborne98 wrote: »
    Purpose is just to learn back to back routing for Frame relay. This is actually part of a CCNA course, however Packet tracer will not support this config and this is on my final hands on exam. The final is a 3 router circle configured w/ 3 serial links HDLC/pppw/chap and frame-relay... I can do the first two, but not the third (Frame-Relay).

    The current config, due to lack of serial interfaces is a 3 router chain with ppp with chap and then the second link being frame relay.

    Since R1 is connected back-to-back with R2 and is also acting as a router you can configure:

    "frame-relay interface-dlci 100" (or whatever number) on R1 and start pinging R1 from R2 and within 10 seconds the pvc should become active and both routers will be communicating. In lab scenarios I never disabled keepalives with this configuration and it has always worked. The "frame-relay interface-dlci" command would be something like a "frame-relay route" command if the router was switching DLCIs between two other routers. Since R1 is acting as a frame-relay switch and a router connected to R2 the "frame-relay interface-dlci" command on R1 will do the trick. On R2 you can disable frame-relay inverse arp and then configure a frame-relay map statement if you want.
  • KaminskyKaminsky Member Posts: 1,235
    shouldn't network 192.168.3.252 be network 192.168.3.0 for rip routing so it routes that subnet and not the exact ip address ?

    Also, what does show frame-relay { lmi / map / pvc } tell you about the layer 2 traffic across those links ? Are they active, etc or is it only a layer 3 issue ?

    Also, frame-relay map ip 192.168.3.254 102 broadcast cisco - what does the "cisco" do at the end of this line ?

    Also, Shouldn't the switch have a frame-relay route statement ?


    With the two configs you have there, it looks like you have an FR switch with one link and nowhere else to go. The FR switch is layer 2 and shouldn't be doing routing. It knows nothing about routing IP... Just knows how to route frame-relay. You have routing on each of the destination points.

    I could be wrong on these... little fuzzy myself to be honest.
    Kam.
  • tim100tim100 Member Posts: 162
    Kaminsky wrote: »
    shouldn't network 192.168.3.252 be network 192.168.3.0 for rip routing so it routes that subnet and not the exact ip address ?

    The IOS will automatically correct it to the classful network in RIP
    Kaminsky wrote: »
    Also, Shouldn't the switch have a frame-relay route statement ?


    With the two configs you have there, it looks like you have an FR switch with one link and nowhere else to go. The FR switch is layer 2 and shouldn't be doing routing. It knows nothing about routing IP... Just knows how to route frame-relay. You have routing on each of the destination points.

    I could be wrong on these... little fuzzy myself to be honest.

    The routers are connected back-to-back so a frame-relay route statement is not needed.
  • KaminskyKaminsky Member Posts: 1,235
    Well that's confused me Tim.

    Two router FR back to back are on the CCNA ? I don't see the point. Surely it would be node-FRS-node at the bare minimum for FR. Otherwise, who are you trying to talk to ?
    Kam.
  • tim100tim100 Member Posts: 162
    Kaminsky wrote: »
    Well that's confused me Tim.

    Two router FR back to back are on the CCNA ? I don't see the point. Surely it would be node-FRS-node at the bare minimum for FR. Otherwise, who are you trying to talk to ?

    You are right in that it really doesn't make sense to have 2 routers connected back to back with frame-relay encapsulation but it can be done.
  • skyborne98skyborne98 Member Posts: 9 ■□□□□□□□□□
    tim100 wrote: »
    On R1 remove:

    frame-relay map ip 192.168.3.254 102 broadcast cisco

    and add:

    frame-relay interface-dlci 201

    On R2 you can remove:

    frame-relay map ip 192.168.3.253 201 broadcast cisco

    since you did not configure a "no frame-relay inverse-arp" statement
    Can you possibly elaborate on the statement "since you did not configure a "no frame-relay inverse-arp" statement"?

    Keep in mind the purpose of this Lab is to use the frame-relay map command
  • tim100tim100 Member Posts: 162
    skyborne98 wrote: »
    Can you possibly elaborate on the statement "since you did not configure a "no frame-relay inverse-arp" statement"?

    Keep in mind the purpose of this Lab is to use the frame-relay map command

    Inverse-arp attempts to dynamically map an ip address to a DLCI. Similar to the way dynamic ARP resolution works in ethernet. The difference being that in ethernet the IP address is known but the layer 2 address is not but in frame-relay the layer 2 address (DLCI) is known but the IP address is not, hence the name inverse-arp. If you configure "no frame-relay inverse-arp" you have to configure a static mapping via the "frame-relay map ip" statement. Keep in mind that the DLCI pertains to the pvc and is locally significant. It is not the layer 2 address of the node to which the ip address maps as in ethernet.
  • skyborne98skyborne98 Member Posts: 9 ■□□□□□□□□□
    Thanks for all the help guys, its been much appreciated. The following is where I am now. I have added 2 switches, one off of each of the routers. They are just setting there acting as a ping able client. I have finally got ping to work the secret as far as I can tell is to make the dlci the same on both routers... I also changed the lmi type, which should have helped with the cdp neighbors issue, but did not. (However each router sees its switch off of their Fa ports)

    So any ideas why cdp isn't working

    Router 1
    enable
    config t
    Hostname R1
    no ip domain-lookup
    frame-relay switching
    interface s3/1
    ip address 192.168.3.253 255.255.255.252
    encap frame-relay
    frame-relay intf-type DCE
    frame-relay lmi-type cisco
    frame-relay map ip 192.168.3.254 102 broadcast cisco
    clock rate 64000
    bandwidth 64
    no shut
    exit
    interf eth2/0
    ip address 192.168.1.1 255.255.255.252
    no shut
    exit
    router rip
    network 192.168.3.0
    network 192.168.1.0
    exit
    line con 0
    logging synchronous
    exit

    Router 2
    enable
    config t
    hostname R2
    no ip domain-lookup
    interface s0/0
    ip address 192.168.3.254 255.255.255.252
    encap frame-relay
    frame-relay intf-type DTE
    frame-relay lmi-type cisco
    frame-relay map ip 192.168.3.253 102 broadcast cisco
    bandwidth 64
    no shut
    exit
    interf eth0/0
    ip address 192.168.2.1 255.255.255.252
    no shut
    exit
    router rip
    network 192.168.3.0
    network 192.168.2.0
    line con 0
    logging synchronous
    exi
  • captobviouscaptobvious Member Posts: 648
    Configuring Cisco Discovery Protocol (CDP)

    Enabling CDP on an Interface

    CDP is enabled by default on all supported interfaces (except for Frame Relay multipoint subinterfaces) to send and receive CDP information. However, some interfaces, such as ATM interfaces, do not support CDP.


    You can disable CDP on an interface which supports CDP with the no cdp enable command.


    To reenable CDP on an interface after disabling it, use the following command in interface configuration mode:

    cdp enable
    Enables CDP on an interface.
  • skyborne98skyborne98 Member Posts: 9 ■□□□□□□□□□
    CDP was enabled....

    I beleive it to be an IOS issue, I was able to take these configs and put them on some 2800 series routers and it worked. Including CDP.
Sign In or Register to comment.