Options

Router as DHCP Client

zobo88zobo88 Member Posts: 60 ■■□□□□□□□□
Hi
Is it possible to have the router gets IP on one of its interface from DHCP server of another Router ?

I am trying to simulate this in GNS3 with 7200s but it does not seem to be working, I have connected both routers via gigabit interfaces, however the client is not getting an IP address


Here is my config for the DHCP server
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.2.1 192.168.2.2
ip dhcp excluded-address 192.168.2.101 192.168.2.254
!
ip dhcp pool my_test
   import all
   network 192.168.2.0 255.255.255.0
   dns-server 2.2.2.2 
   default-router 202.1.1.1 

interface FastEthernet0/0
 ip address 192.168.1.4 255.255.255.0
 duplex half
 speed auto
!
i
!
interface GigabitEthernet1/0
 ip address 192.168.2.2 255.255.255.0
 negotiation auto
!
for the client


interface GigabitEthernet1/0
 ip dhcp client hostname dd.com
 ip dhcp client update dns
 no ip address
 negotiation auto

Comments

Sign In or Register to comment.