Options

ripng strange behavior

larynxlarynx Registered Users Posts: 2 ■□□□□□□□□□
Hi all, I was reproducing in dynamips the simple ripng lab found in Doyle's "Routing TCP/IP vol1" at page 226.
Basically it is shown how multiple ripng processes can be used to filter updates.
I'm having strange results with the routes propagated by ripng process "two" that runs between R2, R3 and R4's L0.

See the results, it seems something is wrong with R2 not receiving R4's L0 (I'm supposed to see 4000::1/64 both on R2 and on R4).

R1#sh ipv6 ro rip
R 2000:24::/64 [120/2]
via FE80::C801:BFF:FE98:8, FastEthernet0/0
R 4001::/64 [120/3]
via FE80::C801:BFF:FE98:8, FastEthernet0/0
R2#sh ipv6 ro rip
R 3000::/64 [120/2]
via FE80::C802:BFF:FE98:8, FastEthernet1/0
R 3001::/64 [120/2]
via FE80::C802:BFF:FE98:8, FastEthernet1/0
R 4001::/64 [120/2]
via FE80::C803:BFF:FE98:38, FastEthernet2/0
R3#sh ipv6 ro rip
R 2000:24::/64 [120/2]
via FE80::C801:BFF:FE98:1C, FastEthernet0/0
R4#sh ipv6 ro rip
R 2000:12::/64 [120/2]
via FE80::C801:BFF:FE98:38, FastEthernet2/0
R 3000::/64 [120/3]
via FE80::C801:BFF:FE98:38, FastEthernet2/0
R 3001::/64 [120/3]
via FE80::C801:BFF:FE98:38, FastEthernet2/0


However by the debug this route is received by R2

R2#
*Aug 4 21:46:58.887: RIPng: response received from FE80::C803:BFF:FE98:38 on FastEthernet2/0 for two
*Aug 4 21:46:58.891: src=FE80::C803:BFF:FE98:38 (FastEthernet2/0)
*Aug 4 21:46:58.895: dst=FF02::9
*Aug 4 21:46:58.895: sport=527, dport=527, length=52
*Aug 4 21:46:58.899: command=2, version=1, mbz=0, #rte=2
*Aug 4 21:46:58.899: tag=0, metric=1, prefix=2000:24::/64
*Aug 4 21:46:58.899: tag=0, metric=1, prefix=4000::/64


I cannot see this route being sent from R2 to R3.

Also I see it on R2's ripng database clearly it says it's not installed.

R2#sh ipv6 rip database
RIP process "one", local RIB
2000:12::/64, metric 2
FastEthernet0/0/FE80::C800:BFF:FE98:8, expires in 165 secs
2000:24::/64, metric 2
FastEthernet2/0/FE80::C803:BFF:FE98:38, expires in 157 secs
4001::/64, metric 2, installed
FastEthernet2/0/FE80::C803:BFF:FE98:38, expires in 157 secs
RIP process "two", local RIB
2000:23::/64, metric 2
FastEthernet1/0/FE80::C802:BFF:FE98:8, expires in 157 secs
2000:24::/64, metric 2
FastEthernet2/0/FE80::C803:BFF:FE98:38, expires in 155 secs
3000::/64, metric 2, installed
FastEthernet1/0/FE80::C802:BFF:FE98:8, expires in 157 secs
3001::/64, metric 2, installed
FastEthernet1/0/FE80::C802:BFF:FE98:8, expires in 157 secs
4000::/64, metric 2
FastEthernet2/0/FE80::C803:BFF:FE98:38, expires in 155 secs



Can you give me a hint? maybe I'm missing something very simple, but closely followed the book.
Thanks in advance sorry for the long post. Below you can find the configs for the 4 routers and the config I used for dynampis.




ROUTER CONFIGS

R1#sh run
Building configuration...

Current configuration : 837 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip domain lookup
no ip ips deny-action ips-interface
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2000:12::1/64
ipv6 rip one enable
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
no ip http server
no ip http secure-server
!
!
!
ipv6 router rip one
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end




R2#sh run
Building configuration...

Current configuration : 1305 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip domain lookup
no ip ips deny-action ips-interface
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2000:12::2/64
ipv6 rip one enable
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 2000:23::2/64
ipv6 rip two enable
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
duplex auto
speed auto
ipv6 address 2000:24::2/64
ipv6 rip two enable
ipv6 rip one enable
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
no ip http server
no ip http secure-server
!
!
!
ipv6 router rip one
!
ipv6 router rip two
port 527 multicast-group FF02::9
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end



R3#sh run
Building configuration...

Current configuration : 1060 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip domain lookup
no ip ips deny-action ips-interface
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
no ip address
ipv6 address 3000::1/64
ipv6 rip two enable
!
interface Loopback1
no ip address
ipv6 address 3001::1/64
ipv6 rip two enable
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2000:23::3/64
ipv6 rip two enable
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
no ip http server
no ip http secure-server
!
!
!
ipv6 router rip one
!
ipv6 router rip two
port 527 multicast-group FF02::9
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end



R4#sh run
Building configuration...

Current configuration : 1147 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip domain lookup
no ip ips deny-action ips-interface
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
no ip address
ipv6 address 4000::1/64
ipv6 rip two enable
!
interface Loopback1
no ip address
ipv6 address 4001::1/64
ipv6 rip one enable
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet2/0
no ip address
duplex auto
speed auto
ipv6 address 2000:24::4/64
ipv6 rip two enable
ipv6 rip one enable
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
no ip http server
no ip http secure-server
!
!
!
ipv6 router rip one
!
ipv6 router rip two
port 527 multicast-group FF02::9
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end




DYNAMIPS CONFIGURATION FILE

model = 7200
autostart = False
[localhost]

7200
image = D:\Program Files\Dynamips\images\c7200-advipservicesk9-mz.124-2.T
# On Linux / Unix use forward slashes:
# image = /opt/7200-images/c7200-jk9o3s-mz.124-7a.image
ram = 128
idlepc = 0x606e92d8

ROUTER R1
f0/0 = LAN 1

ROUTER R2
f0/0 = LAN 1
f1/0 = LAN 2
f2/0 = LAN 3

ROUTER R3
f0/0 = LAN 2

ROUTER R4
f2/0 = LAN 3

Comments

Sign In or Register to comment.