DHCP via wireless

hypnotoadhypnotoad Banned Posts: 915
Guys,

I never have to configure wireless interfaces in routers, I only do it on APs...Can anyone tell me why the clients (successfully connected to the wireless) wouldn't be able to get an IP address?

Thanks. I'm working remotely on this, which makes troubleshooting wireless more interesting.

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname asdf
!
boot-start-marker
boot-end-marker
!
enable secret 5 $asdf
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool 192.168.100.0s24
   network 192.168.100.0 255.255.255.0
   default-router 192.168.100.1
   domain-name corp.root
   option 150 ip 192.168.100.1
   dns-server 192.168.100.9
!
!
multilink bundle-name authenticated
!
!
class-map type inspect match-any private-telnet
 match protocol telnet
 match protocol ssh
!
!
policy-map type inspect internet-private
 class class-default
policy-map type inspect private-internet
 class type inspect private-telnet
  inspect
 class class-default
!
zone security private
 description Private Addresses
zone security internet
 description Dirty Internet
zone-pair security internet-private source internet destination private
 service-policy type inspect internet-private
zone-pair security private-internet source private destination internet
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 ip address 192.168.100.1 255.255.255.0
 zone-member security private
 duplex auto
 speed auto
!
interface Dot11Radio0
 no ip address
 !
 encryption mode ciphers tkip
 !
 ssid Lush
    authentication open
    authentication key-management wpa
    wpa-psk ascii 0 asdfasdf
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Vlan1
 no ip address
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
scheduler max-task-time 5000
end

Comments

  • stuh84stuh84 Member Posts: 503
    I've not worked with it, but I'd guess at the fact that the Dot11Radio0 interface has no IP, and therefore isn't taking part in Layer 3. I don't see any reference to it using another interface (say, via IP unnumbered or something like that)
    Work In Progress: CCIE R&S Written

    CCIE Progress - Hours reading - 15, hours labbing - 1
  • chmorinchmorin Member Posts: 1,446 ■■■■■□□□□□
    stuh84 wrote: »
    I've not worked with it, but I'd guess at the fact that the Dot11Radio0 interface has no IP, and therefore isn't taking part in Layer 3. I don't see any reference to it using another interface (say, via IP unnumbered or something like that)

    Could be.

    Try giving your clients a address and gateway manually as the DHCP server would assign. Can you ping the gateway?
    Currently Pursuing
    WGU (BS in IT Network Administration) - 52%| CCIE:Voice Written - 0% (0/200 Hours)
    mikej412 wrote:
    Cisco Networking isn't just a job, it's a Lifestyle.
  • Bl8ckr0uterBl8ckr0uter Inactive Imported Users Posts: 5,031 ■■■■■■■■□□
    stuh84 wrote: »
    I've not worked with it, but I'd guess at the fact that the Dot11Radio0 interface has no IP, and therefore isn't taking part in Layer 3. I don't see any reference to it using another interface (say, via IP unnumbered or something like that)

    Maybe this will help:

    Configuring the Cisco 871W wireless router - Wireless - Techguide
  • hypnotoadhypnotoad Banned Posts: 915
    knwminus wrote: »

    Yeah, except I cant figure out where to download this template spreadsheet he made.

    Well, I can't imagine setting an IP on dot11radio 0, since I'd need to find a new subnet so it doesnt overlap with fast 0/4...so I don't think that's it.
  • wastedtimewastedtime Member Posts: 586 ■■■■□□□□□□
    You can set up a Bridged-group virtual interface (BVI) here is a resource that may help on it Understanding and Configuring VLAN Routing and Bridging on a Router Using the IRB Feature - Cisco Systems. Also I see you have a start of a ZBF (Zone-Based Policy Firewall - Cisco Systems) that could give you some issues.
  • hypnotoadhypnotoad Banned Posts: 915
    wastedtime wrote: »
    You can set up a Bridged-group virtual interface (BVI) here is a resource that may help on it Understanding and Configuring VLAN Routing and Bridging on a Router Using the IRB Feature - Cisco Systems. Also I see you have a start of a ZBF (Zone-Based Policy Firewall - Cisco Systems) that could give you some issues.


    I think you're right on the BVI (and probably the ZBF too). This is pretty much a fresh load and I kind of assumed I could get by without creating an BVI for some simple stuff.
Sign In or Register to comment.