Options

EIGRP Summary Route AD

peanutnogginpeanutnoggin Member Posts: 1,096 ■■■□□□□□□□
TE,

I'm currently reading the ROUTE Foundation Learning Guide. I noticed early in the book (pg. 42) lists a table of administrative distances... nothing out of the ordinary but I noticed EIGRP's summary routes has an administrative distance of 5. I didn't recall ever seeing a 5 without it being manually configured. I checked Cisco's site and found this link. This table was the exact table that was from the book. I decided to lab a topology of three routers and I could not produce an administrative distance of 5 for summary routes without manually configuring it. Here's the code from the routers.

R1's info:
R1(config)#do sh run int s0/0  
Building configuration...

Current configuration : 68 bytes
!
interface Serial0/0
 ip address 192.168.13.1 255.255.255.248
end

R1(config)#do sh run int s0/1  
Building configuration...

Current configuration : 68 bytes
!
interface Serial0/1
 ip address 192.168.12.1 255.255.255.248
end

R1(config)#do sh ip route      
! removed for clarity

Gateway of last resort is not set

     192.168.12.0/29 is subnetted, 1 subnets
C       192.168.12.0 is directly connected, Serial0/1
     192.168.13.0/29 is subnetted, 1 subnets
C       192.168.13.0 is directly connected, Serial0/0
     2.0.0.0/22 is subnetted, 1 subnets
D       2.2.0.0 [90/2297856] via 192.168.12.2, 00:14:43, Serial0/1
     3.0.0.0/22 is subnetted, 1 subnets
D       3.3.0.0 [90/2297856] via 192.168.13.3, 00:01:42, Serial0/0
     192.168.23.0/29 is subnetted, 1 subnets
D       192.168.23.0 [90/2681856] via 192.168.13.3, 00:16:28, Serial0/0
                     [90/2681856] via 192.168.12.2, 00:16:28, Serial0/1

R1(config)#do sh run | s eigrp 
router eigrp 1
 network 192.168.12.0
 network 192.168.13.0
 no auto-summary
R1(config)#


R1 is showing routes 2.2.0.0 & 3.3.0.0 as an administrative distance of 90 (which is EIGRP internal route administrative distance).


R2's info:
R2#sh run int s0/0
Building configuration...

Current configuration : 120 bytes
!
interface Serial0/0
 ip address 192.168.23.2 255.255.255.248
 ip summary-address eigrp 1 2.2.0.0 255.255.252.0 5
end

R2#sh run int s0/1
Building configuration...

Current configuration : 120 bytes
!
interface Serial0/1
 ip address 192.168.12.2 255.255.255.248
 ip summary-address eigrp 1 2.2.0.0 255.255.252.0 5
end

R2#sh ip route
! removed for clarity

Gateway of last resort is not set

     192.168.12.0/29 is subnetted, 1 subnets
C       192.168.12.0 is directly connected, Serial0/1
     192.168.13.0/29 is subnetted, 1 subnets
D       192.168.13.0 [90/2681856] via 192.168.23.3, 00:05:05, Serial0/0
                     [90/2681856] via 192.168.12.1, 00:05:05, Serial0/1
     2.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D       2.2.0.0/22 is a summary, 00:05:05, Null0
C       2.2.1.0/24 is directly connected, Loopback1
C       2.2.2.0/24 is directly connected, Loopback2
C       2.2.3.0/24 is directly connected, Loopback3
     3.0.0.0/22 is subnetted, 1 subnets
D       3.3.0.0 [90/2297856] via 192.168.23.3, 00:05:05, Serial0/0
     192.168.23.0/29 is subnetted, 1 subnets
C       192.168.23.0 is directly connected, Serial0/0

R2#sh run | s eigrp
 ip summary-address eigrp 1 2.2.0.0 255.255.252.0 5
 ip summary-address eigrp 1 2.2.0.0 255.255.252.0 5
router eigrp 1
 network 2.2.0.0 0.0.3.255
 network 192.168.12.0
 network 192.168.23.0
 no auto-summary
R2#

R3's info:
R3#sh run int s0/0
Building configuration...

Current configuration : 120 bytes
!
interface Serial0/0
 ip address 192.168.13.3 255.255.255.248
 ip summary-address eigrp 1 3.3.0.0 255.255.252.0 5
end

R3#sh run int s0/1
Building configuration...

Current configuration : 120 bytes
!
interface Serial0/1
 ip address 192.168.23.3 255.255.255.248
 ip summary-address eigrp 1 3.3.0.0 255.255.252.0 5
end

R3#sh ip route
! removed for clarity

Gateway of last resort is not set

     192.168.12.0/29 is subnetted, 1 subnets
D       192.168.12.0 [90/2681856] via 192.168.23.2, 00:23:53, Serial0/1
                     [90/2681856] via 192.168.13.1, 00:23:53, Serial0/0
     192.168.13.0/29 is subnetted, 1 subnets
C       192.168.13.0 is directly connected, Serial0/0
     2.0.0.0/22 is subnetted, 1 subnets
D       2.2.0.0 [90/2297856] via 192.168.23.2, 00:22:09, Serial0/1
     3.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D       3.3.0.0/22 is a summary, 00:09:08, Null0
C       3.3.1.0/24 is directly connected, Loopback1
C       3.3.2.0/24 is directly connected, Loopback2
C       3.3.3.0/24 is directly connected, Loopback3
     192.168.23.0/29 is subnetted, 1 subnets
C       192.168.23.0 is directly connected, Serial0/1

R3#sh run | s eigrp
 ip summary-address eigrp 1 3.3.0.0 255.255.252.0 5
 ip summary-address eigrp 1 3.3.0.0 255.255.252.0 5
router eigrp 1
 network 3.3.0.0 0.0.3.255
 network 192.168.13.0
 network 192.168.23.0
 no auto-summary
R3#

Am I missing something? Thanks.

-Peanut
We cannot have a superior democracy with an inferior education system!

-Mayor Cory Booker

Comments

  • Options
    kidfrykidfry Member Posts: 9 ■□□□□□□□□□
    I'm in the process of reading this book as well - In fact, I just received it last week... Ironically, I'm just starting Chapt. 2 EIGRP as well!

    Anyway... On pg. 113 within the highlighted 'Note' section, it states the following!
    You will notice the EIGRP summary route with an AD of 5 only on the local router that is performing the summarization (with the ip summary-address eigrp command), by using the 'show ip route network' command, where network is the specified summarized route.
    Does this help?
  • Options
    CCNAwannabeCCNAwannabe Member Posts: 44 ■■□□□□□□□□
    It looks like the AD command is only in effect for the local routers summary address.. Check this out:

    Cisco IOS IP Configuration Guide, Release 12.2 - Configuring EIGRP - Cisco Systems

    Look under Configuring Floating Summary Routes

    Quite interesting...
  • Options
    peanutnogginpeanutnoggin Member Posts: 1,096 ■■■□□□□□□□
    Kidfry,

    You're spot on... Thanks for pointing that out in the book. After flipping to that page, I now understand. I labbed the configuration again and I was able to see the following:
    R1#sh ip route 172.16.0.0 255.255.248.0
    Routing entry for 172.16.0.0/21
      Known via "eigrp 10", [b]distance 5[/b], metric 128256, type internal
      Redistributing via eigrp 10
      Routing Descriptor Blocks:
      * directly connected, via Null0
          Route metric is 128256, traffic share count is 1
          Total delay is 5000 microseconds, minimum bandwidth is 10000000 Kbit
          Reliability 255/255, minimum MTU 1514 bytes
          Loading 1/255, Hops 0
    

    CCNAWannabe, thank you too for the link.

    -Peanut
    We cannot have a superior democracy with an inferior education system!

    -Mayor Cory Booker
Sign In or Register to comment.