[Solved]EIGRP and frame-relay Hub&Spoke and point to point

thehourmanthehourman Member Posts: 723
I am really lost now with my setup. I have a R1 as the HUB and R2 and R3 as the spokes routers. Also, R1 and R4 and point to point. I have no ip split-horizon on R1's serial0/0. However, on R2, I am not getting the loopback address that I have configured from R3, and R3 is not getting the loopbacks address from R2.

R1 and R4 have all the routes, but R2 is missing all the routes to R3's loopback address, and vice versa on R3.

Here are the running-config:
FRS:
FRS#show run
Building configuration...

Current configuration : 1986 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
frame-relay switching
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
!
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 201 interface Serial1/1 102
 frame-relay route 301 interface Serial1/2 103
 frame-relay route 401 interface Serial1/3 104
!
interface Serial1/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 102 interface Serial1/0 201
!
interface Serial1/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 103 interface Serial1/0 301
!
interface Serial1/3
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 104 interface Serial1/0 401
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

FRS# 
R1:
HQ#show run
Building configuration...

Current configuration : 1732 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HQ
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
no network-clock-participate slot 1 
no network-clock-participate wic 0 
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!         
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!
interface Loopback2
 ip address 172.16.2.1 255.255.255.0
!
interface Loopback3
 ip address 172.16.3.1 255.255.255.0
!
interface Loopback4
 ip address 172.16.4.1 255.255.255.0
!
interface Loopback5
 ip address 172.16.5.1 255.255.255.0
!
interface Loopback6
 ip address 172.16.6.1 255.255.255.0
!
interface Loopback7
 ip address 172.16.7.1 255.255.255.0
!
interface Loopback8
 ip address 172.16.8.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip split-horizon eigrp 25
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.9 255.255.255.252
 frame-relay interface-dlci 401   
!
interface Serial0/0.2 multipoint
 ip address 10.1.1.1 255.255.255.248
 frame-relay map ip 10.1.1.2 201 broadcast
 frame-relay map ip 10.1.1.3 301 broadcast
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 25
 network 10.1.1.1 0.0.0.0
 network 10.1.1.9 0.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

HQ# 
R2:
R2#show run
Building configuration...

Current configuration : 1555 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
no network-clock-participate slot 1 
no network-clock-participate wic 0 
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!         
!
interface Loopback0
 ip address 172.17.0.1 255.255.255.0
!
interface Loopback1
 ip address 172.17.1.1 255.255.255.0
!
interface Loopback2
 ip address 172.17.2.1 255.255.255.0
!
interface Loopback3
 ip address 172.17.3.1 255.255.255.0
!
interface Loopback4
 ip address 172.17.4.1 255.255.255.0
!
interface Loopback5
 ip address 172.17.5.1 255.255.255.0
!
interface Loopback6
 ip address 172.17.6.1 255.255.255.0
!
interface Loopback7
 ip address 172.17.7.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.2 multipoint
 ip address 10.1.1.2 255.255.255.248
 frame-relay map ip 10.1.1.1 102 broadcast
 frame-relay map ip 10.1.1.3 102 broadcast
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!         
router eigrp 25
 network 10.1.1.2 0.0.0.0
 network 172.17.0.0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

R2# 
R3:
R3#show run
Building configuration...

Current configuration : 1341 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
no network-clock-participate slot 1 
no network-clock-participate wic 0 
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!    
!
interface Loopback0
 ip address 172.18.0.1 255.255.255.0
!
interface Loopback1
 ip address 172.18.1.1 255.255.255.0
!
interface Loopback2
 ip address 172.18.2.1 255.255.255.0
!
interface Loopback3
 ip address 172.18.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.1.3 255.255.255.248
 encapsulation frame-relay
!         
interface Serial0/0.2 multipoint
 ip address 10.1.1.3 255.255.255.248
 frame-relay map ip 10.1.1.1 103 broadcast
 frame-relay map ip 10.1.1.2 103 broadcast
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 25
 network 10.1.1.3 0.0.0.0
 network 172.18.0.0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!         
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end
          
R3#
R4:
R4#show run
Building configuration...

Current configuration : 1404 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
no network-clock-participate slot 1 
no network-clock-participate wic 0 
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
 ip address 192.168.2.1 255.255.255.0
!
interface Loopback3
 ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 ip hello-interval eigrp 25 5
 ip hold-time eigrp 25 15
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.10 255.255.255.252
 frame-relay interface-dlci 104   
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
!
router eigrp 25
 network 10.1.1.10 0.0.0.0
 network 192.168.0.0 0.0.255.255
 no auto-summary
!
ip forward-protocol nd
!         
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

R4#  
Studying:
Working on CCNA: Security. Start date: 12.28.10
Microsoft 70-640 - on hold (This is not taking me anywhere. I started this in October, and it is December now, I am still on page 221. WTH!)
Reading:
Network Warrior - Currently at Part II
Reading IPv6 Essentials 2nd Edition - on hold

Comments

  • kalebkspkalebksp Member Posts: 1,033 ■■■■■□□□□□
    You should disable split horizon on the interface which is running EIGRP. S0/0 isn't running EIGRP in your configuration so 'no ip split-horizon' isn't doing anything for you there.
  • thehourmanthehourman Member Posts: 723
    I am about to edit my post and saw your reply.
    I used no ip split-horizon eigrp 25 on the hub router under serial0/0.2 multipoint

    I assumed that when I used the no split-horizon on the physical interface I thought that it would apply it to eigrp multipoint interface
    Studying:
    Working on CCNA: Security. Start date: 12.28.10
    Microsoft 70-640 - on hold (This is not taking me anywhere. I started this in October, and it is December now, I am still on page 221. WTH!)
    Reading:
    Network Warrior - Currently at Part II
    Reading IPv6 Essentials 2nd Edition - on hold
Sign In or Register to comment.