Options

Issues with DMVPN and Eigrp

amb1s1amb1s1 Member Posts: 408
OK I have three routers. R2 is connect to R1 and R1 connects to R3. I want to be able to to create a two tunnels on R1 that connects to R2 and R3. Created the tunnels, when I created the first one, everything was fine, but when I created the second tunnel I get the following message:

*Mar 1 00:30:05.803: IP-EIGRP(Default-IP-Routing-Table:90): Neighbor 192.168.1.2 not on common subnet for Tunnel1
The following are my configs

R1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
crypto isakmp policy 10
 hash md5
 authentication pre-share
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
!         
!
crypto ipsec transform-set strong esp-3des esp-md5-hmac 
!
crypto ipsec profile cisco
 set security-association lifetime seconds 120
 set transform-set strong 
!
!
!
!
!
interface Tunnel0
 ip address 192.168.1.1 255.255.255.0
 no ip redirects
 ip mtu 1440
 no ip next-hop-self eigrp 90
 ip nhrp authentication cisco123
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 no ip split-horizon eigrp 90
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 0
 tunnel protection ipsec profile cisco
!
interface Tunnel1
 ip address 192.168.2.1 255.255.255.0
 no ip redirects
 ip mtu 1440
 no ip next-hop-self eigrp 90
 ip nhrp authentication cisco123
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 no ip split-horizon eigrp 90
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 0
 tunnel protection ipsec profile cisco
!
interface FastEthernet0/0
 ip address 65.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 67.0.0.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 90
 network 192.168.1.0
 network 192.168.2.0
 no auto-summary
!
ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 65.0.0.0 255.255.255.0 FastEthernet0/0
ip route 67.0.0.0 255.255.255.0 FastEthernet1/0
!
!
!
!
!
control-plane
!
!
!         
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end



R2
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
crypto isakmp policy 10
 hash md5
 authentication pre-share
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
!         
!
crypto ipsec transform-set strong esp-3des esp-md5-hmac 
!
crypto ipsec profile cisco
 set security-association lifetime seconds 120
 set transform-set strong 
!
!
!
!
!
interface Tunnel0
 ip address 192.168.2.2 255.255.255.0
 no ip redirects
 ip mtu 1440
 ip nhrp authentication cisco123
 ip nhrp map multicast dynamic
 ip nhrp map 192.168.2.1 67.0.0.2
 ip nhrp map multicast 67.0.0.2
 ip nhrp network-id 1
 ip nhrp nhs 192.168.2.1
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 0
 tunnel protection ipsec profile cisco
!
interface FastEthernet0/0
 ip address 67.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 90
 network 192.168.2.0
 no auto-summary
!
ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!         
end


R3
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
crypto isakmp policy 10
 hash md5
 authentication pre-share
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
!         
!
crypto ipsec transform-set strong esp-3des esp-md5-hmac 
!
crypto ipsec profile cisco
 set security-association lifetime seconds 120
 set transform-set strong 
!
!
!
!
!
interface Tunnel0
 ip address 192.168.1.2 255.255.255.0
 no ip redirects
 ip mtu 1440
 ip nhrp authentication cisco123
 ip nhrp map multicast dynamic
 ip nhrp map 192.168.1.1 65.0.0.2
 ip nhrp map multicast 65.0.0.2
 ip nhrp network-id 1
 ip nhrp nhs 192.168.1.1
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 0
 tunnel protection ipsec profile cisco
!
interface FastEthernet0/0
 ip address 65.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 90
 network 192.168.1.0
 no auto-summary
!
ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!         
end
David G.
http://gomezd.com <
My Tshoot test Blog
http://twitter.com/ipnet255

Comments

  • Options
    paulitblgpaulitblg Registered Users Posts: 6 ■□□□□□□□□□
    Hi amb1s1

    Look at your tunnel interface IP addresses. They are on different subnets.

    Read the output message again. The answer is in the output message

    Remember what the requirements are to become eigrp neighbours

    The routers must be able to send or receive IP packets to one another.
    Interfaces’ IP addresses must be in the same subnet.
    The routers must not be passive in the connected interface.
    The routers must pass neighbor authentication, if configured.
    The K-values used for the calculation of metrics must match.
Sign In or Register to comment.