Network communication help

feenixfirefeenixfire Registered Users Posts: 3 ■□□□□□□□□□
Hi all,
I've been in IT for years on the admin side but i'm new at Cisco configuration. I'm working on my CCNA and i've been going through some router configurations, learning the cmds, etc. I have 2 routers that can communicate with each other via serial. Attached to R2 f0/0 i have attached a switch f0/1 via straight through, then a computer attached to f0/2 on the switch. This is a cut down version of what i'm working on because i'm trying to figure out why my switch can't communicate with my router. I'm sure it's something simple i'm missing but I can't seem to find it. The section i'm studying hasn't gone into switch configuration and vlans but I know i have to setup a vlan which i thought i did properly but still no luck. The interfaces are showing red and they're both set to be up, using a straight through ethernet, but still no luck. Can someone please tell me where i'm going wrong here?

Here's the R2 config:
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
enable secret 5 $1$mERr$5jbOD5lHVUWxAAsNOD6eO/
enable password password
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description Private LAN
ip address 25.0.0.1 255.0.0.0
duplex full
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial1/0
description WAN-To-ISP
ip address 24.0.0.2 255.0.0.0
!
interface Serial1/1
no ip address
!
interface Serial1/2
no ip address
!
interface Serial1/3
no ip address
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
password telnet
login
!
!
!
end



Here's the switch config
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname LOCAL-SWITCH
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
ip address 25.0.0.2 255.0.0.0
!
ip default-gateway 25.0.0.1
!
banner motd
Unauthorized access is forbidden

!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

Comments

  • BrakarificBrakarific Member Posts: 23 ■□□□□□□□□□
    I'd need to see "show ip int" output to properly troubleshoot, but just off the cuff, make sure you use the "no shutdown" command on both the router fa 0/0 interface and the Vlan 1 interface on the switch. I know this sounds obvious, but I never put it past myself to forget a little detail like that. Also, a red light generally means a physical layer comm. failure. This generally means the cable terminations are bad.
  • feenixfirefeenixfire Registered Users Posts: 3 ■□□□□□□□□□
    Brakarific wrote: »
    I'd need to see "show ip int" output to properly troubleshoot, but just off the cuff, make sure you use the "no shutdown" command on both the router fa 0/0 interface and the Vlan 1 interface on the switch. I know this sounds obvious, but I never put it past myself to forget a little detail like that.

    Hey I'm a n00b so I'm fully expecting this issue to have an obvious solution :-p Here's the show ip int results for the switch and router. The only thing i can think of is the router link show up / down. Do you have to configure some protocol on the router's port? I did run the no shutdown on both interfaces.

    Switch results
    LOCAL-SWITCH#show ip int
    Vlan1 is up, line protocol is up
    Internet address is 25.0.0.2/8
    Broadcast address is 255.255.255.255
    Address determined by setup command
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Outgoing access list is not set
    Inbound access list is not set
    Proxy ARP is enabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is disabled
    IP fast switching on the same interface is disabled
    IP Null turbo vector
    IP multicast fast switching is disabled
    IP multicast distributed fast switching is disabled
    IP route-cache flags are None
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Probe proxy name replies are disabled
    Policy routing is disabled
    Network address translation is disable
    WCCP Redirect outbound is disabled
    WCCP Redirect inbound is disabled
    WCCP Redirect exclude is disabled
    BGP Policy Mapping is disabled


    Router results:
    R2#show ip int
    FastEthernet0/0 is up, line protocol is down (disabled)
    Internet address is 25.0.0.1/8
    Broadcast address is 255.255.255.255
    Address determined by setup command
    MTU is 1500
    Helper address is not set
    Directed broadcast forwarding is disabled
    Outgoing access list is not set
    Inbound access list is not set
    Proxy ARP is enabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is disabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP Fast switching turbo vector
    IP multicast fast switching is disabled
    IP multicast distributed fast switching is disabled
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Probe proxy name replies are disabled
    Policy routing is disabled
    Network address translation is disabled
    WCCP Redirect outbound is disabled
    WCCP Redirect exclude is disabled
    BGP Policy Mapping is disabled
    FastEthernet0/1 is administratively down, line protocol is down (disabled)
    Internet protocol processing disabled
    Serial1/0 is up, line protocol is down (disabled)
    Internet address is 24.0.0.2/8
    Broadcast address is 255.255.255.255
    Address determined by setup command
    MTU is 1500
    Helper address is not set
    Directed broadcast forwarding is disabled
    Outgoing access list is not set
    Inbound access list is not set
    Proxy ARP is enabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is disabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP Fast switching turbo vector
    IP multicast fast switching is disabled
    IP multicast distributed fast switching is disabled
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Probe proxy name replies are disabled
    Policy routing is disabled
    Network address translation is disabled
    WCCP Redirect outbound is disabled
    WCCP Redirect exclude is disabled
    BGP Policy Mapping is disabled
    Serial1/1 is down, line protocol is down (disabled)
    Internet protocol processing disabled
    Serial1/2 is down, line protocol is down (disabled)
    Internet protocol processing disabled
    Serial1/3 is down, line protocol is down (disabled)
    Internet protocol processing disabled
  • KrisAKrisA Member Posts: 142
    Brakarific wrote: »
    I'd need to see "show ip int" output to properly troubleshoot, but just off the cuff, make sure you use the "no shutdown" command on both the router fa 0/0 interface and the Vlan 1 interface on the switch. I know this sounds obvious, but I never put it past myself to forget a little detail like that. Also, a red light generally means a physical layer comm. failure. This generally means the cable terminations are bad.

    Agreed

    See also
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown

    Tells me the port is turned off.
    WGU Progress BSIT:NA | Current Term:1 | Transfered To-Do In Progress Completed
    EWB2 BAC1 BBC1 TSV1 WFV1 CLC1 LAE1 LUT1 LAT1 AXV1 TTV1 INC1 INT1 TPV1 SST1 SSC1 GAC1 HHT1 TNV1 QLT1 BOV1 LET1 ORC1 IWC1 IWT1 MGC1 ABV1 AHV1 AJV1 TWA1 CPW2 BRV1
    Currently Reading
    Darril Book
  • feenixfirefeenixfire Registered Users Posts: 3 ■□□□□□□□□□
    The fa0/1 on the router isn't being used, i'm using fa0/0. That being said, however, I found the issue. My speed was different for both interfaces so i set speed on the switch and router to 100 and half duplex. I haven't read anything about those yet but can they both be left at auto?
  • networker050184networker050184 Mod Posts: 11,962 Mod
    feenixfire wrote: »
    The fa0/1 on the router isn't being used, i'm using fa0/0. That being said, however, I found the issue. My speed was different for both interfaces so i set speed on the switch and router to 100 and half duplex. I haven't read anything about those yet but can they both be left at auto?

    Yep, best bet is to just leave them both to auto.
    An expert is a man who has made all the mistakes which can be made.
  • BrakarificBrakarific Member Posts: 23 ■□□□□□□□□□
    Glad you found the fault, I thought about negotiation, but didn't think much further. Which is funny, because I've been reading Gary Donahue's book 'Network Warrior' and he goes into detail as to how often he sees speed negotiation issues in one of his first chapters. So kudos to you for being a better troubleshooter than all of us.
  • pham0329pham0329 Member Posts: 556
    Hm, can someone explain to me why the speed mismatched would cause the link to go down? I can see packets being dropped due to the duplex mismatch resulting from the speed mismatched, but for the link to go down? From what I remember, if one side can't auto negotiate the speed/duplex, it'll just default to the 10/half, 100/full standard....right?
  • BrakarificBrakarific Member Posts: 23 ■□□□□□□□□□
    If it's at 10 half on one side and 100 full on the other side, you will have crazy amounts of packet loss on both ends. The 10 side won't be able to handle the rate at which it will receive data from the 100 side. Plus, if one is half duplex, and the other is full, the full side won't try to avoid collisions. Auto-negotiation doesn't always work as designed, not enough room to write up why, but here is a link -
    Duplex mismatch - Wikipedia, the free encyclopedia
  • pham0329pham0329 Member Posts: 556
    I can see that on a production network, but on a lab with zero traffic, how does a speed/duplex mismatch bring down a link? My initial thought was stp, but again, not enough traffic to really be a problem
  • BrakarificBrakarific Member Posts: 23 ■□□□□□□□□□
    Doesn't have to be a production network. I have seen this twice in my career, and both times it was when I was setting up equipment before a deployment (In my case, Cisco gear wasn't involved, it was Mikrotik). Basically, if you set one as static and the other as auto, it can cause weird things happen, more especially on fiber links, and yet even more so with with Gig interfaces and Non Gig interfaces. Here is how negotiation works, both interfaces start low and go high, sometimes if an interface is statically set to a speed, it will tell the other interface "yeah sure, I can do 10 BaseT, no problem," and the other interface decides to stop there instead of asking about 100 BaseT. This was your problem. In Gary Donahue's book 'Network Warrior', it explains it much better than I can.

    Gig interfaces are worse, because starting with 1000BaseT ethernet standards, instead of negotiating bottom up, it negotiates from top speed down. This is how it should have always been in my opinion, but with the two different methods at play, interesting things with auto-negotiation have been known to happen.
  • pham0329pham0329 Member Posts: 556
    I was going to give Network Warrior a read once I get through ROUTE, so it's good to know it contains some useful information. However, I think you misunderstood my question. I know that when there's a link/speed mismatch, the link see packet loss or underperform. My question was why in the OP's situation, the link didn't come up just because of the speed mismatch?

    Your explanation and reference only explains why speed mismatch cause problems with the link, not why it won't come up because of the mismatch. I've tested this with the 3550s
    • Sw1 = 10/half, sw2 = 100/full = link came up
    • Sw1 = 10/half, sw2 = auto (100/full) = link came up
  • Timber WolfTimber Wolf Member Posts: 90 ■■□□□□□□□□
    I think it may very between devices and IOS's. I had a 2610xm with NM-4e hooked up to a 3550 and the link came up as up down and yelled at me that there was a mismatch and did not fully come up until i changed the settings on both the router and switch.
    WGU BS IT - Security
    Need to complete: CSV1 BOV1 RIT1 BNC1 KET1 TPV1 MGC1 CJV1 KFT1 CNV1 SBT1 RGT1
    Completed: CUV1 CTV1
    Transferred: CVV1 DJV1 IWT1 IWC1 BVC1 QLT1 DHV1 HHT1 GAC1 DFV1 INT1 INC1 CPV1 AXV1 QBT1 LUT1 LAE1 CLC1 BBC1 AGC1 WFV1 CQV1 COV1
  • BrakarificBrakarific Member Posts: 23 ■□□□□□□□□□
    pham0329-'Your explanation and reference only explains why speed mismatch cause problems with the link, not why it won't come up because of the mismatch.'

    Ahh, ok, I see what you are saying. I did misunderstand you. Why the LED would be Red? I have no idea. You are right, it should have just been a mismatch, not a completely dead link. So, I guess this is a question for someone with obviously more experience than the both of us. Looks like Timber Wolf had the same issue, but as for an explanation, I don't have one.
Sign In or Register to comment.