RIPv2 Problem

fluk3dfluk3d Member Posts: 141 ■■■□□□□□□□
I'm working through configuring RIPv2 between two routers in GNS3 and I've hit a wall. I attached the network topology diagram and RIPv2 is working between the Ottawa & Vancouver router however Toronto Router does not seem to be getting any updates. If I run a debug ip rip on the Ottawa router I can send that it's sending and getting updates on all interfaces however if I do a debug ip rip on the Toronto router this is what I get


*Mar 1 00:15:05.851: RIP: ignored v2 packet from 192.168.168.6 (sourced from one of our addresses)
*Mar 1 00:15:20.675: RIP: sending v2 update to 255.255.255.255 via Serial0/0 (192.168.168.6)
*Mar 1 00:15:20.679: RIP: build update entries - suppressing null update


Anyone notice if I'm doing something wrong?

Thank you

Config of Ottawa Router


!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service dhcp
!
hostname Ottawa
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.199
!
ip dhcp pool loopback_lan
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
!
!
!
!
!
crypto pki trustpoint TP-self-signed-4279256517
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4279256517
revocation-check none
rsakeypair TP-self-signed-4279256517
!
!
crypto pki certificate chain TP-self-signed-4279256517
certificate self-signed 01 nvram:IOS-Self-Sig#3737.cer
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1/0
shutdown
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Ethernet2/0
no ip address
shutdown
half-duplex
!
interface Ethernet2/1
no ip address
shutdown
half-duplex
!
interface Ethernet2/2
no ip address
shutdown
half-duplex
!
interface Ethernet2/3
no ip address
shutdown
half-duplex
!
interface Serial3/0
ip address 192.168.168.6 255.255.255.252
ip nat outside
ip virtual-reassembly
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface Vlan1
no ip address
!
no ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
banner motd ** Ottawa Router - MOTD **
!
line con 0
exec-timeout 0 0
password 7 REMOVED
logging synchronous
login
line aux 0
line vty 0 1
password REMOVED
login
line vty 2 4
login
!
!
end


Config Toronto Router


Current configuration : 1708 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Toronto
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Serial0/0
ip address 192.168.168.6 255.255.255.252
ip rip v2-broadcast
ip rip send version 2
ip rip receive version 2
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Ethernet2/0
no ip address
shutdown
half-duplex
!
interface Ethernet2/1
no ip address
shutdown
half-duplex
!
interface Ethernet2/2
no ip address
shutdown
half-duplex
!
interface Ethernet2/3
no ip address
shutdown
half-duplex
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
no ip address
!
router rip
version 2
network 192.168.168.0
!
no ip http server
no ip http secure-server
!
!
!
!
!
--More--
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end


"Imagination is more important than knowledge." - Albert Einstein

Comments

  • pham0329pham0329 Member Posts: 556
    you configured the same ip (192.168.168.6) on both the Ottawa router and the Toronto S0/0 interface
  • fluk3dfluk3d Member Posts: 141 ■■■□□□□□□□
    Well I feel like an idiot! thank you, I had to disable, and re-enable rip but after that sh ip route rip shoes all my routes to my vancouver router.

    Thanks again!
    "Imagination is more important than knowledge." - Albert Einstein
  • fluk3dfluk3d Member Posts: 141 ■■■□□□□□□□
    Also regarding the ip classes command is it necessary even tho ripv2 advertises classes networks? is that command only to be used when using ripv1?
    "Imagination is more important than knowledge." - Albert Einstein
Sign In or Register to comment.