Options

Advertising Static Routes with Network Statements

reloadedreloaded Member Posts: 235
Hello all. So at work, I've been given the task to migrate a smaller network based on EIGRP/static routing to OSPF. The boss tells me he doesn't want any redistribute static or connected (i.e. clean config), so I'm looking to advertise some external customer routes via network statements in EIGRP and then OSPF at a later date.

So I start playing around in GNS3 and notice that EIGRP will only advertise static routes via network statements if the static route points to the exit interface, not the next hop:


ip route 12.12.12.12 255.255.255.255 F1/0
!
router eigrp 10
network 12.0.0.0


If the static route is configured for the exit interface, the route will propagate to adjacent EIGRP routers.

However, how can I get this to work in OSPF? I'm using network statements to advertise static routes configured with either the next hop or exit interface and the routes aren't being propagated to adjacent OSPF routers.


ip route 12.12.12.12 255.255.255.255 F1/0 or next hop
!
router ospf 10
network 12.12.12.12 0.0.0.0 area 0


Would rather not use redistribute static under OSPF if I don't have to. Any thoughts??
Reloaded~4~Ever

Comments

  • Options
    NetworkVeteranNetworkVeteran Member Posts: 2,338 ■■■■■■■■□□
    reloaded wrote: »
    The boss tells me he doesn't want any redistribute static or connected (i.e. clean config), so I'm looking to advertise some external customer routes via network statements in EIGRP and then OSPF at a later date.

    ip route 12.12.12.12 255.255.255.255 F1/0 or next hop
    !
    router ospf 10
    network 12.12.12.12 0.0.0.0 area 0


    Would rather not use redistribute static under OSPF if I don't have to. Any thoughts??

    Yes. My thought is, whatever your boss wants to call it, what you're doing is redistributing static routes into OSPF. Use the 'redistribute' command since that's made for that purpose.

    Dig deeper to find out his real business concern is with using the 'redistribute' command. Once you understand that, you can work to address any valid concerns and also to clear up any misconceptions. For example, one concern might be that you do not have direct control over which routes are redistributed. You could address that with a route map. That could also be used to tag these static routes so they could be treated differently elsewhere. It's a flexible command.

    Perhaps he wants you to take another approach entirely where there are no static routes at all. As I said, dig deeper, and identify the true concern. Only then will you have a good solution.
Sign In or Register to comment.