Issue with a 360 Lab - Layer 2 configuraton

amb1s1amb1s1 Member Posts: 408
OK, I'm using IOU so don't if this is a bug or what, but here my problem.

I'm trying to ping from Router 6 to switch 3 vlan, but it wont ping. Can you guys spot the problem?

R6 E0/0 Connect to Switch1 E1/1

R6
interface Ethernet0/0
no ip address
!
interface Ethernet0/0.40
encapsulation dot1Q 40
ip address 172.16.16.6 255.255.255.0
!
interface Ethernet0/0.300
encapsulation dot1Q 300
ip address 172.16.67.6 255.255.255.0

Switch 1
interface Ethernet1/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 40,300
switchport mode trunk
duplex auto
end

Switch 1 E2/3 Connect to Switch 3 E2/1


Switch 1
interface Ethernet2/3
switchport access vlan 300
switchport mode access
duplex auto
end

Switch 3

interface Ethernet2/1
switchport access vlan 300
switchport mode access
duplex auto
end

interface Vlan300
ip address 172.16.67.7 255.255.255.0
end
David G.
http://gomezd.com <
My Tshoot test Blog
http://twitter.com/ipnet255

Comments

  • Dieg0MDieg0M Member Posts: 861
    You need to use trunks to carry the VLAN tag between your 2 switches... This is not even a CCNP level question...
    Follow my CCDE journey at www.routingnull0.com
  • AwesomeGarrettAwesomeGarrett Member Posts: 257
    He should not need a trunk because the access ports are for vlan 300.

    It would be the equivalent of router on a stick but without using trunk ports and having a port on the router for every vlan.
  • ScalesScales Member Posts: 95 ■■□□□□□□□□
    Can you post the output of a show vlan, show ip int brief (with only the relevant ports and SVI's) from the switches?
  • amb1s1amb1s1 Member Posts: 408
    Dieg0M wrote: »
    You need to use trunks to carry the VLAN tag between your 2 switches... This is not even a CCNP level question...

    Like other say, no need of trunk. The reason why I posted here is because must of the people that use IOU are CCIE candidates and in my eyes the config looks good and I'm just looking if anybody encounter a bug on IOU.

    Here is my output:

    R6
    Ethernet0/0 unassigned YES unset up up
    Ethernet0/0.40 172.16.16.6 YES manual up up
    Ethernet0/0.300 172.16.67.6 YES manual up up

    SW1
    show vlan
    300 NET-300 active Et2/3

    show int trunk
    Port Vlans allowed on trunk
    Et1/1 40,300
    show ip int brie
    connection to R6
    Ethernet1/1 unassigned YES unset up up
    connection to Sw3
    Ethernet2/3 unassigned YES unset up up


    Sw3:

    sho vlan
    300 NET-300 active Et2/1

    show ip int brie
    connection to Sw1
    Ethernet2/1 unassigned YES unset up up

    Vlan300 172.16.67.7 YES manual up up
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • amb1s1amb1s1 Member Posts: 408
    I pretty sure it is a bug on IOU because I just downloaded GNS3 and did the same config and it is pinging on gns3.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • ScalesScales Member Posts: 95 ■■□□□□□□□□
    Probably an issue with IOU. the Show int trunk on Switch 1 says the vlan is allowed and not pruned yes?
  • AwesomeGarrettAwesomeGarrett Member Posts: 257
    Yeah, everything looks to be in order and I do not see a reason why it would not work. If you read some of the reviews for the Cisco360 they are not good. Mostly for being buggy.
  • AwesomeGarrettAwesomeGarrett Member Posts: 257
    Scales wrote: »
    Probably an issue with IOU. the Show int trunk on Switch 1 says the vlan is allowed and not pruned yes?


    It probably does, but you bring up a good point. If there for whatever reason VTP pruning enabled? That doesn't always work as intended.
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    My advise is to have afew IOU images in your setup file that you can toggle between as follows:

    IOS=${DIR}/bin/unix-advipservices-ms.151-2.9.S
    IOS1=${DIR}/bin/unix-adventerprisek9-ms.124-15.T9
    IOS2=${DIR}/bin/unix-adventerprisek9-ms.124-24.T4

    ${WRAPPER} -m ${IOS1} -p $dport -- -e ${ETH} -s ${SER} -n 1024 -m 128 $index &

    Then you can quickly switch between IOS versions and find out if its a bug.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • gorebrushgorebrush Member Posts: 2,743 ■■■■■■■□□□
    It's posts like these that confirm that IOU just isn't worth it.
  • Dieg0MDieg0M Member Posts: 861
    He should not need a trunk because the access ports are for vlan 300.

    It would be the equivalent of router on a stick but without using trunk ports and having a port on the router for every vlan.

    You are right he is only carrying one VLAN. I looked at this too quickly. Best practice would be to trunk on each port to carry both his vlan's (usually one of them a management VLAN). This should work and I don't think it would be a problem with VTP pruning since VTP packets are only transmitted over trunk ports.
    Follow my CCDE journey at www.routingnull0.com
  • amb1s1amb1s1 Member Posts: 408
    Dieg0M wrote: »
    You are right he is only carrying one VLAN. I looked at this too quickly. Best practice would be to trunk on each port to carry both his vlan's (usually one of them a management VLAN). This should work and I don't think it would be a problem with VTP pruning since VTP packets are only transmitted over trunk ports.

    The problem was that by default any port that the switchport encapsulation is not confgure manually will default to ISL and on IOU ISL is not supported. I manually made all the interface dot1q except for the port that the lab wants to be an access and everything started to work. About best practice remember that CCIE is not a best practice exams and if you think it is, you will fail.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • Dieg0MDieg0M Member Posts: 861
    But you did specify the encapsulation to dot1q. What am I missing here?
    Follow my CCDE journey at www.routingnull0.com
  • amb1s1amb1s1 Member Posts: 408
    Dieg0M wrote: »
    But you did specify the encapsulation to dot1q. What am I missing here?
    There were other interfaces to other switches.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • Dieg0MDieg0M Member Posts: 861
    Still don't understand, how did this fix the problem of the config you showed us?
    Follow my CCDE journey at www.routingnull0.com
  • amb1s1amb1s1 Member Posts: 408
    Dieg0M wrote: »
    Still don't understand, how did this fix the problem of the config you showed us?

    The configuration was OK, the problem was with a Bug on IOU. You do this configuration on a real hardware and you would not have any issues. Don't look at this as a config problem, instead a problem with IOU. IOU is a cisco emulator similar to GNS3 but a little bit more advance. My co-worker is going to give me his lab, so I won't have this type of issues.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • Dieg0MDieg0M Member Posts: 861
    I understand what IOU and GNS3 is but what do you mean by:
    amb1s1 wrote: »
    The problem was that by default any port that the switchport encapsulation is not confgure manually will default to ISL
    I understand this, but how did you fix your problem since the configuration you provided us has the encapsulation set to dot1q? Or did you not fix the problem using IOU?
    Follow my CCDE journey at www.routingnull0.com
  • AwesomeGarrettAwesomeGarrett Member Posts: 257
    Dieg0M wrote: »
    This should work and I don't think it would be a problem with VTP pruning since VTP packets are only transmitted over trunk ports.

    Good point.
  • amb1s1amb1s1 Member Posts: 408
    Dieg0M wrote: »
    I understand what IOU and GNS3 is but what do you mean by:
    I understand this, but how did you fix your problem since the configuration you provided us has the encapsulation set to dot1q? Or did you not fix the problem using IOU?
    The port from switch1 to router6 was dot1q and there were two connection to switch 3 one was access and the other was set to default(isl). After I change the second connection from the default to dot1q, I was able to ping.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • amb1s1amb1s1 Member Posts: 408
    There were two connection from switch 1 to 3
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • Dieg0MDieg0M Member Posts: 861
    The other link was not mentioned at all in the original post. So what you're saying is that one connection was in access mode and the other was trunked to the switch without any encapsulation type? Can you please provide the full config as I am trying to pinpoint the exact bug in IOU other than ISL not being supported.
    Follow my CCDE journey at www.routingnull0.com
  • amb1s1amb1s1 Member Posts: 408
    Dieg0M wrote: »
    The other link was not mentioned at all in the original post. So what you're saying is that one connection was in access mode and the other was trunked to the switch without any encapsulation type? Can you please provide the full config as I am trying to pinpoint the exact bug in IOU other than ISL not being supported.
    The exact bug is isl. You can use ISL and you are going to see the ISL trunk, but it does not work. There is nothing to pinpoint.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • Dieg0MDieg0M Member Posts: 861
    How is ISL the problem? The configuration you posted does not use ISL and should work but you say that "it wont ping".
    Follow my CCDE journey at www.routingnull0.com
  • amb1s1amb1s1 Member Posts: 408
    Did you read my previews post? Because I think we are running into a circle in here. I'm going to leave like this, I can't spend too much timer figure out why a bug is causing a problem. I'm going back to lab, I think we are wasting time figure the big problem.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • amb1s1amb1s1 Member Posts: 408
    A bug problem.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Thread synopsis,
    amb1s1 didn't know the difference between isl,dot1q,access and trunking.After discussion started he figured it out.
    Dieg0m aware amb1s1's short coming pounced on him, in defence amd1s1 decided to create a new topology to deflect the attack lol.

    Some iou images are terrible, ports stay down, some are up but dont sent traffic etc, once you find a working image happy days.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • amb1s1amb1s1 Member Posts: 408
    EdTheLad wrote: »
    Thread synopsis,
    amb1s1 didn't know the difference between isl,dot1q,access and trunking.After discussion started he figured it out.
    Dieg0m aware amb1s1's short coming pounced on him, in defence amd1s1 decided to create a new topology to deflect the attack lol.

    Some iou images are terrible, ports stay down, some are up but dont sent traffic etc, once you find a working image happy days.
    I did knew the difference between isl, dot1q and access port. I see it, I work on it and I design everyday. What I did not knew was that leaving the trunk as default will create issues on IOU.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • keenonkeenon Member Posts: 1,922 ■■■■□□□□□□
    IOU is buggy all around
    Become the stainless steel sharp knife in a drawer full of rusty spoons
Sign In or Register to comment.