Options

ROAS L2 Switch DG

Magic JohnsonMagic Johnson Member Posts: 414
3 VLANs (2,5,10) Defined on switch and subinterfaces on router. VLAN 2 native VLAN is applied on the physical int on the router, and is the only SVI up on the switch.

I have 2 PCs connected to the layer 2 switch, each in their own vlan (5+10 respectively).

I have set the DG of the switch to the IP of the physical interface on the router.

I can ping:

The two PCs from the router, but not the SVI on the switch
From the PCs I can ping the ip of the subinterfaces on the router of their VLAN but not the other PC or any other IPs

Basically I think I've got myself in one hell of a muddle and I'm not sure how close (or far away) I am from nailing this.

Router:

interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/0.10
encapsulation dot1q 5
ip address 172.16.5.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1q 10
ip address 172.16.6.1 255.255.255.0
!

172.16.0.0/24 is subnetted, 2 subnets
C 172.16.5.0 is directly connected, FastEthernet0/0.10
C 172.16.6.0 is directly connected, FastEthernet0/0.20
C 192.168.1.0 is directly connected, FastEthernet0/0
!

Switch:

interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport mode access
switchport access vlan 5
!
interface FastEthernet0/3
switchport mode access
switchport access vlan 10
!

interface Vlan 1
no ip address
no ip route-cache
!
interface Vlan0005
ip address 172.16.5.5 255.255.255.0
no ip route-cache
shutdown
!
interface Vlan0010
ip address 172.16.6.10 255.255.255.0
no ip route-cache
shutdown
!
interface Vlan0002
ip address 192.168.1.5 255.255.255.0
no ip route-cache
!

!
ip default-gateway 192.168.1.1
!

icon_sad.gif

Comments

  • Options
    Magic JohnsonMagic Johnson Member Posts: 414
    Oh MAN it was because I hadn't set the DGs on the PCs. ARGH. I didn't think I could because I could not for the life of me find any command using help that would do this in Boson netsim! Thanks to some trawling I found an ipconfig /dg X.X.X.X command and boom, we are working!

    Now, the only thing I can't ping from the PCs is the SVI of the switch...any ideas?
  • Options
    busines4ubusines4u Member Posts: 67 ■■□□□□□□□□
    interface Vlan0005
    ip address 172.16.5.5 255.255.255.0
    no ip route-cache
    shutdown
    !
    interface Vlan0010
    ip address 172.16.6.10 255.255.255.0
    no ip route-cache
    shutdown

    From the configuration you posted above it appears that both of these VLANS are shutdown. If you do a "show ip interface brief" what do those two interfaces show status wise? You need to issue the "no shutdown" command underneath both of the VLAN005 and VLAN0010 interfaces.
  • Options
    Magic JohnsonMagic Johnson Member Posts: 414
    busines4u wrote: »
    interface Vlan0005
    ip address 172.16.5.5 255.255.255.0
    no ip route-cache
    shutdown
    !
    interface Vlan0010
    ip address 172.16.6.10 255.255.255.0
    no ip route-cache
    shutdown

    From the configuration you posted above it appears that both of these VLANS are shutdown. If you do a "show ip interface brief" what do those two interfaces show status wise? You need to issue the "no shutdown" command underneath both of the VLAN005 and VLAN0010 interfaces.

    Hey, yeah everytime I enabled one the other would shut down, so I was like WHAT so Googled it, apparently the 2950 can only have one 'non-shutdown' VLAN for management purposes, the rest are 'shutdown' but still active.
  • Options
    busines4ubusines4u Member Posts: 67 ■■□□□□□□□□
    Yes that is correct. The 2950 is a Layer 2 switch and will cause the results you are seeing. You need a layer 3 switch in order to have multiple SVI's in the up/status. On Layer 2 switches the SVI that you enabled and assigned an IP address to is used to connect to for configuration/management.
  • Options
    Magic JohnsonMagic Johnson Member Posts: 414
    busines4u wrote: »
    Yes that is correct. The 2950 is a Layer 2 switch and will cause the results you are seeing. You need a layer 3 switch in order to have multiple SVI's in the up/status. On Layer 2 switches the SVI that you enabled and assigned an IP address to is used to connect to for configuration/management.

    Aye, learn by doing! :)

    So can you clarify for me, should I be able to ping that management SVI from the PCs?

    EDIT: Apart from that, I've just configured a pretty neat little lab with two ROAS, over a serial link and the pcs on all the different vlans either side can now talk to each other. :) Sweet! Next chapter; ospf!
Sign In or Register to comment.