Time for some more lab help!

Danielh22185Danielh22185 Member Posts: 1,195 ■■■■□□□□□□
So I'm plucking through the Simplified book for route and am making notes of things to come back and lab (might add I had I have picked up on many grammatical / typos in the book). Yet I really do enjoy the layout and the general explanations of the book. I just have a slight worry in the back of my head that the commands I am typing might not be correct from the example due to the number of errors I have found.

Anywho, I am working on a scenario explained in the book (page 328 if you have it)

Basically the objective is to filter R2 the ABR from sending specific routes / Summary LSAs from Area 0 (R1) routes to the remainder of the OSPF domain. Specifically the 192.168.1.1 and 192.168.1.3 networks. Well I have checked, re-checked, and triple checked my commands and can't seem to pinpoint why this is not working.

R3 appears to be still learning all the routes / summary LSAs from R1 (area 0) via R2 the ABR into Area 1.

Here are the configs and topology.


sh runBuilding configuration...


Current configuration : 1530 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 10
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
 ip address 192.168.2.1 255.255.255.0
!
interface Loopback3
 ip address 192.168.3.1 255.255.255.0
!
interface Loopback4
 ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.0.1 255.255.255.252
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.3 area 0
 network 192.168.0.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 0
 network 192.168.4.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

=============================================================

sh run
Building configuration...


Current configuration : 1438 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 10
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.0.0.2 255.255.255.252
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.0.0.5 255.255.255.252
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 0 filter-list prefix Deny-Odd-Only out
 network 10.0.0.0 0.0.0.3 area 0
 network 10.0.0.4 0.0.0.3 area 1
 distribute-list Filter-Odd-Subnets in Serial0/0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ip access-list standard Filter-Odd-Subnets
 deny   0.0.1.0 255.255.254.255
 permit any
!
!
ip prefix-list Deny-Odd-Only seq 5 deny 192.168.1.0/24
ip prefix-list Deny-Odd-Only seq 7 deny 192.168.3.0/24
ip prefix-list Deny-Odd-Only seq 9 permit 0.0.0.0/0 le 32
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

=========================================================================

R3#sh run
Building configuration...


Current configuration : 1040 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 10
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.0.0.6 255.255.255.252
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 10.0.0.4 0.0.0.3 area 1
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end






Currently Studying: IE Stuff...kinda...for now...
My ultimate career goal: To climb to the top of the computer network industry food chain.
"Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi

Comments

  • Danielh22185Danielh22185 Member Posts: 1,195 ■■■■□□□□□□
    Here are the LSDBs from R2 and R3 which should not have the odd numbered subnets:
    R2#sh ip ospf database
    
    
                OSPF Router with ID (2.2.2.2) (Process ID 1)
    
    
                    Router Link States (Area 0)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    1.1.1.1         1.1.1.1         1873        0x80000002 0x00A667 7
    2.2.2.2         2.2.2.2         1872        0x80000001 0x00CDAE 2
    
    
                    Summary Net Link States (Area 0)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.0.0.4        2.2.2.2         1868        0x80000001 0x0013D6
    
    
                    Router Link States (Area 1)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    2.2.2.2         2.2.2.2         1851        0x80000002 0x0092D9 2
    3.3.3.3         3.3.3.3         1852        0x80000001 0x003138 2
    
    
                    Summary Net Link States (Area 1)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.0.0.0        2.2.2.2         1868        0x80000001 0x003BB2
    192.168.0.1     2.2.2.2         1869        0x80000001 0x001E6B
    192.168.1.1     2.2.2.2         1869        0x80000001 0x001375
    192.168.2.1     2.2.2.2         1869        0x80000001 0x00087F
    192.168.3.1     2.2.2.2         1869        0x80000001 0x00FC89
    192.168.4.1     2.2.2.2         1869        0x80000001 0x00F193
    
    R3#sh ip ospf database
    
    
                OSPF Router with ID (3.3.3.3) (Process ID 1)
    
    
                    Router Link States (Area 1)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    2.2.2.2         2.2.2.2         1843        0x80000002 0x0092D9 2
    3.3.3.3         3.3.3.3         1842        0x80000001 0x003138 2
    
    
                    Summary Net Link States (Area 1)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.0.0.0        2.2.2.2         1859        0x80000001 0x003BB2
    192.168.0.1     2.2.2.2         1859        0x80000001 0x001E6B
    192.168.1.1     2.2.2.2         1859        0x80000001 0x001375
    192.168.2.1     2.2.2.2         1859        0x80000001 0x00087F
    192.168.3.1     2.2.2.2         1859        0x80000001 0x00FC89
    192.168.4.1     2.2.2.2         1859        0x80000001 0x00F193
    
    
    
    
    
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
  • AwesomeGarrettAwesomeGarrett Member Posts: 257
    You need to use the command ip ospf network point-to-point under the loopback interfaces. By default, the network type for the loopback interface is OSPF network type LOOPBACK, you can verify this by using the show ip ospf interface brief command. Because of this they are advertised as a /32 in the LSA and your filter will never match the LSA and filter the route.

    You can use secondary IP addresses under the fast Ethernet interfaces to avoid having to change the network type.
  • Danielh22185Danielh22185 Member Posts: 1,195 ■■■■□□□□□□
    You need to use the command ip ospf network point-to-point under the loopback interfaces. By default, the network type for the loopback interface is OSPF network type LOOPBACK, you can verify this by using the show ip ospf interface brief command. Because of this they are advertised as a /32 in the LSA and your filter will never match the LSA and filter the route.

    You can use secondary IP addresses under the fast Ethernet interfaces to avoid having to change the network type.


    Fantastic! I never thought to consider that, yet it is such a fundamental task icon_sad.gif I need to get more in the habit if I am going to simulate networks to go the entire route and make the ospf network types correct on the interfaces.

    Thanks AwesomeGarret that worked perfectly and solved my problem!
    R2# sh ip ospf database
    
    
                OSPF Router with ID (2.2.2.2) (Process ID 1)
    
    
                    Router Link States (Area 0)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    1.1.1.1         1.1.1.1         19          0x80000007 0x00F11C 7
    2.2.2.2         2.2.2.2         181         0x80000002 0x00CBAF 2
    
    
                    Summary Net Link States (Area 0)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.0.0.4        2.2.2.2         183         0x80000001 0x0013D6
    
    
                    Router Link States (Area 1)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    2.2.2.2         2.2.2.2         180         0x80000002 0x0092D9 2
    3.3.3.3         3.3.3.3         181         0x80000002 0x002F39 2
    
    
                    Summary Net Link States (Area 1)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.0.0.0        2.2.2.2         183         0x80000001 0x003BB2
    192.168.0.0     2.2.2.2         47          0x80000001 0x002862
    192.168.2.0     2.2.2.2         27          0x80000001 0x001276
    192.168.4.0     2.2.2.2         17          0x80000001 0x00FB8A
    
    
    
    
    R3#sh ip ospf database
    
    
                OSPF Router with ID (3.3.3.3) (Process ID 1)
    
    
                    Router Link States (Area 1)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    2.2.2.2         2.2.2.2         190         0x80000002 0x0092D9 2
    3.3.3.3         3.3.3.3         189         0x80000002 0x002F39 2
    
    
                    Summary Net Link States (Area 1)
    
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.0.0.0        2.2.2.2         193         0x80000001 0x003BB2
    192.168.0.0     2.2.2.2         56          0x80000001 0x002862
    192.168.2.0     2.2.2.2         36          0x80000001 0x001276
    192.168.4.0     2.2.2.2         26          0x80000001 0x00FB8A
    
    
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
Sign In or Register to comment.