Can't get PSTN Simulator to take calls

draughtdraught Member Posts: 229 ■■■■□□□□□□
Update: 911 is working now but I'm not getting sound which makes this a MoH issue now. I'll get a 10 second delay of no sound then the off-hook sound. Tells me I need to figure out how to get MoH working.

Comments

  • bobfromfplbobfromfpl Member Posts: 104
    Is your controller connection up? Multiple frames established?
  • draughtdraught Member Posts: 229 ■■■■□□□□□□
    I'm just going include the entire config as this is really confusing me as it's not music like I thought.

    Here is the PSTN simulator 911 tcl script

    proc init { } { global param
    set param(interruptPrompt) true
    set param(abortKey) *
    set param(terminationKey) #

    }

    proc act_Setup { } {
    global dest
    leg setupack leg_incoming
    leg proceeding leg_incoming
    leg connect leg_incoming

    media play leg_incoming flash:hq_911.au
    fsm setstate CALLDISCONNECTED
    }

    proc act_Cleanup { } {
    call close
    }

    init
    set callfsm(CALL,ev_setup_indication) "act_Setup,CALLDISCONNECTED"
    set callfsm(CALLDISCONNECTED,ev_disconnected) "act_Cleanup,same_state"

    set callfsm(CALLDISCONNECTED,ev_disconnected) "act_Cleanup,same_state"
    set callfsm(CALLDISCONNECTED,ev_media_done) "act_Cleanup,same_state"
    set callfsm(CALLDISCONNECTED,ev_disconnect_done) "act_Cleanup,same_state"
    set callfsm(CALLDISCONNECTED,ev_leg_timer) "act_Cleanup,same_state"

    fsm define callfsm CALL_INIT
    Here is the PSTN_Simulator running config
    no ipv6 cef!
    multilink bundle-name authenticated
    !
    isdn switch-type primary-ni
    !
    voice translation-rule 1
    rule 1 /^5552[^12]..$/ /1510&/
    rule 2 /^5105552[^12]..$/ /1&/
    !
    voice translation-profile TenDIGITS
    translate calling 1
    translate called 1
    !
    voice-card 0
    !
    application
    service us_900 flash:us_900.tcl
    !
    service intl flash:international.tcl
    !
    service info flash:info.tcl
    !
    service local flash:mrrogers.tcl
    !
    service ld flash:ld.tcl
    !
    service 911 flash:hq_911.tcl
    !
    !
    crypto pki token default removal timeout 0
    !
    license udi pid CISCO2811 sn FTX1146A0XX
    !
    redundancy
    !
    controller T1 0/0/0
    cablelength long 0db
    pri-group timeslots 1-6,24
    description PSTN
    !
    interface FastEthernet0/0
    ip address 10.10.0.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0/0:23
    description PSTN
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn protocol-emulate network
    isdn incoming-voice voice
    no cdp enable
    !
    interface Serial0/1/0
    no ip address
    shutdown
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    voice-port 0/0/0:23
    translation-profile incoming TenDIGITS
    !
    voice-port 0/2/0
    !
    voice-port 0/2/1
    !
    mgcp profile default
    !
    dial-peer voice 101 pots
    description 1+10 digits to Pod 1
    port 0/0/0:23
    prefix 51055521
    !
    dial-peer voice 102 pots
    destination-pattern 151055522..
    port 0/0/0:23
    prefix 5105552
    !
    dial-peer voice 800 pots
    service us_800
    incoming called-number 1800.......
    !
    dial-peer voice 855 pots
    service us-800
    incoming called-number 1855.......
    !
    dial-peer voice 866 pots
    service us_800
    incoming called-number 1866.......
    !
    dial-peer voice 877 pots
    service us_800
    incoming called-number 1877.......
    !
    dial-peer voice 888 pots
    service us_800
    incoming called-number 1888.......
    !
    dial-peer voice 900 pots
    service us_900
    incoming called-number 1900.......
    !
    dial-peer voice 411 pots
    service info
    incoming called-number [2-8]11
    !
    dial-peer voice 123 pots
    incoming called-number .
    direct-inward-dial
    !
    dial-peer voice 911 pots
    service 911
    incoming called-number 911
    !
    dial-peer voice 9100 pots
    service ld
    incoming called-number 1[2-4,6-9].......
    !
    dial-peer voice 9102 pots
    service ld
    incoming called-number 151[^0]........
    !
    dial-peer voice 9101 pots
    incoming called-number 151[^1]........
    !
    dial-peer voice 9103 pots
    service ld
    incoming called-number 15105[2-4,5-9]......
    !
    dial-peer voice 9104 pots
    service ld
    incoming called-number 15105[^5].....
    !
    dial-peer voice 9105 pots
    service ld
    incoming called-number 151055[^5]....
    !
    dial-peer voice 9106 pots
    service ld
    incoming called-number 15105552[^12]..
    !
    dial-peer voice 9107 pots
    service ld
    incoming called-number 15105555[^0]..
    !
    dial-peer voice 9108 pots
    service ld
    incoming called-number 151055550[^0-5]
    !
    dial-peer voice 9011 pots
    service intl
    incoming called-number 011.......
    !
    dial-peer voice 7 pots
    incoming called-number [2-9]......
    !
    telephony-service
    max-conferences 8 gain -6
    transfer-system full-consult
    !
    scheduler allocate 20000 1000
    end

    Here is rtrpod1's config
    boot-end-marker!
    card type t1 0 0
    enable secret 5 $1$XiXK$PFeYvd2yjgaIXQFpvngi81
    !
    no aaa new-model
    !
    resource policy
    !
    network-clock-participate wic 0
    !
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.0.1 10.10.0.10
    ip dhcp excluded-address 10.15.0.1 10.15.0.10
    !
    ip dhcp pool Data
    network 10.10.0.0 255.255.255.0
    default-router 10.10.0.1
    option 150 ip 10.10.0.1
    !
    ip dhcp pool Voice
    network 10.15.0.0 255.255.255.0
    default-router 10.15.0.1
    option 150 ip 10.15.0.1
    !
    no ip domain lookup
    !
    isdn switch-type primary-ni
    !
    voice-card 0
    no dspfarm
    !
    crypto pki token default removal timeout 0
    !
    username draught privilege 15 secret 5 $1$guoi$sYRf3Tf.qn0aRuS5d1TNx0
    !
    controller T1 0/0/0
    framing esf
    linecode b8zs
    pri-group timeslots 1-6,24
    !
    controller T1 0/0/1
    framing esf
    linecode b8zs
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.10
    description data vlan
    encapsulation dot1Q 10
    ip address 10.10.0.1 255.255.255.0
    !
    interface FastEthernet0/0.11
    description Management vlan
    encapsulation dot1Q 11
    ip address 10.11.0.1 255.255.255.0
    !
    interface FastEthernet0/0.15
    description data vlan
    encapsulation dot1Q 15
    ip address 10.15.0.1 255.255.255.0
    !
    interface FastEthernet0/1
    ip address 192.168.0.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/0/0:23
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn protocol-emulate network
    isdn incoming-voice voice
    no cdp enable
    !
    interface Serial0/3/0
    no ip address
    shutdown
    no fair-queue
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    !
    tftp-server phone/7940-7960/P00308010200.loads alias P00308010200.loads
    tftp-server phone/7940-7960/P00308010200.bin alias P00308010200.bin
    tftp-server phone/7940-7960/P00308010200.sb2 alias P00308010200.sb2
    tftp-server phone/7940-7960/P00308010200.sbn alias P00308010200.sbn
    !
    control-plane
    !
    voice-port 0/0/0:23
    !
    voice-port 0/2/0
    !
    voice-port 0/2/1
    !
    dial-peer voice 911 pots
    description Emergency Services
    destination-pattern 911
    port 0/0/0:23
    prefix 911
    !
    dial-peer voice 9911 pots
    destination-pattern 9911
    prefix 911
    !
    dial-peer voice 2000 voip
    destination-pattern 2000
    session target ipv4:192.168.0.1
    !
    dial-peer voice 2001 voip
    destination-pattern 200.
    session target ipv4:10.10.0.1
    !
    !
    dial-peer voice 1 pots
    destination-pattern 9T
    port 0/2/0
    gatekeeper
    shutdown
    !
    telephony-service
    no auto-reg-ephone
    load 7960-7940 P00308010200
    max-ephones 4
    max-dn 12
    ip source-address 10.10.0.1 port 2000
    max-conferences 8 gain -6
    transfer-system full-consult
    create cnf-files version-stamp 7960 Mar 01 2002 03:24:53
    !
    ephone-dn 1 dual-line
    number 2001
    label my button 2001
    description heading here
    !
    ephone-dn 2
    number 2002
    label button 2 2002
    !
    ephone 1
    device-security-mode none
    mac-address 0014.6AC3.D1FA
    type 7960
    button 1:1
    !
    ephone 2
    device-security-mode none
    mac-address 0007.0EC4.7280
    type 7960
    button 1:2
    !
    scheduler allocate 20000 1000
    ntp clock-period 17180010
    ntp server 192.168.0.1
    !
    end

    Thanks!
  • bobfromfplbobfromfpl Member Posts: 104
    Is the PSTN receiving the call?

    paste the output of show controller T1 0/0/0 on both devices
  • draughtdraught Member Posts: 229 ■■■■□□□□□□
    The PSTN is not receiving the call and I'm at loss to figure this out.

    Here's the show controller output for the PSTN simulator

    PSTN_Simulator#show controllers t1 0/0/0
    T1 0/0/0 is up.
    Applique type is Channelized T1
    Cablelength is long 0db
    Description: PSTN
    No alarms detected.
    alarm-trigger is not set
    Soaking time: 3, Clearance time: 10
    AIS State:Clear LOS State:Clear LOF State:Clear
    Version info Firmware: 20100222, FPGA: 13, spm_count = 0
    Framing is ESF, Line Code is B8ZS, Clock Source is Line.
    CRC Threshold is 320. Reported from firmware is 320.
    Data in current interval (104 seconds elapsed):
    0 Line Code Violations, 0 Path Code Violations
    6 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
    6 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

    Here's the RtrPod1 controller output

    RtrPod1#show controllers t1 0/0/0
    T1 0/0/0 is up.
    Applique type is Channelized T1
    Cablelength is long gain36 0db
    No alarms detected.
    alarm-trigger is not set
    Soaking time: 3, Clearance time: 10
    AIS State:Clear LOS State:Clear LOF State:Clear
    Version info Firmware: 20040802, FPGA: 13, spm_count = 0
    Framing is ESF, Line Code is B8ZS, Clock Source is Line.
    CRC Threshold is 320. Reported from firmware is 320.
    Data in current interval (243 seconds elapsed):
    4726 Line Code Violations, 35 Path Code Violations
    2 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins
    2 Errored Secs, 0 Bursty Err Secs, 1 Severely Err Secs, 165 Unavail Secs
  • shodownshodown Member Posts: 2,271
    can you do a debug isdn q931 from both devices a the same time, and do a debug voip ccapi inout from the same devices at each time.
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
  • draughtdraught Member Posts: 229 ■■■■□□□□□□
    I just tried the debug commands a moment ago.Thanks for the help, this is making me think I'm missing a configuration somewhere as the PSTN_Simulator is not getting calls. I'm also wondering about constant bad frame messages mean. Hope this helps.

    Debug commands on RtrPod1 below
    Mar 1 02:02:16.803: ISDN Se0/0/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME() <
    This same message REPEATS over and OVER.

    When call is made below:

    Mar 1 02:04:31.573: //-1/8103BC75800C/CCAPI/cc_api_call_setup_ind_common:
    Interface=0x488C39C4, Call Info(
    Calling Number=2001,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=(TON=Unknown, NPI=Unknown),
    Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE,
    Incoming Dial-peer=20001, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=TRUE,
    Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
    Mar 1 02:04:31.573: //-1/8103BC75800C/CCAPI/ccCheckClipClir:
    In: Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Mar 1 02:04:31.573: //-1/8103BC75800C/CCAPI/ccCheckClipClir:
    Out: Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Mar 1 02:04:31.573: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


    Mar 1 02:04:31.573: :cc_get_feature_vsa malloc success
    Mar 1 02:04:31.573: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


    Mar 1 02:04:31.573: cc_get_feature_vsa count is 1
    Mar 1 02:04:31.573: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


    Mar 1 02:04:31.573: :FEATURE_VSA attributes are: feature_name:0,fearture_time:1202452384,feature_id:5
    Mar 1 02:04:31.573: //5/8103BC75800C/CCAPI/cc_api_call_setup_ind_common:
    Set Up Event Sent;
    Call Info(Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=(TON=Unknown, NPI=Unknown))
    Mar 1 02:04:31.573: //5/8103BC75800C/CCAPI/cc_process_call_setup_ind:
    Event=0x482F9050
    Mar 1 02:04:31.577: //5/8103BC75800C/CCAPI/ccCallSetContext:
    Context=0x4684C750
    Mar 1 02:04:31.577: //5/8103BC75800C/CCAPI/cc_process_call_setup_ind:
    >>>>CCAPI handed cid 5 with tag 20001 to app "_ManagedAppProcess_Default"
    Mar 1 02:04:31.581: //5/8103BC75800C/CCAPI/ccCallSetupAck:
    Call Id=5
    Mar 1 02:04:31.581: //5/8103BC75800C/CCAPI/cc_api_set_transfer_info:
    Transfer Number=, Transfer Reason=0x0
    Mar 1 02:04:31.581: //5/8103BC75800C/CCAPI/ccGenerateToneInfo:
    Stop Tone On Digit=TRUE, Tone=Dial Tone,
    Tone Direction=Network, Params=0x0, Call Id=5
    Mar 1 02:04:31.585: //5/8103BC75800C/CCAPI/ccSetDigitTimeouts:
    Initial Digit Timeout=-1000(ms), Inter Digit Timeout=-1000(ms)
    Mar 1 02:04:31.585: //5/8103BC75800C/CCAPI/ccSetDigitTimeouts:
    Call Entry(Inter Digit Timeout=10000(ms), Initial Digit Timeout=10000(ms))
    Mar 1 02:04:31.585: //5/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
    (callID=0x5, digit_event=0x1, enable=TRUE, consume=FALSE)
    Mar 1 02:04:31.585: //5/8103BC75800C/CCAPI/ccCallReportDigits:
    Enabled=TRUE, Call Id=5
    Mar 1 02:04:31.585: //5/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
    (vdbPtr=0x488C39C4, callID=0x5, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)
    Mar 1 02:04:31.585: //5/8103BC75800C/CCAPI/cc_api_call_report_digits_done:
    Enabled=TRUE, Disposition=0x0, Interface=0x488C39C4, Call Id=5
    Mar 1 02:04:31.585: //5/8103BC75800C/CCAPI/cc_api_call_report_digits_done:
    Call Entry(Initial Digit Timeout=10000(ms), Inter Digit Timeout=10000(ms))
    Mar 1 02:04:31.813: ISDN Se0/0/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2
    Mar 1 02:04:32.089: //5/8103BC75800C/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=5, Digit=9, DigitBeginFlags=0x0,
    Rtp Timestamp=0x31128, Rtp Expiration=0x0
    Mar 1 02:04:32.089: //5/8103BC75800C/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=5, Digit=9, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Mar 1 02:04:32.089: //5/8103BC75800C/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Mar 1 02:04:32.189: //5/8103BC75800C/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=5, Digit=1, DigitBeginFlags=0x0,
    Rtp Timestamp=0x38E28, Rtp Expiration=0x0
    Mar 1 02:04:32.189: //5/8103BC75800C/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=5, Digit=1, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Mar 1 02:04:32.189: //5/8103BC75800C/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Mar 1 02:04:32.289: //5/8103BC75800C/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=5, Digit=1, DigitBeginFlags=0x0,
    Rtp Timestamp=0x40B28, Rtp Expiration=0x0
    Mar 1 02:04:32.289: //5/8103BC75800C/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=5, Digit=1, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Mar 1 02:04:32.289: //5/8103BC75800C/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()
    Mar 1 02:04:40.813: ISDN Se0/0/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2
    Mar 1 02:04:42.289: //5/8103BC75800C/CCAPI/cc_handle_inter_digit_timer:
    Generate inter-digit timeout CC_EV_CALL_DIGIT_END event
    Mar 1 02:04:42.289: //5/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
    (callID=0x5, digit_event=0x0, enable=FALSE, consume=FALSE)
    Mar 1 02:04:42.289: //5/8103BC75800C/CCAPI/ccCallReportDigits:
    Enabled=TRUE, Call Id=5
    Mar 1 02:04:42.289: //5/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
    (vdbPtr=0x488C39C4, callID=0x5, disp=0, digit_event=0x0, enable=FALSE, consume=FALSE)
    Mar 1 02:04:42.289: //5/8103BC75800C/CCAPI/cc_api_call_report_digits_done:
    Enabled=TRUE, Disposition=0x0, Interface=0x488C39C4, Call Id=5
    Mar 1 02:04:42.289: //5/8103BC75800C/CCAPI/cc_api_call_report_digits_done:
    Call Entry(Initial Digit Timeout=10000(ms), Inter Digit Timeout=10000(ms))
    Mar 1 02:04:42.289: //5/8103BC75800C/CCAPI/ccCallProceeding:
    Progress Indication=NULL(0)
    Mar 1 02:04:42.293: //5/8103BC75800C/CCAPI/ccCallSetupRequest:
    Destination=, Calling IE Present=TRUE, Mode=0,
    Outgoing Dial-peer=1, Params=0x4684D4F8, Progress Indication=ORIGINATING SIDE IS NON ISDN(3)
    Mar 1 02:04:42.293: //5/8103BC75800C/CCAPI/ccCheckClipClir:
    In: Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Mar 1 02:04:42.293: //5/8103BC75800C/CCAPI/ccCheckClipClir:
    Out: Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Mar 1 02:04:42.293: //5/8103BC75800C/CCAPI/ccCallSetupRequest:
    Destination Pattern=9T, Called Number=911, Digit Strip=TRUE
    Mar 1 02:04:42.293: //5/8103BC75800C/CCAPI/ccCallSetupRequest:
    Calling Number=2001(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=911(TON=Unknown, NPI=Unknown),
    Redirect Number=, Display Info=
    Account Number=, Final Destination Flag=FALSE,
    Guid=8103BC75-2BEF-11D6-800C-B8DE850375D7, Outgoing Dial-peer=1
    Mar 1 02:04:42.293: //5/8103BC75800C/CCAPI/cc_api_display_ie_subfields:
    ccCallSetupRequest:
    cisco-username=
    ccCallInfo IE subfields
    cisco-ani=2001
    cisco-anitype=0
    cisco-aniplan=0
    cisco-anipi=0
    cisco-anisi=0
    dest=911
    cisco-desttype=0
    cisco-destplan=0
    cisco-rdie=FFFFFFFF
    cisco-rdn=
    cisco-rdntype=0
    cisco-rdnplan=0
    cisco-rdnpi=0
    cisco-rdnsi=0
    cisco-redirectreason=0 fwd_final_type =0
    final_redirectNumber =
    hunt_group_timeout =0


    Mar 1 02:04:42.293: //5/8103BC75800C/CCAPI/ccIFCallSetupRequestPrivate:
    Interface=0x4830FCF4, Interface Type=6, Destination=, Mode=0x0,
    Call Params(Calling Number=2001,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=911(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
    Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE, Outgoing Dial-peer=1, Call Count On=FALSE,
    Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)
    Mar 1 02:04:42.297: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


    Mar 1 02:04:42.297: :cc_get_feature_vsa malloc success
    Mar 1 02:04:42.297: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


    Mar 1 02:04:42.297: cc_get_feature_vsa count is 2
    Mar 1 02:04:42.297: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


    Mar 1 02:04:42.297: :FEATURE_VSA attributes are: feature_name:0,fearture_time:1202452168,feature_id:6
    Mar 1 02:04:42.297: //6/8103BC75800C/CCAPI/ccIFCallSetupRequestPrivate:
    SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1
    Mar 1 02:04:42.297: //6/8103BC75800C/CCAPI/ccCallSetContext:
    Context=0x4684D4A8
    Mar 1 02:04:42.297: //5/8103BC75800C/CCAPI/ccSaveDialpeerTag:
    Outgoing Dial-peer=1
    Mar 1 02:04:42.301: //6/8103BC75800C/CCAPI/cc_api_call_proceeding:
    Interface=0x4830FCF4, Progress Indication=NULL(0)BAD FRAME()
    Mar 1 02:04:43.553: //6/8103BC75800C/CCAPI/cc_api_call_disconnected:
    Cause Value=34, Interface=0x4830FCF4, Call Id=6
    Mar 1 02:04:43.553: //6/8103BC75800C/CCAPI/cc_api_call_disconnected:
    Call Entry(Responsed=TRUE, Cause Value=34, Retry Count=0)
    Mar 1 02:04:43.553: //5/xxxxxxxxxxxx/CCAPI/ccCallReleaseResources:
    release reserved xcoding resource.
    Mar 1 02:04:43.553: //6/8103BC75800C/CCAPI/ccCallSetAAA_Accounting:
    Accounting=0, Call Id=6
    Mar 1 02:04:43.553: //6/8103BC75800C/CCAPI/ccCallDisconnect:
    Cause Value=34, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=34)
    Mar 1 02:04:43.553: //6/8103BC75800C/CCAPI/ccCallDisconnect:
    Cause Value=34, Call Entry(Responsed=TRUE, Cause Value=34)
    Mar 1 02:04:43.557: //6/8103BC75800C/CCAPI/cc_api_call_disconnect_done:
    Disposition=0, Interface=0x4830FCF4, Tag=0x0, Call Id=6,
    Call Entry(Disconnect Cause=34, Voice Class Cause Code=0, Retry Count=0)
    Mar 1 02:04:43.557: //6/8103BC75800C/CCAPI/cc_api_call_disconnect_done:
    Call Disconnect Event Sent
    Mar 1 02:04:43.557: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:


    Mar 1 02:04:43.557: :cc_free_feature_vsa freeing 47ABF6C0
    Mar 1 02:04:43.557: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:


    Mar 1 02:04:43.561: vsacount in free is 1
    Mar 1 02:04:43.561: //5/8103BC75800C/CCAPI/ccCallDisconnect:
    Cause Value=34, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
    Mar 1 02:04:43.561: //5/8103BC75800C/CCAPI/ccCallDisconnect:
    Cause Value=34, Call Entry(Responsed=TRUE, Cause Value=34)BAD FRAME()BAD FRAME()BAD FRAME()
    Mar 1 02:04:49.813: ISDN Se0/0/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2
    Mar 1 02:04:50.933: //5/8103BC75800C/CCAPI/cc_api_call_disconnect_done:
    Disposition=0, Interface=0x488C39C4, Tag=0x0, Call Id=5,
    Call Entry(Disconnect Cause=34, Voice Class Cause Code=0, Retry Count=0)
    Mar 1 02:04:50.933: //5/8103BC75800C/CCAPI/cc_api_call_disconnect_done:
    Call Disconnect Event Sent
    Mar 1 02:04:50.933: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:


    Mar 1 02:04:50.933: :cc_free_feature_vsa freeing 47ABF798
    Mar 1 02:04:50.933: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

    Debug commands on PSTN_Simulator below:

    *Feb 1 23:00:13.267: ISDN Se0/0/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()
    *Feb 1 23:00:22.267: ISDN Se0/0/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2BAD FRAME()BAD FRAME()BAD FRAME()BAD FRAME()
    No calls are registered on the PSTN.
  • shodownshodown Member Posts: 2,271
    Remove this from your HQ router and let me know what happens

    isdn protocol-emulate network
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
  • draughtdraught Member Posts: 229 ■■■■□□□□□□
    I removed the line and I'm still getting the same result sadly.
  • shodownshodown Member Posts: 2,271
    I will get you my PSTN configs tomorrow. I have to do quite a few things with the wife, but I'll get them up on the board.
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
  • draughtdraught Member Posts: 229 ■■■■□□□□□□
    Thanks that would be a big help!
  • bobfromfplbobfromfpl Member Posts: 104
    q931 won't work because I dont think you're establising a 921 connection yet. you had 4k+ line code violations on RtrPod1, can you check isdn status on both devices, also you may want to change clocking to you your PSTN Internal.
  • draughtdraught Member Posts: 229 ■■■■□□□□□□
    This loops when I use debug ISDN standard. No effect from calls.

    *Feb 2 15:29:08.155: ISDN Se0/0/0:23 EVENT: Pri_Activate_L2: sending NL_EST_REQ
    *Feb 2 15:29:12.155: ISDN Se0/0/0:23 Q931: Ux_DLRelInd: DL_REL_IND received from L2
    *Feb 2 15:29:12.155: ISDN Se0/0/0:23 EVENT: CCPRI_Go: received NL_REL_IND
    *Feb 2 15:29:17.155: ISDN Se0/0/0:23 EVENT: Pri_Activate_L2: sending NL_EST_REQ

    this is the error message for rtrpod1 I

    SDN Se0/0/0:23 **ERROR**: CCPCC_CallOrigination: SETUP timed-out (2nd T303) to NETWORK

    PSTN: *Feb 2 16:01:21.883: ISDN Se0/0/0:23 **ERROR**: L3_GetUser_NLCB: DUPLICATE SETUP, message ignored.*Feb 2 16:02:17.887: ISDN Se0/0/0:23 **ERROR**: CCPCC_TApplnAckExpiry: Application Ack Timer expired. b channel 6 cref 0x8081 call_id 0x0002
    *Feb 2 16:02:17.887: %ISDN-4-STATUS: Interface Se0/0/0:23 Application AckTimer expired. st 0x1407 ev 0x2 cid 0x8081 cref 0x2
    *Feb 2 16:02:17.887: %ISDN-6-DISCONNECT: Interface Serial0/0/0:5 disconnected from unknown , call lasted 0 seconds

    What area should I try to change the clocking example? I'm only familiar with basic CCNA setting serial clocking. Well I'm starting to seriously think it would be easier to connect an FX0 port my home phone line and skip the simulation part. Still bugs me I can't figure this out.
  • shodownshodown Member Posts: 2,271
    PSTN1#show run
    Building configuration...


    Current configuration : 13024 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname PSTN1
    !
    boot-start-marker
    boot-end-marker
    !
    card type e1 0 2
    enable secret 5 $1$A0xQ$rShWzGD9wyjeBAFJzgDdp0
    !
    aaa new-model
    !
    !
    !
    aaa session-id common
    network-clock-participate wic 0
    network-clock-participate wic 2
    network-clock-participate wic 3
    network-clock-select 1 E1 0/2/0
    !
    !
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.24.1
    ip dhcp excluded-address 192.168.24.2
    !
    ip dhcp pool phones
    network 192.168.24.0 255.255.255.0
    option 150 ip 192.168.1.10
    default-router 192.168.24.1
    !
    !
    no ip domain lookup
    ip domain name PSTN
    frame-relay switching
    isdn switch-type primary-net5
    !
    voice-card 0
    no dspfarm
    !
    !
    !
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    redirect ip2ip
    sip
    bind control source-interface GigabitEthernet0/0
    bind media source-interface GigabitEthernet0/0
    header-passing
    !
    !
    !
    voice class codec 1
    codec preference 1 g729r8
    codec preference 2 g711ulaw
    !
    !
    !
    !
    !
    !
    !
    !
    voice translation-rule 101
    rule 1 /^\+.*/ //
    rule 2 /^501.*/ //
    rule 3 /^1206.*/ //
    rule 4 /^00.*/ //
    rule 5 /^0011.*/ //
    rule 6 /^206/ /1206/
    rule 7 /^1512.*/ /\0/
    rule 8 /^011\(.*\)/ /\1/
    !
    voice translation-rule 102
    rule 1 /^1\(2065015111\)$/ /\1/ type any subscriber plan any isdn
    rule 2 /^1\(5126026222\)$/ /\1/ type any national plan any isdn
    rule 3 /^31207037333$/ /\0/ type any international plan any isdn
    rule 4 /^31107047444$/ /\0/ type any international plan any isdn
    rule 5 /^911$/ /&/ type any unknown plan any unknown
    rule 6 /^15126022.../ /\0/ type any unknown plan any unknown
    rule 7 /^31207033.../ /\0/ type any unknown plan any unknown
    rule 8 /^....$/ /\0/ type any unknown plan any unknown
    !
    voice translation-rule 103
    rule 1 /^206.*/ /\0/ type any subscriber plan any isdn
    rule 2 /^1/ // type any national plan any isdn
    rule 3 /^00/ // type any international plan any isdn
    !
    voice translation-rule 201
    rule 1 /^\+.*/ //
    rule 2 /^602.*/ //
    rule 3 /^1512.*/ //
    rule 4 /^00.*/ //
    rule 5 /^0011.*/ //
    rule 6 /^512/ /1512/
    rule 7 /^1206.*/ /\0/
    rule 8 /^011\(.*\)/ /\1/
    !
    voice translation-rule 202
    rule 1 /^1\(5126026222\)$/ /\1/ type any subscriber plan any isdn
    rule 2 /^1\(2065015111\)$/ /\1/ type any national plan any isdn
    rule 3 /^31207037333$/ /\0/ type any international plan any isdn
    rule 4 /^31107047444$/ /\0/ type any international plan any isdn
    rule 5 /^911$/ /&/ type any unknown plan any unknown
    rule 6 /^12065011.../ /\0/ type any unknown plan any unknown
    rule 7 /^31207033.../ /\0/ type any unknown plan any unknown
    rule 8 /^....$/ /\0/ type any unknown plan any unknown
    !
    voice translation-rule 203
    rule 1 /^512.*/ /\0/ type any subscriber plan any isdn
    rule 2 /^1/ // type any national plan any isdn
    rule 3 /^00/ // type any international plan any isdn
    !
    voice translation-rule 301
    rule 1 /^00\(12065015...\)/ /+\1/
    rule 2 /^00\(15126026...\)/ /+\1/
    rule 3 /^12065015.../ /+&/
    rule 4 /^15126026.../ /+&/
    rule 5 /^\+.*/ // type any unknown
    rule 6 /^20.*/ // type any unknown
    rule 7 /^020.*/ // type any unknown
    rule 8 /^011\(.*\)/ /+\1/ type any unknown
    rule 9 /^112$/ /911/ type any unknown
    rule 10 /^703..../ /+3120\0/ type any unknown
    rule 11 /^0\(10.*\)/ /+31\1/ type any unknown
    rule 12 /^00\(1.*\)/ /+\1/ type any unknown
    !
    voice translation-rule 302
    rule 1 /^31207037333$/ /7037333/ type any subscriber plan any isdn
    rule 2 /^7033\(...\)/ /0207033\1/
    rule 3 /^911$/ /112/ type any unknown plan any unknown
    rule 4 /^31\(107047444\)/ /0\1/ type any national plan any isdn
    rule 5 /^12065015111/ /\0/ type any international plan any isdn
    rule 6 /^15126026222/ /\0/ type any international plan any isdn
    rule 7 /^12065011.../ /\0/ type any unknown plan any unknown
    rule 8 /^15126022.../ /\0/ type any unknown plan any unknown
    rule 9 /^....$/ /\0/ type any unknown plan any unknown
    !
    voice translation-rule 303
    rule 1 /^703.*/ /\0/ type any subscriber plan any isdn
    rule 2 /^010/ // type any national plan any isdn
    rule 3 /^1/ // type any international plan any isdn
    !
    !
    voice translation-profile BR1-Proper-Types
    translate calling 202
    translate called 203
    !
    voice translation-profile BR1-manipulate-dnis-from
    translate called 201
    !
    voice translation-profile BR2-Proper-Types
    translate calling 302
    translate called 303
    !
    voice translation-profile BR2-manipulate-dnis-from
    translate called 301
    !
    voice translation-profile HQ-Proper-Types
    translate calling 102
    translate called 103
    !
    voice translation-profile HQ-manipulate-dnis-from
    translate called 101
    !
    !
    username cisco privilege 15 password 0 cisco
    !
    !
    controller T1 0/0/0
    framing esf
    clock source internal
    linecode b8zs
    pri-group timeslots 1-6,24
    !
    controller T1 0/0/1
    framing esf
    linecode b8zs
    pri-group timeslots 1-2,24
    !
    controller E1 0/2/0
    pri-group timeslots 1-3,16
    !
    controller E1 0/2/1
    clock source internal
    channel-group 0 timeslots 1-31
    description == Circuit to Capetown
    !
    controller T1 0/3/0
    framing esf
    clock source internal
    linecode b8zs
    cablelength short 133
    channel-group 0 timeslots 1-24
    description == Data Circuit to detroit
    !
    controller T1 0/3/1
    framing esf
    clock source internal
    linecode b8zs
    cablelength short 133
    channel-group 0 timeslots 1-24
    description == Data Circuit to CorpHQ
    !
    !
    !
    !
    interface GigabitEthernet0/0
    ip address 192.168.23.2 255.255.255.252
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1.1
    encapsulation dot1Q 24
    ip address 192.168.24.1 255.255.255.0
    !
    interface Serial0/0/0:23
    description BALTIMORE PRI
    no ip address
    encapsulation hdlc
    isdn switch-type primary-5ess
    isdn protocol-emulate network
    isdn incoming-voice voice
    isdn map address transparent
    isdn negotiate-bchan
    isdn outgoing ie display
    no cdp enable
    !
    interface Serial0/0/1:23
    description Detroit PRI
    no ip address
    encapsulation hdlc
    isdn switch-type primary-5ess
    isdn protocol-emulate network
    isdn incoming-voice voice
    isdn map address transparent
    isdn supp-service name calling
    isdn negotiate-bchan
    isdn outgoing ie display
    no cdp enable
    !
    interface Serial0/2/0:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn protocol-emulate network
    isdn incoming-voice voice
    isdn negotiate-bchan resend-setup
    no isdn outgoing ie network-facility
    isdn outgoing display-ie
    isdn outgoing ie redirecting-number
    no cdp enable
    !
    interface Serial0/2/1:0
    description frame relay circuit to Capetown
    no ip address
    encapsulation frame-relay IETF
    no fair-queue
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 102 interface Serial0/3/1:0 202
    !
    interface Serial0/3/0:0
    description FR to BR1
    no ip address
    encapsulation frame-relay IETF
    no fair-queue
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 101 interface Serial0/3/1:0 201
    !
    interface Serial0/3/1:0
    description FR to HQR
    no ip address
    encapsulation frame-relay IETF
    no fair-queue
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 201 interface Serial0/3/0:0 101
    frame-relay route 202 interface Serial0/2/1:0 102
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.168.23.1
    !
    no ip http server
    !
    !
    tftp-server flash:/apps41.8-4-1-23.sbn alias apps41.8-4-1-23.sbn
    tftp-server flash:/term41.default.loads alias term41.default.loads
    tftp-server flash:/cnu41.8-4-1-23.sbn alias cnu41.8-4-1-23.sbn
    tftp-server flash:/dsp41.8-4-1-23.sbn alias dsp41.8-4-1-23.sbn
    tftp-server flash:/jar41sccp.8-4-1-23.sbn alias jar41sccp.8-4-1-23.sbn
    tftp-server flash:SCCP41.8-4-2S.loads alias SCCP41.8-4-2S.loads
    !
    control-plane
    !
    !
    !
    voice-port 0/0/0:23
    translation-profile incoming HQ-manipulate-dnis-from
    description == Voice PRI to CorpHQ
    !
    voice-port 0/2/0:15
    translation-profile incoming BR2-manipulate-dnis-from
    description == Voice PRI to Branch2
    !
    voice-port 0/0/1:23
    translation-profile incoming BR1-manipulate-dnis-from
    description == Voice PRI to Branch1
    !
    !
    !
    !
    !
    dial-peer voice 1 pots
    description == All inbound calls from HQ BR1 BR2 into PSTN
    incoming called-number .
    direct-inward-dial
    !
    dial-peer voice 101 pots
    description == Subscriber Calls from PSTN into Baltimore
    translation-profile outgoing HQ-Proper-Types
    destination-pattern 2065011...
    direct-inward-dial
    port 0/0/0:23
    forward-digits 10
    !
    dial-peer voice 102 pots
    description == National Calls from PSTN into Baltimore
    translation-profile outgoing HQ-Proper-Types
    destination-pattern 12065011...
    direct-inward-dial
    port 0/0/0:23
    forward-digits 10
    !
    dial-peer voice 103 pots
    description == International Calls into Baltimore from PSTN Coming from NL P
    translation-profile outgoing HQ-Proper-Types
    destination-pattern 0012065011...
    direct-inward-dial
    port 0/0/0:23
    forward-digits 10
    !
    dial-peer voice 201 pots
    description == Subscriber Calls from PSTN into Detroit
    translation-profile outgoing BR1-Proper-Types
    destination-pattern 5126022...
    direct-inward-dial
    port 0/0/1:23
    forward-digits 10
    !
    dial-peer voice 202 pots
    description == National Calls from PSTN into Detroit
    translation-profile outgoing BR1-Proper-Types
    destination-pattern 15126022...
    direct-inward-dial
    port 0/0/1:23
    forward-digits 10
    !
    dial-peer voice 203 pots
    description == International Calls into Detroit from PSTN Coming from NL Pho
    translation-profile outgoing BR1-Proper-Types
    destination-pattern 0015126022...
    direct-inward-dial
    port 0/0/1:23
    forward-digits 10
    !
    dial-peer voice 301 pots
    description == Subscriber Calls from PSTN into Capetown
    translation-profile outgoing BR2-Proper-Types
    destination-pattern 7033...
    direct-inward-dial
    port 0/2/0:15
    forward-digits 7
    !
    dial-peer voice 302 pots
    description == National Calls from PSTN into Capetown
    translation-profile outgoing BR2-Proper-Types
    destination-pattern 0207033...
    direct-inward-dial
    port 0/2/0:15
    forward-digits 10
    !
    dial-peer voice 303 pots
    description == International Calls into Capetown from PSTN Coming from US Ph
    translation-profile outgoing BR2-Proper-Types
    destination-pattern 01131207033...
    direct-inward-dial
    port 0/2/0:15
    forward-digits 9
    prefix 0
    !
    dial-peer voice 304 pots
    description == International Calls into cape town from PSTN Coming from US P
    translation-profile outgoing BR2-Proper-Types
    destination-pattern 31207033...
    direct-inward-dial
    port 0/2/0:15
    forward-digits 9
    prefix 0
    !
    dial-peer voice 1001 voip
    description == SIP ITSP Calls from CUCM or CUCME
    voice-class codec 1
    session protocol sipv2
    incoming called-number .
    dtmf-relay sip-notify
    no vad
    !
    dial-peer terminator *
    no dial-peer outbound status-check pots
    num-exp 1800....... 911
    num-exp 1866....... 911
    num-exp 1877....... 911
    num-exp 1888....... 911
    num-exp 1900....... 911
    num-exp 1976....... 911
    num-exp 1777....... 911
    num-exp 1444....... 911
    num-exp 0800....... 911
    num-exp 0900....... 911
    !
    gatekeeper
    shutdown
    !
    !
    telephony-service
    load 7961 SCCP41.8-4-2S.loads
    max-ephones 20
    max-dn 20
    ip source-address 192.168.23.2 port 2000
    create cnf-files version-stamp Jan 01 2002 00:00:00
    dialplan-pattern 1 2023217... extension-length 4 extension-pattern 2...
    max-conferences 2 gain -6
    web admin system name cisco password cisco
    transfer-system full-consult
    !
    !
    ephone-dn 1 dual-line
    number 12065015111 secondary +12065015111
    label Seattle, US +1 206 501 5111
    description INE PSTN Phone
    name Seattle US Phone
    !
    !
    ephone-dn 2 dual-line
    number 15126026222 secondary +15126026222
    label Austin, US +1 512 602 6222
    name Austin TX Phone
    !
    !
    ephone-dn 3 dual-line
    number 31207037333 secondary +31207037333
    label Amsterdam, NL +31 20 703 73 33
    name Amsterdam NL Phone
    !
    !
    ephone-dn 4 dual-line
    number 31107047444 secondary +31107047444
    label Rotterdam, NL +31 10 704 74 44
    name Rotterdam NL Phone
    !
    !
    ephone-dn 5 dual-line
    number 12065015555 secondary +12065015555
    label JShephard Cell +1 206 501 5555
    name Jack Shephard Mobile
    !
    !
    ephone-dn 6 dual-line
    number 911 secondary 112
    label US/EU Emer/FreePhone/Prem
    name Emergency Services
    !
    !
    ephone-dn 7
    number 911 secondary 999
    label 911+999
    description PSTN Phone
    !
    !
    ephone-dn 8
    number 4082222020 secondary 2222020
    !
    !
    ephone-dn 9
    number 8593333030 secondary 3333030
    !
    !
    ephone-dn 10
    number 8144444040 secondary 44444040
    !
    !
    ephone-dn 11
    number 554455556666 secondary 011554455556666
    !
    !
    ephone 1
    !
    !
    !
    ephone 2
    mac-address 0000.0000.0015
    type CIPC
    button 1:1
    !
    !
    !
    ephone 5
    mac-address 0018.BAC8.D0F9
    type 7961
    !
    !
    !
    ephone 6
    mac-address 0018.BAC8.CA5E
    type 7961
    button 1:1 2:2 3:3 4:4 5:5 6:6
    !
    !
    !
    ephone 10
    mac-address 0018.BAC8.CFC2
    type 7961
    button 1:1
    !
    !
    !
    ephone 11
    mac-address 001B.D512.2D7B
    type 7961
    button 1:2
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    transport input telnet
    !
    scheduler allocate 20000 1000
    !
    end




    HQ router



    hostname Seattle
    !
    boot-start-marker
    boot system flash:c2801-ipvoice_ivs-mz.151-4.M6.bin
    boot-end-marker
    !
    !
    enable secret 5 $1$QFch$K2ID5xvn4OIy7GS2p.2mr1
    !
    aaa new-model
    !
    !
    !
    !
    !
    !
    !
    aaa session-id common
    network-clock-participate wic 2
    network-clock-select 1 T1 0/2/1
    ip source-route
    !
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.3.1
    ip dhcp excluded-address 192.168.3.1 192.168.3.2
    !
    ip dhcp pool phones
    network 192.168.3.0 255.255.255.0
    option 150 ip 192.168.2.20
    default-router 192.168.3.1
    dns-server 4.2.2.2
    !
    !
    ip cef
    no ip domain lookup
    ip domain name lab.com
    no ipv6 cef
    multilink bundle-name authenticated
    !
    !
    !
    isdn switch-type primary-ni
    !
    !
    !
    voice service voip
    h323
    session transport udp
    !
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g729r8
    !
    !
    !
    !
    voice translation-rule 1
    rule 1 /^....$/ /2025551000/
    !
    voice translation-rule 2
    rule 1 /562480..../ /1000/
    !
    voice translation-rule 10
    rule 1 /206501\(.*\)/ /\1/
    !
    voice translation-rule 11
    rule 1 /717231\(.*\)/ /\1/
    rule 2 /717943\(.*\)/ /\1/
    !
    !
    voice translation-profile INBOUND
    translate called 10
    !
    voice translation-profile National_Outbound
    translate calling 1
    !
    voice translation-profile inbound
    translate called 2
    !
    !
    voice-card 0
    !
    !
    !
    license udi pid CISCO2801 sn FTX1005Y1HK
    archive
    log config
    hidekeys
    username cisco privilege 15 password 0 cisco
    username terrencebattlehunt privilege 15 password 0 cisco
    !
    !
    controller T1 0/2/0
    shutdown
    clock source internal
    pri-group timeslots 1-3,24
    !
    controller T1 0/2/1
    cablelength short 133
    channel-group 0 timeslots 1-24
    description == Data Circuit to CorpHQ
    !
    !
    !
    !
    !
    !
    interface Loopback4
    ip address 192.168.4.1 255.255.255.255
    ip ospf 1 area 0
    h323-gateway voip interface
    h323-gateway voip bind srcaddr 192.168.4.1
    !
    interface FastEthernet0/0
    no ip address
    ip ospf 1 area 0
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.2
    encapsulation dot1Q 2
    ip address 192.168.2.1 255.255.255.0
    !
    interface FastEthernet0/0.3
    encapsulation dot1Q 3
    ip address 192.168.3.1 255.255.255.0
    !
    interface FastEthernet0/1
    bandwidth 1544
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/2/0:23
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn incoming-voice voice
    no cdp enable
    !
    interface Serial0/2/1:0
    no ip address
    encapsulation frame-relay IETF
    ip ospf 1 area 0
    no fair-queue
    frame-relay traffic-shaping
    frame-relay lmi-type ansi
    !
    interface Serial0/2/1:0.1 point-to-point
    bandwidth 1500
    ip address 10.10.33.1 255.255.255.128
    ip ospf mtu-ignore
    ip ospf 1 area 0
    snmp trap link-status
    frame-relay interface-dlci 201
    !
    interface Serial0/2/1:0.2 point-to-point
    bandwidth 1200
    ip address 10.10.33.129 255.255.255.128
    ip ospf mtu-ignore
    ip ospf 1 area 0
    snmp trap link-status
    frame-relay interface-dlci 202
    !
    router ospf 1
    network 0.0.0.0 255.255.255.255 area 0
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    ip route 0.0.0.0 0.0.0.0 192.168.2.2
    ip route 192.168.100.0 255.255.255.0 172.16.1.1
    !
    logging trap debugging
    disable-eadi
    !
    !
    tftp-server flash:/phone/7941-7961/SCCP41.8-3-3S.loads alias SCCP41.8-3-3S.loads
    tftp-server flash:/phone/7941-7961/jar41sccp.8-3-2-27.sbn alias jar41sccp.8-3-2-27.sbn
    tftp-server flash:/phone/7941-7961/dsp41.8-3-2-27.sbn alias dsp41.8-3-2-27.sbn
    tftp-server flash:/phone/7941-7961/cvm41sccp.8-3-2-27.sbn alias cvm41sccp.8-3-2-27.sbn
    tftp-server flash:/phone/7941-7961/cnu41.8-3-2-27.s alias cnu41.8-3-2-27.s
    tftp-server flash:/phone/7941-7961/apps41.8-3-2-27.sbn alias apps41.8-3-2-27.sbn
    tftp-server flash:/phone/7941-7961/term41.default.loads alias term41.default.loads
    tftp-server flash:/phone/7941-7961/term61.default.loads alias term61.default.loads
    !
    !
    control-plane
    !
    !
    voice-port 0/2/0:23
    !
    ccm-manager mgcp
    no ccm-manager fax protocol cisco
    ccm-manager music-on-hold
    ccm-manager config server 192.168.2.20
    !
    mgcp call-agent 192.168.2.20 service-type mgcp version 0.1
    mgcp rtp unreachable timeout 1000 action notify
    mgcp modem passthrough voip mode nse
    mgcp package-capability rtp-package
    mgcp package-capability sst-package
    mgcp package-capability pre-package
    no mgcp package-capability res-package
    no mgcp timer receive-rtcp
    mgcp sdp simple
    mgcp fax t38 inhibit
    !
    mgcp profile default
    !
    !
    dial-peer voice 1 pots
    incoming called-number .
    direct-inward-dial
    !
    dial-peer voice 1000 voip
    destination-pattern 1...
    session target ipv4:192.168.2.20
    !
    dial-peer voice 929 pots
    destination-pattern 91[2-9]..[2-9]......$
    !
    dial-peer voice 900 pots
    destination-pattern 1[2-9]..[2-9]......$
    prefix 1
    !
    dial-peer voice 800 pots
    destination-pattern [2-9]..[2-9]......$
    !
    dial-peer voice 801 pots
    destination-pattern 9[2-9]..[2-9]......$
    !
    dial-peer voice 911 pots
    destination-pattern 911
    forward-digits all
    !
    dial-peer voice 9011 pots
    destination-pattern 9011T
    prefix 011
    !
    dial-peer voice 11 pots
    destination-pattern 011T
    prefix 011
    !
    !
    !
    gatekeeper
    shutdown
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    password cisco
    transport input all
    !
    scheduler allocate 20000 1000
    ntp master 2
    ntp server 96.47.67.105
    end


    Seattle#
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
  • draughtdraught Member Posts: 229 ■■■■□□□□□□
    Thanks for the PSTN sample. I'm still having issues getting it to work, the problem this time is it get in reconfiguration loop. What I'm going to try next is to put the flash files for the phone on the PSTN as well. Otherwise my only other solution is to do the entire configuration from scratch. What was the address of the switch? 10.10.0.10? Thanks again though!
  • draughtdraught Member Posts: 229 ■■■■□□□□□□
    I restarted the lab and I'm trying this again from scratch and I still can't get anything from the PSTN simulator. I've followed instructions as best as possible but really the Cisco Press book needed an editor this should not be CCNP Voice level material. I will show my running config if needed again but the core problem is with the scripts themselves I'm willing to bet. Below is the basic one I use.
    proc init {} { global param
    set param(interruptPrompt) true
    set param(abortKey) *
    set param(terminationKey) #

    }


    proc act_Setup { } {
    global dest
    leg setupack leg_incoming
    leg proceeding leg_incoming
    leg connect leg_incoming
    media play leg_incoming flash:ld.au
    fsm setstate CALLDISCONNECTED
    }


    proc act_Cleanup { } {
    call close
    }


    init
    set callfsm(CALL,ev_setup_indication) "act_Setup,CALLDISCONNECTED"
    set callfsm(CALLDISCONNECTED,ev_disconnected) "act_Cleanup,same_state"


    set callfsm(CALLDISCONNECTED,ev_disconnected) "act_Cleanup,same_state"
    set callfsm(CALLDISCONNECTED,ev_media_done) "act_Cleanup,same_state"
    set callfsm(CALLDISCONNECTED,ev_disconnect_done) "act_Cleanup,same_state"
    set callfsm(CALLDISCONNECTED,ev_leg_timer) "act_Cleanup,same_state"


    fsm define callfsm CALL_INIT]

    If I can't get the Cisco Press lab book simulator to work what are my other options? I wish could just rent a T1 connection for a week but that would be extremely expensive. It's utterly ridiculous that a lab has been included in an official Cisco press lab book is so difficult. This is a lab I've yet to read of a single person compete and those who can understand/debug at all are CCNPs! Enough banging my head against this lab I guess back to reading icon_study.gif apologies for the small rant.Here are the config files as well:router.doc PSTN.doc


    I just don't see the error here. Besides the audio files I made sure were the correct format I'm not even getting a dial tone on 911 or anything perhaps that's a sign.
  • draughtdraught Member Posts: 229 ■■■■□□□□□□
    I ran a debug voip dialpeer command and got these interesting results. What I'm wondering is what exactly is stopping it from matching the digit. I have a 411 dialpeer right here below.

    dial-peer voice 411 pots
    service info
    incoming called-number [2-8]11.


    I'm supposed to be good at networking because I enjoy figuring this stuff out. Problem now is I lack time so I'll be skipping the working PSTN part of the voice lab as this could take weeks or who knows to figure out!

    *Feb 22 00:44:01.499: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
    Calling Number=5000, Called Number=411, Voice-Interface=0x4B431E38,
    Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,
    Peer Info Type=DIALPEER_INFO_SPEECH
    *Feb 22 00:44:01.499: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
    Match Rule=DP_MATCH_INCOMING_DNIS; Called Number=411
    *Feb 22 00:44:01.499: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
    Is Incoming=TRUE, Number Expansion=FALSE
    *Feb 22 00:44:01.499: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
    Dial String=411, Expanded String=411, Calling Number=
    Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
    *Feb 22 00:44:01.499: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    Result=Success(0); Incoming Dial-peer=411 Is Matched
    *Feb 22 00:44:01.499: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    Result=Success(0); Incoming Dial-peer=123 Is Matched
    *Feb 22 00:44:01.499: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5985
    PSTN(config)#
    *Feb 22 00:44:01.499: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
    Result=Success(0) after DP_MATCH_INCOMING_DNIS; Incoming Dial-peer=411
    *Feb 22 00:44:01.499: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
    dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
    *Feb 22 00:44:01.499: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerSPI:exit@6564
    *Feb 22 00:44:01.499: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
    Calling Number=5000, Called Number=411, Voice-Interface=0x0,
    Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,
    Peer Info Type=DIALPEER_INFO_FAX
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
    Match Rule=DP_MATCH_INCOMING_DNIS; Called Number=411
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
    Is Incoming=TRUE, Number Expansion=FALSE
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
    Dial String=411, Expanded String=411, Calling Number=
    Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_FAX
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=800,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=855,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=866,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=877,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=888,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=900,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=411,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=123,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=911,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9104,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9105,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9107,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9108,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9011,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=7,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=12911,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.503: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=5001,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
    Result=-1
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5985
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
    Match Rule=DP_MATCH_ANSWER; Calling Number=5000
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
    Is Incoming=TRUE, Number Expansion=FALSE
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
    Dial String=, Expanded String=, Calling Number=5000T
    Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_FAX
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=800,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=855,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=866,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=877,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=888,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=900,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=411,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=123,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=911,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9104,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9105,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9107,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9108,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9011,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=7,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=12911,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.507: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=5001,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
    Result=-1
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5985
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
    Match Rule=DP_MATCH_ORIGINATE; Calling Number=5000
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
    Is Incoming=TRUE, Number Expansion=FALSE
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
    Dial String=, Expanded String=, Calling Number=5000T
    Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_FAX
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=800,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=855,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=866,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=877,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=888,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=900,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=411,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=123,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=911,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9104,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9105,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9107,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9108,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=9011,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=7,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=12911,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
    OutboundSearch=FALSE, Peer Info Type=DIALPEER_INFO_FAX, Current Peer(Tag=5001,Peer Info Type=DIALPEER_INFO_SPEECH)
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
    Result=-1
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@5985
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
    Result=NO_MATCH(-1) After All Match Rules Attempt
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
    dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1
    *Feb 22 00:44:01.511: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerSPI:exit@6564
    *Feb 22 00:44:01.519: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
    Calling Number=, Called Number=411, Peer Info Type=DIALPEER_INFO_SPEECH
    *Feb 22 00:44:01.519: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
    Match Rule=DP_MATCH_DEST; Called Number=411
    *Feb 22 00:44:01.519: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
    Dial String=411, Expanded String=411, Calling Number=
    Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
    *Feb 22 00:44:01.519: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
    Result=-1
    *Feb 22 00:44:01.519: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
    No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)
    *Feb 22 00:44:01.519: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
    dialstring=411, saf_enabled=0, saf_dndb_lookup=1, dp_result=-1
    *Feb 22 00:44:01.519: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
    Result=NO_MATCH(-1)
  • shodownshodown Member Posts: 2,271
    The pattern you have doesn't match 911.
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
  • draughtdraught Member Posts: 229 ■■■■□□□□□□
    I was just using 411 as an example the issue is the same for any number I dial 911, 9911. I am however able to make calls between phones with extensions that I've set up, I just can't get this PSTN working.
Sign In or Register to comment.