Help Understanding Offset-Lists Better

Danielh22185Danielh22185 Member Posts: 1,195 ■■■■□□□□□□
I am playing around with off-set lists trying to understand how they operate a bit better. In my topology I am performing multi-point redistribution between ospf and eigrp. I am attempting to influence a route learned from OSPF to take a different path via an off-set list. What I found interesting is when I enter the command:

offset-list 1 in 100000 -- this command increments the metric of the network I am targeting with access-list 1. However it does NOT seem to influence the path.

Then when I enter the command:
offset-list 1 in 100000 fa0/0 (fa0/0) being the inbound interface receiving the redistributed OSPF routes, the off-set list works and the path is redirected to another router perform OSPF / EIGRP redistribution, as I wanted to.

My question is why is the path not influenced if I do NOT specify an inbound interface. I can clearly see the metric is incremented, however the path is unaffected.

Working Code:
R4#sh run
Building configuration...


Current configuration : 1096 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 10
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.0.9 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 ip address 10.0.0.5 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.0.0.2 255.255.255.252
!
router eigrp 1
 offset-list 1 in 1000000 FastEthernet0/0
 network 10.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 1 permit 1.1.1.1
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end



R4#sh ip route 1.1.1.1
Routing entry for 1.1.1.1/32
Known via "eigrp 1", distance 170, metric 286720, type external
Redistributing via eigrp 1
Last update from 10.0.0.6 on FastEthernet0/1, 00:02:14 ago
Routing Descriptor Blocks:
* 10.0.0.6, from 10.0.0.6, 00:02:14 ago, via FastEthernet0/1
Route metric is 286720, traffic share count is 1
Total delay is 1200 microseconds, minimum bandwidth is 10000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 2

R4#sh ip eigrp top
IP-EIGRP Topology Table for AS(1)/ID(10.0.0.9)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status


P 1.1.1.1/32, 1 successors, FD is 286720
via 10.0.0.6 (286720/284160), FastEthernet0/1
via 10.0.0.10 (1284160/281600), FastEthernet0/0

Non-Working (excluding fa0/0 as the specified interface to apply an offset list to)

[PHP]
R4#sh runBuilding configuration...
Current configuration : 1080 bytes!version 12.4service timestamps debug datetime msecservice timestamps log datetime msecno service password-encryption!hostname R4!boot-start-markerboot-end-marker!!no aaa new-modelmemory-size iomem 10ip cef!!!!no ip domain lookupip domain name lab.local!multilink bundle-name authenticated!!!!!!!!!!!!!!!!!!!!!archive log config hidekeys!!!!!!!!interface FastEthernet0/0 ip address 10.0.0.9 255.255.255.252 duplex auto speed auto!interface Serial0/0 no ip address shutdown!interface FastEthernet0/1 ip address 10.0.0.5 255.255.255.252 duplex auto speed auto!interface Serial0/1 ip address 10.0.0.2 255.255.255.252!router eigrp 1 offset-list 1 in 1000000 network 10.0.0.0 no auto-summary!ip forward-protocol nd!!no ip http serverno ip http secure-server!access-list 1 permit 1.1.1.1!!!!!control-plane!!!!!!!!!!line con 0 exec-timeout 0 0 privilege level 15 logging synchronousline aux 0 exec-timeout 0 0 privilege level 15 logging synchronousline vty 0 4 login!!end
[/PHP]

R4#sh ip route 1.1.1.1
Routing entry for 1.1.1.1/32
Known via "eigrp 1", distance 170, metric 1284160, type external
Redistributing via eigrp 1
Last update from 10.0.0.10 on FastEthernet0/0, 00:00:02 ago
Routing Descriptor Blocks:
* 10.0.0.10, from 10.0.0.10, 00:00:02 ago, via FastEthernet0/0
Route metric is 1284160, traffic share count is 1
Total delay is 40162 microseconds, minimum bandwidth is 10000 Kbit
Reliability 1/255, minimum MTU 1500 bytes
Loading 255/255, Hops 1


IP-EIGRP Topology Table for AS(1)/ID(10.0.0.9)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status


P 1.1.1.1/32, 1 successors, FD is 1284160
via 10.0.0.10 (1284160/281600), FastEthernet0/0
via 10.0.0.6 (1286720/284160), FastEthernet0/1





Thanks!
Currently Studying: IE Stuff...kinda...for now...
My ultimate career goal: To climb to the top of the computer network industry food chain.
"Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi

Comments

  • Danielh22185Danielh22185 Member Posts: 1,195 ■■■■□□□□□□
    screwed something up there...

    here is the config of when the offset list is applied without specifying the fa0/0 interface to apply it to:
    R4#sh runBuilding configuration...
    
    
    Current configuration : 1080 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R4
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 10
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip domain name lab.local
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    archive
     log config
      hidekeys
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
     ip address 10.0.0.9 255.255.255.252
     duplex auto
     speed auto
    !
    interface Serial0/0
     no ip address
     shutdown
    !
    interface FastEthernet0/1
     ip address 10.0.0.5 255.255.255.252
     duplex auto
     speed auto
    !
    interface Serial0/1
     ip address 10.0.0.2 255.255.255.252
    !
    router eigrp 1
     offset-list 1 in 1000000
     network 10.0.0.0
     no auto-summary
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    access-list 1 permit 1.1.1.1
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous
    line aux 0
     exec-timeout 0 0
     privilege level 15
     logging synchronous
    line vty 0 4
     login
    !
    !
    end
    
    
    
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
  • APAAPA Member Posts: 959
    It looks like it has worked in your last snippet.

    You don't specify a specific interface to pair the offset with. Therefore 'offset-list in' is 'offsetting' 1000000 to all eigrp interfaces in 10.0.0.0/8 where 1.1.1.1 is received. Therefore 10.0.0.10 is seen as the best next hop still due to the FD of 1284160.

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
  • Danielh22185Danielh22185 Member Posts: 1,195 ■■■■□□□□□□
    APA wrote: »
    It looks like it has worked in your last snippet.

    You don't specify a specific interface to pair the offset with. Therefore 'offset-list in' is 'offsetting' 1000000 to all eigrp interfaces in 10.0.0.0/8 where 1.1.1.1 is received. Therefore 10.0.0.10 is seen as the best next hop still due to the FD of 1284160.

    Ah ha! Thank you! That makes perfect sense why I would not see a path change then, essentially I am increasing all metric to that route.
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
  • APAAPA Member Posts: 959
    No problems :)

    Always helps to have another pair of eyes looks over the outputs.

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
Sign In or Register to comment.