A couple issues running CCP between GNS3 and a loopback

OfWolfAndManOfWolfAndMan Member Posts: 923 ■■■■□□□□□□
First thing: This only happens when I am running a topology of 3 routers. The one connecting the other two and the loopback has the "ntp master 3" command configured to provide ntp clock. However, when this is enabled, two problems occur: I can only discover the R2 (The one with ntp master 3 configured) sometimes. Also, I have OSPF configured between the two running fine, but sometimes the neighbor relationship between R1 and R2 then R2 and R3 expires because the hold timer expires. I disabled ntp master 3 and it works for now, but I still seem to be getting an error when trying to customize R2 after its discovered (Configuring logging in CCP). Here's the config:


R2#sr
Building configuration...

Current configuration : 3855 bytes
!
! Last configuration change at 18:39:19 UTC Wed Mar 26 2014
! NVRAM config last updated at 18:05:34 UTC Wed Mar 26 2014
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Uxk9$1Ku0UrKdX6ZGTW4ZXpvO00
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip domain name ccnasecurity.com
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-4279256517
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4279256517
revocation-check none
rsakeypair TP-self-signed-4279256517
!
!
crypto pki certificate chain TP-self-signed-4279256517
certificate self-signed 01
3082023A 308201A3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 34323739 32353635 3137301E 170D3134 30333236 31373539
34325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 32373932
35363531 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100A6E8 755B7CD5 5DD21EE8 D31D2E18 AA278ED9 2DF61D38 22ED6DDC 74ACFBAC
C3E37C37 96FE2CE0 9C9B99E7 5E1DD2AC D683E552 C562D029 2507E65F BE15CF41
CF7B6829 1EBF83DF 12E0B36D 66A3828B 9B22A3BF CC7C4BA6 676AE559 D6E27983
ABCF6DD7 21D1CF7F 65F4A941 0A151758 CB46C088 2DECE97A 0B083F61 112FD093
303B0203 010001A3 62306030 0F060355 1D130101 FF040530 030101FF 300D0603
551D1104 06300482 02523230 1F060355 1D230418 30168014 25A1687E 8CCE2F5D
0709AA3B 16EF50D7 1059C233 301D0603 551D0E04 16041425 A1687E8C CE2F5D07
09AA3B16 EF50D710 59C23330 0D06092A 864886F7 0D010104 05000381 81005CAC
AB644F90 B2CFF4A1 2282F8B8 C590311E ADF9C264 A471F0A3 A80511AE 2392F663
9D68ABEE 766A1EFF FB01B907 82531E59 9F659DBE 04212E52 0B1EF3C5 ED090DA1
917F0F67 CFE23697 3DB52EC2 C1FB73B7 DA381B1E 29CA849A C9375F75 A1561F75
268114BB 51C19230 FC3199C1 9A144B01 8FDD18A0 4F335D00 F32D286C 0B9A
quit
username anthony privilege 15 password 7 04612B0B2F2F1F1D4A4B5541
!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
interface Serial1/0
ip address 10.1.1.2 255.255.255.252
serial restart-delay 0
!
!
interface Serial1/1
ip address 10.2.2.2 255.255.255.252
serial restart-delay 0
clock rate 64000
!
!
interface Serial1/2
ip address 10.3.3.2 255.255.255.252
serial restart-delay 0
clock rate 64000
!
!
interface Serial1/3
ip address 10.4.4.2 255.255.255.252
serial restart-delay 0
!
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
!
router ospf 21
log-adjacency-changes
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 10.0.0.0 0.7.255.255 area 0
network 192.168.3.0 0.0.0.255 area 0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
shutdown
!
alias exec sr show run
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
exec-timeout 5 0
logging synchronous
login local
transport input ssh
line vty 5 15
no login
!
end

3.0 network is for the loopback and 10.0.0.0 is for the router links
:study:Reading: Lab Books, Ansible Documentation, Python Cookbook 2018 Goals: More Ansible/Python work for Automation, IPSpace Automation Course [X], Build Jenkins Framework for Network Automation []

Comments

  • OfWolfAndManOfWolfAndMan Member Posts: 923 ■■■■□□□□□□
    Also, this is the error I get when trying to configure the router in CCP:
    Missing required permissions manifest attributde in main jar: http://127.0.0.1:8600/Counterpoint/ssdm-cp-1.1.jar

    So I checked it out and it looks like a Java issue. Tinkering to see if I can fix it.
    :study:Reading: Lab Books, Ansible Documentation, Python Cookbook 2018 Goals: More Ansible/Python work for Automation, IPSpace Automation Course [X], Build Jenkins Framework for Network Automation []
  • OfWolfAndManOfWolfAndMan Member Posts: 923 ■■■■□□□□□□
    Looks like I figured it out :D Went to Control Panel -> Java -> Security Tab -> Edit Site List -> Added the loopback address. I'm still curious how setting stratum number on the router would cause it to lose OSPF adjacency though...
    :study:Reading: Lab Books, Ansible Documentation, Python Cookbook 2018 Goals: More Ansible/Python work for Automation, IPSpace Automation Course [X], Build Jenkins Framework for Network Automation []
Sign In or Register to comment.