Options

help with eBGP in Packet Tracer

tomislav91tomislav91 Member Posts: 59 ■■□□□□□□□□



I tried to do eBGP between "yellow" and "green" router. It pings each other.
This is codes. Networks are all in my big network. This is only a part, only a BGP part.
router bgp 65200
 bgp log-neighbor-changes
 no synchronization
 neighbor 213.108.31.13 remote-as 64600
 network 31.47.88.0 mask 255.255.248.0
 network 194.145.56.0 mask 255.255.248.0
 network 62.177.32.0 mask 255.255.224.0
 network 176.97.32.0 mask 255.255.224.0
network 195.242.184.0
!
ip classless
ip route 31.47.88.0 255.255.248.0 Null0 
ip route 194.145.56.0 255.255.248.0 Null0 
ip route 62.177.32.0 255.255.224.0 Null0 
ip route 176.97.32.0 255.255.224.0 Null0 
ip route 195.242.184.0 255.255.255.0 Null0
router bgp 64600
 bgp log-neighbor-changes
 no synchronization
 neighbor 213.108.31.14 remote-as 65200
 neighbor 81.161.114.0 remote-as 65500
 network 5.11.56.0 mask 255.255.248.0
 network 46.229.176.0 mask 255.255.240.0
 network 37.233.96.0 mask 255.255.240.0
 network 78.24.16.0 mask 255.255.248.0
network 213.108.31.0
!
ip classless
ip route 5.11.56.0 255.255.248.0 Null0 
ip route 46.229.176.0 255.255.240.0 Null0 
ip route 37.233.96.0 255.255.240.0 Null0 
ip route 78.24.16.0 255.255.248.0 Null0 
ip route 213.108.31.0 255.255.255.0 Null0 

Because of PT don't support iBGP, I must do redistribute BGP-OSPF. But don't have much experience in that. Where I put commands
router ospf 1

 router-id x.x.x.x

 redistribute bgp 65200 metric-type 1 metric 100 subnets
.
.
.

Only in AS65200 or where?

Comments

  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    I'd suggest rather than trying to piece unsupported features together in a simulator you get some real gear or GNS3 and practice it the right way.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    tomislav91tomislav91 Member Posts: 59 ■■□□□□□□□□
    I must do it in PT. I rather do in GNS3, but I must it in PT.
  • Options
    fredrikjjfredrikjj Member Posts: 879
    tomislav91 wrote: »
    I must do it in PT. I rather do in GNS3, but I must it in PT.

    So it's a project for school and now you want us to do it instead of you doing some research. Am I close? :)

    I'd suggest connecting both yellow and black to the lower of the green routers. That should make it a bit easier for you. Then redistribute what that BGP router learns into the internal protocol if packet tracer supports that. Use google to find a cisco configuration guide and then compare what it says to what PT has available.

    Use this process to verify that it's working:

    1. Check that the BGP sessions are up.
    2. Check that the BGP router is learning information from black and yellow.
    3. Verify that this information is being redistributed into the internal routing protocol.
    4. Do the same verifications in yellow/black.
    5. If step 1-4 looks good, use ping to verify reachability.

    PS.
    Those static routes to null0 are probably going to cause you problems so I would remove those right away and start over without them. Unless they are actual summaries and you know what you are doing and have more specific prefixes in the BGP router's routing tables.
  • Options
    tomislav91tomislav91 Member Posts: 59 ■■□□□□□□□□
    Router#sh ip bgp sum
    BGP router identifier 213.108.31.13, local AS number 64600
    BGP table version is 18, main routing table version 6
    10 network entries using 1320 bytes of memory
    10 path entries using 520 bytes of memory
    5/5 BGP path/bestpath attribute entries using 920 bytes of memory
    2 BGP AS-PATH entries using 48 bytes of memory
    0 BGP route-map cache entries using 0 bytes of memory
    0 BGP filter-list cache entries using 0 bytes of memory
    Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
    BGP using 2840 total bytes of memory
    BGP activity 10/0 prefixes, 10/0 paths, scan interval 60 secs
    
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    213.108.31.14   4 65200     120     106        18    0    0 00:41:48         4
    81.161.114.0    4 65500       0       0        18    0    0 01:51:46        4
    
    Router21>en
    Router21#sh ip bgp sum
    BGP router identifier 213.108.31.14, local AS number 65200
    BGP table version is 17, main routing table version 6
    10 network entries using 1320 bytes of memory
    10 path entries using 520 bytes of memory
    5/5 BGP path/bestpath attribute entries using 920 bytes of memory
    2 BGP AS-PATH entries using 48 bytes of memory
    0 BGP route-map cache entries using 0 bytes of memory
    0 BGP filter-list cache entries using 0 bytes of memory
    Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
    BGP using 2840 total bytes of memory
    BGP activity 10/0 prefixes, 10/0 paths, scan interval 60 secs
    
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    213.108.31.13   4 64600     115     109        17    0    0 00:42:31        4
    

    I do according to this https://supportforums.cisco.com/document/71756/redistributing-internal-bgp-routes-ospf redistributing, but PC10 didn't ping PC12, unreachable error and request timed out.

    What can be problem?

  • Options
    tomislav91tomislav91 Member Posts: 59 ■■□□□□□□□□
    Down it will shows sh run command and I didn't paste all, only important pieces.
    traceroute from PC 10 to PC 12.
    PC>tracert 37.233.104.10
    
    Tracing route to 37.233.104.10 over a maximum of 30 hops: 
    
      1   109 ms    1 ms      29 ms     5.11.56.1
      2   0 ms      46 ms     0 ms      213.108.31.17
      3   *         *         *         Request timed out.
      4   *         *         *         Request timed out.
      5   *         *         *         Request timed out.
    
    That is a router 11, you can see in picture, and there is his conf
    Router11>en
    Router11#sh run
    
    interface FastEthernet0/0
     ip address 213.108.31.17 255.255.255.248
     duplex auto
     speed auto
     ipv6 address 2001:1B38:13:2::/64 eui-64
     ipv6 enable
     ipv6 ospf 1 area 0
    !
    interface FastEthernet0/1
     ip address 213.108.31.1 255.255.255.252
     duplex auto
     speed auto
     ipv6 address 2001:1B38:11:1::/64 eui-64
     ipv6 enable
     ipv6 ospf 1 area 0
    !
    interface Vlan1
     no ip address
     shutdown
    !
    router ospf 1
     router-id 1.1.1.11
     log-adjacency-changes
     redistribute connected subnets 
     network 213.108.31.16 0.0.0.7 area 0
     network 213.108.31.0 0.0.0.3 area 0
    !
    ipv6 router ospf 1
     router-id 1.1.1.11
     log-adjacency-changes
    !
    ip classless
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
     login
    !
    !
    !
    end
    

    It's OK for me. Don't know why here stops.


    Why there stops? It seems that router that need to redistribute it, not working well. If you can see in picture, next hop is BGP router.
    Router#sh run
    !
    
    interface FastEthernet1/1
     ip address 213.108.31.13 255.255.255.252
     duplex auto
     speed auto
     ipv6 address 2001:4C28:5:1::/64 eui-64
     ipv6 enable
    
    router ospf 1
     router-id 1.1.1.10
     log-adjacency-changes
     redistribute bgp 64600 metric 100 metric-type 1 subnets 
     network 213.108.31.0 0.0.0.3 area 0
     network 213.108.31.4 0.0.0.3 area 0
    !
    router bgp 64600
     bgp log-neighbor-changes
     bgp redistribute-internal
     no synchronization
     neighbor 213.108.31.14 remote-as 65200
     neighbor 81.161.114.0 remote-as 65500
     network 5.11.56.0 mask 255.255.248.0
     network 46.229.176.0 mask 255.255.240.0
     network 37.233.96.0 mask 255.255.240.0
     network 78.24.16.0 mask 255.255.248.0
     network 213.108.31.0
    !
    ipv6 router ospf 1
     router-id 1.1.1.10
     log-adjacency-changes
     redistribute connected subnets 
    !
    ip classless
    ip route 5.11.56.0 255.255.248.0 Null0 
    ip route 46.229.176.0 255.255.240.0 Null0 
    ip route 37.233.96.0 255.255.240.0 Null0 
    ip route 78.24.16.0 255.255.248.0 Null0 
    ip route 213.108.31.0 255.255.255.0 Null0 
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
     login
    !
    !
    !
    end
    

    But ping 213.108.31.1, not .2, Why then stops at 213.108.31.17, and not in 213.108.31.1
    PC>ping 213.108.31.1
    
    Pinging 213.108.31.1 with 32 bytes of data:
    
    Reply from 213.108.31.1: bytes=32 time=157ms TTL=254
    Reply from 213.108.31.1: bytes=32 time=0ms TTL=254
    Reply from 213.108.31.1: bytes=32 time=53ms TTL=254
    Reply from 213.108.31.1: bytes=32 time=124ms TTL=254
    
    Ping statistics for 213.108.31.1:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 157ms, Average = 83ms
    
    PC>ping 213.108.31.2
    
    Pinging 213.108.31.2 with 32 bytes of data:
    
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    
  • Options
    tomislav91tomislav91 Member Posts: 59 ■■□□□□□□□□
    i solve problem.
    I just want to ask, Can you tell me, if I have BGP network, do I must in that interfaces configure OSPFv3?(if doing ospf in my networking), or BGP stay standalone?
    I ask, because, when I was finish, all PCs ping all PCs, but routers doesn't. Only in their AS.
    Must I do OSPFv3 on interfaces where is BGP?
  • Options
    fredrikjjfredrikjj Member Posts: 879
    Inside the AS, the routers are reachable through OSPF. Outside the AS, the routers and their links (often called 'transit links') won't be reachable unless you advertise them into BGP.
  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    Usually your router links will be IP'ed out of a larger block that is advertised to the internet.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    tomislav91tomislav91 Member Posts: 59 ■■□□□□□□□□
    fredrikjj wrote: »
    Inside the AS, the routers are reachable through OSPF. Outside the AS, the routers and their links (often called 'transit links') won't be reachable unless you advertise them into BGP.

    How to advertuse them into BGP? I did redistribution BGP-OSPF because I can't use iBGP in PT
  • Options
    fredrikjjfredrikjj Member Posts: 879
    Are you trolling us dude? :D
  • Options
    tomislav91tomislav91 Member Posts: 59 ■■□□□□□□□□
    Why?
    I just some help.
    Does anyone has expierence in PT here?
Sign In or Register to comment.