Trying to setup BSR for multicast

OfWolfAndManOfWolfAndMan ■■□□□□□□□□ Posts: 923Member ■■□□□□□□□□
The problem I am having is the IOSs I have in GNS3 do not support PIMv2 (Which is needed to setup BSR). Anyone know a good image? Also, I want to make sure the image supports IGMPv3 as well (For configuring SSM).
:study:Reading: Lab Books, Ansible Documentation, Python Cookbook 2018 Goals: More Ansible/Python work for Automation, IPSpace Automation Course [X], Build Jenkins Framework for Network Automation []

Comments

  • reaper81reaper81 Posts: 631Member
    I'm suprised that you even found an image that doesn't have it. It's been around for ages since 12.2. Any 12.4+ image would be good enough. It depends on if you want to practice on 12.4 or 15.x.
    Daniel Dib
    CCIE #37149
  • lrblrb Posts: 526Member
    Daniel is right, BSR has been around for a long time now so any recent image should be fine.

    I just ran up a small GNS3 setup to see if it worked with my 2691 image.
    R2#show ver | inc IOS
    Cisco IOS Software, 2600 Software (C2691-ADVIPSERVICESK9-M), Version 12.4(15)T6, RELEASE SOFTWARE (fc2)
    
    R2(config)#ip multicast-routing
    
    R2(config)#int range l0 , fa0/0
    R2(config-if-range)#ip pim sparse-mode
    
    R2(config)#ip pim bsr-candidate l0
    R2(config)#ip pim rp-candidate l0
    
    R2#show ip pim bsr-router
    PIMv2 Bootstrap information
    This system is the Bootstrap Router (BSR)
      BSR address: 2.2.2.2 (?)
      Uptime:      00:00:10, BSR Priority: 0, Hash mask length: 0
      Next bootstrap message in 00:00:50
      Candidate RP: 2.2.2.2(Loopback0)
        Holdtime 150 seconds
        Advertisement interval 60 seconds
        Next advertisement in 00:00:53
    

    Seems to work okay with that IOS release.
  • OfWolfAndManOfWolfAndMan ■■□□□□□□□□ Posts: 923Member ■■□□□□□□□□
    Guess I just got unlucky initially. I was using a 3640 12.4 jk9s image. The error message I got when trying to configure #ip pim bsr-candidate lo0 command was Warning: PIMv2 not configured on Loopback0, BSR message not originated. I soon came to realize that I did enable sparse mode on every outgoing interface with the exception of the loopback. Small mistake.
    :study:Reading: Lab Books, Ansible Documentation, Python Cookbook 2018 Goals: More Ansible/Python work for Automation, IPSpace Automation Course [X], Build Jenkins Framework for Network Automation []
Sign In or Register to comment.